diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2009-09-16 23:09:44 +0100 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2009-09-17 22:24:36 +0100 |
commit | af85ce4b4e675feb5796f87137c86d70c2f15b9a (patch) | |
tree | f19dbb9bcf1eec671b26685458f7cc47ebb3721e /meta/packages/gcc | |
parent | 046ae6a38d829048663fe1afb1f67de1fbe2e3b5 (diff) | |
download | poky-af85ce4b4e675feb5796f87137c86d70c2f15b9a.tar.gz |
Remove layout_* variables
Remove layout_* variables and replace them with variables specific to the
different classes. The layout variables were only useful for the native/cross
classes and caused more confusion than they solved. They didn't scale to the
sdk class. It now clear a small set of native/cross variables fulfil the needs.
This patch also changes native.bbclass to use "/" as the STAGING_DIR which makes
sense since we're installing binaries into the locations we're compiling them for.
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/gcc')
-rw-r--r-- | meta/packages/gcc/gcc-configure-cross.inc | 8 | ||||
-rw-r--r-- | meta/packages/gcc/gcc-configure-sdk.inc | 4 | ||||
-rw-r--r-- | meta/packages/gcc/gcc-configure-target.inc | 2 | ||||
-rw-r--r-- | meta/packages/gcc/gcc-cross-initial.inc | 2 | ||||
-rw-r--r-- | meta/packages/gcc/gcc-cross-intermediate.inc | 2 | ||||
-rw-r--r-- | meta/packages/gcc/gcc-cross-sdk_4.1.2.bb | 2 | ||||
-rw-r--r-- | meta/packages/gcc/gcc-cross-sdk_4.2.3.bb | 2 | ||||
-rw-r--r-- | meta/packages/gcc/gcc-cross-sdk_4.3.1.bb | 2 | ||||
-rw-r--r-- | meta/packages/gcc/gcc-cross-sdk_4.3.3.bb | 2 | ||||
-rw-r--r-- | meta/packages/gcc/gcc-cross.inc | 1 | ||||
-rw-r--r-- | meta/packages/gcc/gcc-cross_4.1.2.bb | 4 | ||||
-rw-r--r-- | meta/packages/gcc/gcc-cross_4.2.3.bb | 4 | ||||
-rw-r--r-- | meta/packages/gcc/gcc-cross_4.3.1.bb | 4 | ||||
-rw-r--r-- | meta/packages/gcc/gcc-cross_4.3.2.bb | 4 | ||||
-rw-r--r-- | meta/packages/gcc/gcc-cross_4.3.3.bb | 4 | ||||
-rw-r--r-- | meta/packages/gcc/gcc-cross_csl-arm-2007q3.bb | 8 | ||||
-rw-r--r-- | meta/packages/gcc/gcc-cross_csl-arm-2008q1.bb | 8 | ||||
-rw-r--r-- | meta/packages/gcc/gcc-native.inc | 2 |
18 files changed, 33 insertions, 32 deletions
diff --git a/meta/packages/gcc/gcc-configure-cross.inc b/meta/packages/gcc/gcc-configure-cross.inc index 5befaa8c67..8a47a45bc9 100644 --- a/meta/packages/gcc/gcc-configure-cross.inc +++ b/meta/packages/gcc/gcc-configure-cross.inc | |||
@@ -2,8 +2,8 @@ require gcc-configure-common.inc | |||
2 | 2 | ||
3 | USE_NLS = '${@base_conditional( "TARGET_OS", "linux-uclibc", "no", "", d )}' | 3 | USE_NLS = '${@base_conditional( "TARGET_OS", "linux-uclibc", "no", "", d )}' |
4 | 4 | ||
5 | EXTRA_OECONF_PATHS = "--with-local-prefix=${STAGING_DIR_TARGET}${layout_prefix} \ | 5 | EXTRA_OECONF_PATHS = "--with-local-prefix=${STAGING_DIR_TARGET}${target_prefix} \ |
6 | --with-gxx-include-dir=${STAGING_DIR_TARGET}/${layout_includedir}/c++ \ | 6 | --with-gxx-include-dir=${STAGING_DIR_TARGET}/${target_includedir}/c++ \ |
7 | --with-sysroot=${STAGING_DIR_TARGET} \ | 7 | --with-sysroot=${STAGING_DIR_TARGET} \ |
8 | --with-build-sysroot=${STAGING_DIR_TARGET}" | 8 | --with-build-sysroot=${STAGING_DIR_TARGET}" |
9 | 9 | ||
@@ -31,8 +31,8 @@ do_stage_append () { | |||
31 | rmdir ${CROSS_DIR}/include || : | 31 | rmdir ${CROSS_DIR}/include || : |
32 | 32 | ||
33 | # Move libssp into staging | 33 | # Move libssp into staging |
34 | install -d ${STAGING_DIR_TARGET}${layout_base_libdir}/ | 34 | install -d ${STAGING_DIR_TARGET}${target_base_libdir}/ |
35 | mv ${CROSS_DIR}/${TARGET_SYS}/lib/libssp* ${STAGING_DIR_TARGET}${layout_base_libdir}/ || true | 35 | mv ${CROSS_DIR}/${TARGET_SYS}/lib/libssp* ${STAGING_DIR_TARGET}${target_base_libdir}/ || true |
36 | 36 | ||
37 | # We don't really need to keep this around | 37 | # We don't really need to keep this around |
38 | # rm -rf ${CROSS_DIR}/share but leave java there | 38 | # rm -rf ${CROSS_DIR}/share but leave java there |
diff --git a/meta/packages/gcc/gcc-configure-sdk.inc b/meta/packages/gcc/gcc-configure-sdk.inc index ddaa041ee9..c04b93e568 100644 --- a/meta/packages/gcc/gcc-configure-sdk.inc +++ b/meta/packages/gcc/gcc-configure-sdk.inc | |||
@@ -4,8 +4,8 @@ require gcc-configure-common.inc | |||
4 | USE_NLS = '${@base_conditional( "TARGET_OS", "linux-uclibc", "no", "", d )}' | 4 | USE_NLS = '${@base_conditional( "TARGET_OS", "linux-uclibc", "no", "", d )}' |
5 | USE_NLS = '${@base_conditional( "TARGET_OS", "linux-uclibcgnueabi", "no", "", d )}' | 5 | USE_NLS = '${@base_conditional( "TARGET_OS", "linux-uclibcgnueabi", "no", "", d )}' |
6 | 6 | ||
7 | EXTRA_OECONF_PATHS = "--with-local-prefix=${STAGING_DIR_TARGET}${layout_prefix} \ | 7 | EXTRA_OECONF_PATHS = "--with-local-prefix=${STAGING_DIR_TARGET}${target_prefix} \ |
8 | --with-gxx-include-dir=${prefix}/${TARGET_SYS}${layout_includedir}/c++/${BINV}/ \ | 8 | --with-gxx-include-dir=${prefix}/${TARGET_SYS}${target_includedir}/c++/${BINV}/ \ |
9 | --with-sysroot=${prefix}/${TARGET_SYS} \ | 9 | --with-sysroot=${prefix}/${TARGET_SYS} \ |
10 | --with-build-sysroot=${STAGING_DIR_TARGET}" | 10 | --with-build-sysroot=${STAGING_DIR_TARGET}" |
11 | 11 | ||
diff --git a/meta/packages/gcc/gcc-configure-target.inc b/meta/packages/gcc/gcc-configure-target.inc index a3e274522c..44d6136240 100644 --- a/meta/packages/gcc/gcc-configure-target.inc +++ b/meta/packages/gcc/gcc-configure-target.inc | |||
@@ -1,6 +1,6 @@ | |||
1 | require gcc-configure-common.inc | 1 | require gcc-configure-common.inc |
2 | 2 | ||
3 | EXTRA_OECONF_PATHS = " \ | 3 | EXTRA_OECONF_PATHS = " \ |
4 | --with-local-prefix=${STAGING_DIR_TARGET}${layout_prefix} \ | 4 | --with-local-prefix=${STAGING_DIR_TARGET}${prefix} \ |
5 | --with-gxx-include-dir=${includedir}/c++/${BINV}/" | 5 | --with-gxx-include-dir=${includedir}/c++/${BINV}/" |
6 | 6 | ||
diff --git a/meta/packages/gcc/gcc-cross-initial.inc b/meta/packages/gcc/gcc-cross-initial.inc index 15e5fa62fc..a2c4445578 100644 --- a/meta/packages/gcc/gcc-cross-initial.inc +++ b/meta/packages/gcc/gcc-cross-initial.inc | |||
@@ -4,7 +4,7 @@ PACKAGES = "" | |||
4 | 4 | ||
5 | # This is intended to be a -very- basic config | 5 | # This is intended to be a -very- basic config |
6 | # sysroot is needed in case we use libc-initial | 6 | # sysroot is needed in case we use libc-initial |
7 | EXTRA_OECONF = "--with-local-prefix=${STAGING_DIR_TARGET}${layout_prefix} \ | 7 | EXTRA_OECONF = "--with-local-prefix=${STAGING_DIR_TARGET}${target_prefix} \ |
8 | --with-newlib \ | 8 | --with-newlib \ |
9 | --without-headers \ | 9 | --without-headers \ |
10 | --disable-shared \ | 10 | --disable-shared \ |
diff --git a/meta/packages/gcc/gcc-cross-intermediate.inc b/meta/packages/gcc/gcc-cross-intermediate.inc index 4fa12886f1..57fa949485 100644 --- a/meta/packages/gcc/gcc-cross-intermediate.inc +++ b/meta/packages/gcc/gcc-cross-intermediate.inc | |||
@@ -5,7 +5,7 @@ PACKAGES = "" | |||
5 | 5 | ||
6 | # This is intended to be a -very- basic config | 6 | # This is intended to be a -very- basic config |
7 | # sysroot is needed in case we use libc-initial | 7 | # sysroot is needed in case we use libc-initial |
8 | EXTRA_OECONF = "--with-local-prefix=${STAGING_DIR_TARGET}${layout_prefix} \ | 8 | EXTRA_OECONF = "--with-local-prefix=${STAGING_DIR_TARGET}${target_prefix} \ |
9 | --enable-shared \ | 9 | --enable-shared \ |
10 | --disable-multilib \ | 10 | --disable-multilib \ |
11 | --disable-threads \ | 11 | --disable-threads \ |
diff --git a/meta/packages/gcc/gcc-cross-sdk_4.1.2.bb b/meta/packages/gcc/gcc-cross-sdk_4.1.2.bb index 616a5831d0..83f0ec865b 100644 --- a/meta/packages/gcc/gcc-cross-sdk_4.1.2.bb +++ b/meta/packages/gcc/gcc-cross-sdk_4.1.2.bb | |||
@@ -7,4 +7,4 @@ require gcc-package-sdk.inc | |||
7 | 7 | ||
8 | DEPENDS += "gmp-native mpfr-native" | 8 | DEPENDS += "gmp-native mpfr-native" |
9 | 9 | ||
10 | EXTRA_OECONF += "--disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${layout_exec_prefix}" | 10 | EXTRA_OECONF += "--disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native}" |
diff --git a/meta/packages/gcc/gcc-cross-sdk_4.2.3.bb b/meta/packages/gcc/gcc-cross-sdk_4.2.3.bb index 7e3a459ea8..8cca9f8f06 100644 --- a/meta/packages/gcc/gcc-cross-sdk_4.2.3.bb +++ b/meta/packages/gcc/gcc-cross-sdk_4.2.3.bb | |||
@@ -11,4 +11,4 @@ DEPENDS += "gmp-native mpfr-native" | |||
11 | 11 | ||
12 | EXTRA_OECONF += "--disable-libunwind-exceptions --disable-libssp \ | 12 | EXTRA_OECONF += "--disable-libunwind-exceptions --disable-libssp \ |
13 | --disable-libgomp --disable-libmudflap \ | 13 | --disable-libgomp --disable-libmudflap \ |
14 | --with-mpfr=${STAGING_DIR_NATIVE}${layout_exec_prefix}" | 14 | --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native}" |
diff --git a/meta/packages/gcc/gcc-cross-sdk_4.3.1.bb b/meta/packages/gcc/gcc-cross-sdk_4.3.1.bb index 9562b43fdc..94a95de407 100644 --- a/meta/packages/gcc/gcc-cross-sdk_4.3.1.bb +++ b/meta/packages/gcc/gcc-cross-sdk_4.3.1.bb | |||
@@ -11,7 +11,7 @@ DEPENDS += "gmp-sdk mpfr-sdk" | |||
11 | 11 | ||
12 | EXTRA_OECONF += "--disable-libunwind-exceptions --disable-libssp \ | 12 | EXTRA_OECONF += "--disable-libunwind-exceptions --disable-libssp \ |
13 | --disable-libgomp --disable-libmudflap \ | 13 | --disable-libgomp --disable-libmudflap \ |
14 | --with-mpfr=${STAGING_DIR_NATIVE}${layout_exec_prefix}" | 14 | --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native}" |
15 | 15 | ||
16 | # to find libmpfr | 16 | # to find libmpfr |
17 | export LD_LIBRARY_PATH = "${STAGING_LIBDIR}" | 17 | export LD_LIBRARY_PATH = "${STAGING_LIBDIR}" |
diff --git a/meta/packages/gcc/gcc-cross-sdk_4.3.3.bb b/meta/packages/gcc/gcc-cross-sdk_4.3.3.bb index 9562b43fdc..65df556e8c 100644 --- a/meta/packages/gcc/gcc-cross-sdk_4.3.3.bb +++ b/meta/packages/gcc/gcc-cross-sdk_4.3.3.bb | |||
@@ -11,7 +11,7 @@ DEPENDS += "gmp-sdk mpfr-sdk" | |||
11 | 11 | ||
12 | EXTRA_OECONF += "--disable-libunwind-exceptions --disable-libssp \ | 12 | EXTRA_OECONF += "--disable-libunwind-exceptions --disable-libssp \ |
13 | --disable-libgomp --disable-libmudflap \ | 13 | --disable-libgomp --disable-libmudflap \ |
14 | --with-mpfr=${STAGING_DIR_NATIVE}${layout_exec_prefix}" | 14 | --with-mpfr=${STAGING_DIR_NATIVE}${native_prefix}" |
15 | 15 | ||
16 | # to find libmpfr | 16 | # to find libmpfr |
17 | export LD_LIBRARY_PATH = "${STAGING_LIBDIR}" | 17 | export LD_LIBRARY_PATH = "${STAGING_LIBDIR}" |
diff --git a/meta/packages/gcc/gcc-cross.inc b/meta/packages/gcc/gcc-cross.inc index 3fa6f61f0d..3485824b8a 100644 --- a/meta/packages/gcc/gcc-cross.inc +++ b/meta/packages/gcc/gcc-cross.inc | |||
@@ -5,6 +5,7 @@ | |||
5 | target_libdir := "${libdir}" | 5 | target_libdir := "${libdir}" |
6 | target_includedir := "${includedir}" | 6 | target_includedir := "${includedir}" |
7 | target_base_libdir := "${base_libdir}" | 7 | target_base_libdir := "${base_libdir}" |
8 | target_prefix := "${prefix}" | ||
8 | 9 | ||
9 | inherit cross | 10 | inherit cross |
10 | 11 | ||
diff --git a/meta/packages/gcc/gcc-cross_4.1.2.bb b/meta/packages/gcc/gcc-cross_4.1.2.bb index c9e3279ffc..d37ca6653c 100644 --- a/meta/packages/gcc/gcc-cross_4.1.2.bb +++ b/meta/packages/gcc/gcc-cross_4.1.2.bb | |||
@@ -9,6 +9,6 @@ SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 " | |||
9 | 9 | ||
10 | EXTRA_OECONF_append_avr32= " --disable-libmudflap " | 10 | EXTRA_OECONF_append_avr32= " --disable-libmudflap " |
11 | 11 | ||
12 | EXTRA_OECONF += "--disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${layout_exec_prefix}" | 12 | EXTRA_OECONF += "--disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native}" |
13 | 13 | ||
14 | ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${layout_includedir}" | 14 | ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${target_includedir}" |
diff --git a/meta/packages/gcc/gcc-cross_4.2.3.bb b/meta/packages/gcc/gcc-cross_4.2.3.bb index 72f72835c3..22efffa539 100644 --- a/meta/packages/gcc/gcc-cross_4.2.3.bb +++ b/meta/packages/gcc/gcc-cross_4.2.3.bb | |||
@@ -7,6 +7,6 @@ require gcc-package-cross.inc | |||
7 | 7 | ||
8 | SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 " | 8 | SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 " |
9 | 9 | ||
10 | EXTRA_OECONF += "--disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${layout_exec_prefix}" | 10 | EXTRA_OECONF += "--disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native}" |
11 | 11 | ||
12 | ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${layout_includedir}" | 12 | ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${target_includedir}" |
diff --git a/meta/packages/gcc/gcc-cross_4.3.1.bb b/meta/packages/gcc/gcc-cross_4.3.1.bb index 11e04594fc..84bee6baf3 100644 --- a/meta/packages/gcc/gcc-cross_4.3.1.bb +++ b/meta/packages/gcc/gcc-cross_4.3.1.bb | |||
@@ -7,6 +7,6 @@ require gcc-package-cross.inc | |||
7 | 7 | ||
8 | SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 " | 8 | SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 " |
9 | 9 | ||
10 | EXTRA_OECONF += "--disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${layout_exec_prefix}" | 10 | EXTRA_OECONF += "--disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native}" |
11 | 11 | ||
12 | ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${layout_includedir}" | 12 | ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${target_includedir}" |
diff --git a/meta/packages/gcc/gcc-cross_4.3.2.bb b/meta/packages/gcc/gcc-cross_4.3.2.bb index 11e04594fc..84bee6baf3 100644 --- a/meta/packages/gcc/gcc-cross_4.3.2.bb +++ b/meta/packages/gcc/gcc-cross_4.3.2.bb | |||
@@ -7,6 +7,6 @@ require gcc-package-cross.inc | |||
7 | 7 | ||
8 | SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 " | 8 | SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 " |
9 | 9 | ||
10 | EXTRA_OECONF += "--disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${layout_exec_prefix}" | 10 | EXTRA_OECONF += "--disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native}" |
11 | 11 | ||
12 | ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${layout_includedir}" | 12 | ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${target_includedir}" |
diff --git a/meta/packages/gcc/gcc-cross_4.3.3.bb b/meta/packages/gcc/gcc-cross_4.3.3.bb index 11e04594fc..84bee6baf3 100644 --- a/meta/packages/gcc/gcc-cross_4.3.3.bb +++ b/meta/packages/gcc/gcc-cross_4.3.3.bb | |||
@@ -7,6 +7,6 @@ require gcc-package-cross.inc | |||
7 | 7 | ||
8 | SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 " | 8 | SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 " |
9 | 9 | ||
10 | EXTRA_OECONF += "--disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${layout_exec_prefix}" | 10 | EXTRA_OECONF += "--disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native}" |
11 | 11 | ||
12 | ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${layout_includedir}" | 12 | ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${target_includedir}" |
diff --git a/meta/packages/gcc/gcc-cross_csl-arm-2007q3.bb b/meta/packages/gcc/gcc-cross_csl-arm-2007q3.bb index 4fde67b006..b00bebc5c0 100644 --- a/meta/packages/gcc/gcc-cross_csl-arm-2007q3.bb +++ b/meta/packages/gcc/gcc-cross_csl-arm-2007q3.bb | |||
@@ -7,7 +7,7 @@ require gcc-package-cross.inc | |||
7 | 7 | ||
8 | SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 " | 8 | SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 " |
9 | 9 | ||
10 | EXTRA_OECONF += "--disable-multilib --disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${layout_exec_prefix}" | 10 | EXTRA_OECONF += "--disable-multilib --disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native}" |
11 | 11 | ||
12 | #We don't want i686 linux ending up in the CFLAGS_FOR_TARGET like this: -isystem/OE/angstrom-tmp/staging/i686-linux/usr/include | 12 | #We don't want i686 linux ending up in the CFLAGS_FOR_TARGET like this: -isystem/OE/angstrom-tmp/staging/i686-linux/usr/include |
13 | CFLAGS = "" | 13 | CFLAGS = "" |
@@ -16,11 +16,11 @@ LDFLAGS = "" | |||
16 | 16 | ||
17 | # staging-linkage and cross-linkage recipes don't work anymore, so do it by hand for this backwards CSL toolchain | 17 | # staging-linkage and cross-linkage recipes don't work anymore, so do it by hand for this backwards CSL toolchain |
18 | do_compile_prepend() { | 18 | do_compile_prepend() { |
19 | ln -sf ${STAGING_DIR_TARGET}${layout_libdir}/crt*.o ${CROSS_DIR}/${TARGET_SYS}/lib/ | 19 | ln -sf ${STAGING_DIR_TARGET}${target_libdir}/crt*.o ${CROSS_DIR}/${TARGET_SYS}/lib/ |
20 | ln -sf ${STAGING_DIR_TARGET}${layout_libdir}/ld-* ${CROSS_DIR}/${TARGET_SYS}/lib/ | 20 | ln -sf ${STAGING_DIR_TARGET}${target_libdir}/ld-* ${CROSS_DIR}/${TARGET_SYS}/lib/ |
21 | ln -sf ${STAGING_DIR_TARGET}/lib/libc* ${CROSS_DIR}/${TARGET_SYS}/lib/ | 21 | ln -sf ${STAGING_DIR_TARGET}/lib/libc* ${CROSS_DIR}/${TARGET_SYS}/lib/ |
22 | sed -i -e 's:gcc_no_link=yes:gcc_no_link=no:' ${S}/libstdc++-v3/configure | 22 | sed -i -e 's:gcc_no_link=yes:gcc_no_link=no:' ${S}/libstdc++-v3/configure |
23 | 23 | ||
24 | } | 24 | } |
25 | 25 | ||
26 | ARCH_FLAGS_FOR_TARGET += " -L${STAGING_DIR_TARGET}${layout_libdir} -isystem${STAGING_DIR_TARGET}${layout_includedir}" | 26 | ARCH_FLAGS_FOR_TARGET += " -L${STAGING_DIR_TARGET}${target_libdir} -isystem${STAGING_DIR_TARGET}${target_includedir}" |
diff --git a/meta/packages/gcc/gcc-cross_csl-arm-2008q1.bb b/meta/packages/gcc/gcc-cross_csl-arm-2008q1.bb index 01b5bdacc4..a1581c2aa1 100644 --- a/meta/packages/gcc/gcc-cross_csl-arm-2008q1.bb +++ b/meta/packages/gcc/gcc-cross_csl-arm-2008q1.bb | |||
@@ -7,7 +7,7 @@ require gcc-package-cross.inc | |||
7 | 7 | ||
8 | SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 " | 8 | SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 " |
9 | 9 | ||
10 | EXTRA_OECONF += "--disable-multilib --disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${layout_exec_prefix}" | 10 | EXTRA_OECONF += "--disable-multilib --disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native}" |
11 | 11 | ||
12 | #We don't want i686 linux ending up in the CFLAGS_FOR_TARGET like this: -isystem/OE/angstrom-tmp/staging/i686-linux/usr/include | 12 | #We don't want i686 linux ending up in the CFLAGS_FOR_TARGET like this: -isystem/OE/angstrom-tmp/staging/i686-linux/usr/include |
13 | CFLAGS = "" | 13 | CFLAGS = "" |
@@ -16,11 +16,11 @@ LDFLAGS = "" | |||
16 | 16 | ||
17 | # staging-linkage and cross-linkage recipes don't work anymore, so do it by hand for this backwards CSL toolchain | 17 | # staging-linkage and cross-linkage recipes don't work anymore, so do it by hand for this backwards CSL toolchain |
18 | do_compile_prepend() { | 18 | do_compile_prepend() { |
19 | ln -sf ${STAGING_DIR_TARGET}${layout_libdir}/crt*.o ${CROSS_DIR}/${TARGET_SYS}/lib/ | 19 | ln -sf ${STAGING_DIR_TARGET}${target_libdir}/crt*.o ${CROSS_DIR}/${TARGET_SYS}/lib/ |
20 | ln -sf ${STAGING_DIR_TARGET}${layout_libdir}/ld-* ${CROSS_DIR}/${TARGET_SYS}/lib/ | 20 | ln -sf ${STAGING_DIR_TARGET}${target_libdir}/ld-* ${CROSS_DIR}/${TARGET_SYS}/lib/ |
21 | ln -sf ${STAGING_DIR_TARGET}/lib/libc* ${CROSS_DIR}/${TARGET_SYS}/lib/ | 21 | ln -sf ${STAGING_DIR_TARGET}/lib/libc* ${CROSS_DIR}/${TARGET_SYS}/lib/ |
22 | sed -i -e 's:gcc_no_link=yes:gcc_no_link=no:' ${S}/libstdc++-v3/configure | 22 | sed -i -e 's:gcc_no_link=yes:gcc_no_link=no:' ${S}/libstdc++-v3/configure |
23 | 23 | ||
24 | } | 24 | } |
25 | 25 | ||
26 | ARCH_FLAGS_FOR_TARGET += " -L${STAGING_DIR_TARGET}${layout_libdir} -isystem${STAGING_DIR_TARGET}${layout_includedir}" | 26 | ARCH_FLAGS_FOR_TARGET += " -L${STAGING_DIR_TARGET}${target_libdir} -isystem${STAGING_DIR_TARGET}${target_includedir}" |
diff --git a/meta/packages/gcc/gcc-native.inc b/meta/packages/gcc/gcc-native.inc index 6fa615ffc7..63b7375e96 100644 --- a/meta/packages/gcc/gcc-native.inc +++ b/meta/packages/gcc/gcc-native.inc | |||
@@ -5,7 +5,7 @@ PROVIDES = "gcc-native-${PV}" | |||
5 | inherit native | 5 | inherit native |
6 | 6 | ||
7 | # This is intended to be a -very- basic config | 7 | # This is intended to be a -very- basic config |
8 | EXTRA_OECONF = "--with-local-prefix=${STAGING_DIR_TARGET}${layout_prefix} \ | 8 | EXTRA_OECONF = "--with-local-prefix=${STAGING_DIR_TARGET}${prefix} \ |
9 | --with-newlib \ | 9 | --with-newlib \ |
10 | --disable-shared \ | 10 | --disable-shared \ |
11 | --disable-threads \ | 11 | --disable-threads \ |