diff options
author | Richard Purdie <richard@openedhand.com> | 2008-01-24 21:28:38 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2008-01-24 21:28:38 +0000 |
commit | c673a12162ed112edea7c97141946d2b88152c3a (patch) | |
tree | f749cfd454c7057aa58a33d155d13d4e64921f7e /meta/packages/gcc | |
parent | dc87a5f8219b5769ae971399b4c3335249849be4 (diff) | |
download | poky-c673a12162ed112edea7c97141946d2b88152c3a.tar.gz |
gcc: Remove 3.4.3 and 4.1.1, add missing sdk 3.4.4 and initial 4.1.2
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3591 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/gcc')
-rw-r--r-- | meta/packages/gcc/gcc-cross-initial_3.4.3.bb | 2 | ||||
-rw-r--r-- | meta/packages/gcc/gcc-cross-initial_4.1.1.bb | 5 | ||||
-rw-r--r-- | meta/packages/gcc/gcc-cross-sdk_4.1.1.bb | 40 | ||||
-rw-r--r-- | meta/packages/gcc/gcc-cross_3.4.3.bb | 16 | ||||
-rw-r--r-- | meta/packages/gcc/gcc-cross_4.1.1.bb | 18 | ||||
-rw-r--r-- | meta/packages/gcc/gcc_3.4.3.bb | 26 | ||||
-rw-r--r-- | meta/packages/gcc/gcc_4.1.1.bb | 61 |
7 files changed, 0 insertions, 168 deletions
diff --git a/meta/packages/gcc/gcc-cross-initial_3.4.3.bb b/meta/packages/gcc/gcc-cross-initial_3.4.3.bb deleted file mode 100644 index 1639511362..0000000000 --- a/meta/packages/gcc/gcc-cross-initial_3.4.3.bb +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | require gcc-cross_${PV}.bb | ||
2 | require gcc-cross-initial.inc | ||
diff --git a/meta/packages/gcc/gcc-cross-initial_4.1.1.bb b/meta/packages/gcc/gcc-cross-initial_4.1.1.bb deleted file mode 100644 index 1c1d094382..0000000000 --- a/meta/packages/gcc/gcc-cross-initial_4.1.1.bb +++ /dev/null | |||
@@ -1,5 +0,0 @@ | |||
1 | require gcc-cross_${PV}.bb | ||
2 | require gcc-cross-initial.inc | ||
3 | |||
4 | EXTRA_OECONF += "--disable-libmudflap \ | ||
5 | --disable-libssp" | ||
diff --git a/meta/packages/gcc/gcc-cross-sdk_4.1.1.bb b/meta/packages/gcc/gcc-cross-sdk_4.1.1.bb deleted file mode 100644 index a59a435532..0000000000 --- a/meta/packages/gcc/gcc-cross-sdk_4.1.1.bb +++ /dev/null | |||
@@ -1,40 +0,0 @@ | |||
1 | DESCRIPTION = "The GNU cc and gcc C compilers." | ||
2 | require gcc_${PV}.bb | ||
3 | PR = "r2" | ||
4 | |||
5 | EXCLUDE_FROM_SHLIBS = "1" | ||
6 | |||
7 | inherit sdk | ||
8 | |||
9 | FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}" | ||
10 | |||
11 | DEPENDS = "virtual/${TARGET_PREFIX}binutils virtual/${TARGET_PREFIX}libc-for-gcc" | ||
12 | PACKAGES = "${PN}" | ||
13 | |||
14 | require gcc4-build-sdk.inc | ||
15 | require gcc-package-sdk.inc | ||
16 | |||
17 | SRC_URI = "http://ftp.gnu.org/pub/gnu/gcc/gcc-4.1.1/gcc-4.1.1.tar.bz2 \ | ||
18 | file://100-uclibc-conf.patch;patch=1 \ | ||
19 | file://110-arm-eabi.patch;patch=1 \ | ||
20 | file://200-uclibc-locale.patch;patch=1 \ | ||
21 | file://300-libstdc++-pic.patch;patch=1 \ | ||
22 | file://301-missing-execinfo_h.patch;patch=1 \ | ||
23 | file://302-c99-snprintf.patch;patch=1 \ | ||
24 | file://303-c99-complex-ugly-hack.patch;patch=1 \ | ||
25 | file://304-index_macro.patch;patch=1 \ | ||
26 | file://602-sdk-libstdc++-includes.patch;patch=1 \ | ||
27 | file://740-sh-pr24836.patch;patch=1 \ | ||
28 | file://800-arm-bigendian.patch;patch=1 \ | ||
29 | file://arm-nolibfloat.patch;patch=1 \ | ||
30 | file://arm-softfloat.patch;patch=1 \ | ||
31 | file://gcc41-configure.in.patch;patch=1 \ | ||
32 | file://arm-thumb.patch;patch=1 \ | ||
33 | file://arm-thumb-cache.patch;patch=1 \ | ||
34 | file://ldflags.patch;patch=1 \ | ||
35 | file://cse.patch;patch=1 \ | ||
36 | file://unbreak-armv4t.patch;patch=1 \ | ||
37 | file://fix-ICE-in-arm_unwind_emit_set.diff;patch=1 \ | ||
38 | file://gcc-4.1.1-pr13685-1.patch;patch=1 \ | ||
39 | file://gcc-ignore-cache.patch;patch=1 \ | ||
40 | file://zecke-no-host-includes.patch;patch=1" | ||
diff --git a/meta/packages/gcc/gcc-cross_3.4.3.bb b/meta/packages/gcc/gcc-cross_3.4.3.bb deleted file mode 100644 index b61223b39c..0000000000 --- a/meta/packages/gcc/gcc-cross_3.4.3.bb +++ /dev/null | |||
@@ -1,16 +0,0 @@ | |||
1 | require gcc_${PV}.bb | ||
2 | # path mangling, needed by the cross packaging | ||
3 | require gcc-paths-cross.inc | ||
4 | inherit cross | ||
5 | FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}" | ||
6 | # NOTE: split PR. If the main .oe changes something that affects its *build* | ||
7 | # remember to increment this one too. | ||
8 | PR = "r10" | ||
9 | |||
10 | DEPENDS = "virtual/${TARGET_PREFIX}binutils virtual/${TARGET_PREFIX}libc-for-gcc" | ||
11 | PROVIDES = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++" | ||
12 | |||
13 | # cross build | ||
14 | require gcc3-build-cross.inc | ||
15 | # cross packaging | ||
16 | require gcc-package-cross.inc | ||
diff --git a/meta/packages/gcc/gcc-cross_4.1.1.bb b/meta/packages/gcc/gcc-cross_4.1.1.bb deleted file mode 100644 index 2d6cb19960..0000000000 --- a/meta/packages/gcc/gcc-cross_4.1.1.bb +++ /dev/null | |||
@@ -1,18 +0,0 @@ | |||
1 | require gcc_${PV}.bb | ||
2 | # path mangling, needed by the cross packaging | ||
3 | require gcc-paths-cross.inc | ||
4 | inherit cross | ||
5 | FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}" | ||
6 | # NOTE: split PR. If the main .oe changes something that affects its *build* | ||
7 | # remember to increment this one too. | ||
8 | PR = "r12" | ||
9 | |||
10 | DEPENDS = "virtual/${TARGET_PREFIX}binutils virtual/${TARGET_PREFIX}libc-for-gcc gmp-native mpfr-native" | ||
11 | PROVIDES = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++" | ||
12 | |||
13 | # cross build | ||
14 | require gcc3-build-cross.inc | ||
15 | # cross packaging | ||
16 | require gcc-package-cross.inc | ||
17 | |||
18 | EXTRA_OECONF += "--disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${layout_exec_prefix}" | ||
diff --git a/meta/packages/gcc/gcc_3.4.3.bb b/meta/packages/gcc/gcc_3.4.3.bb deleted file mode 100644 index 289fe8fdd6..0000000000 --- a/meta/packages/gcc/gcc_3.4.3.bb +++ /dev/null | |||
@@ -1,26 +0,0 @@ | |||
1 | PR = "r11" | ||
2 | DESCRIPTION = "The GNU cc and gcc C compilers." | ||
3 | HOMEPAGE = "http://www.gnu.org/software/gcc/" | ||
4 | SECTION = "devel" | ||
5 | LICENSE = "GPL" | ||
6 | |||
7 | inherit autotools gettext | ||
8 | |||
9 | require gcc-package.inc | ||
10 | |||
11 | SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \ | ||
12 | file://gcc34-reverse-compare.patch;patch=1 \ | ||
13 | file://gcc34-arm-ldm.patch;patch=1 \ | ||
14 | file://gcc34-arm-ldm-peephole.patch;patch=1 \ | ||
15 | file://gcc34-arm-tune.patch;patch=1 \ | ||
16 | file://gcc-3.4.1-uclibc-100-conf.patch;patch=1 \ | ||
17 | file://gcc-3.4.1-uclibc-200-locale.patch;patch=1 \ | ||
18 | file://gcc-3.4.0-arm-lib1asm.patch;patch=1 \ | ||
19 | file://gcc-3.4.0-arm-nolibfloat.patch;patch=1 \ | ||
20 | file://gcc-3.4.0-arm-bigendian.patch;patch=1 \ | ||
21 | file://gcc-3.4.0-arm-bigendian-uclibc.patch;patch=1 \ | ||
22 | file://GCC3.4.0VisibilityPatch.diff;patch=1 \ | ||
23 | file://15342.patch;patch=1 \ | ||
24 | file://always-fixincperm.patch;patch=1" | ||
25 | |||
26 | require gcc3-build.inc | ||
diff --git a/meta/packages/gcc/gcc_4.1.1.bb b/meta/packages/gcc/gcc_4.1.1.bb deleted file mode 100644 index 9135daca18..0000000000 --- a/meta/packages/gcc/gcc_4.1.1.bb +++ /dev/null | |||
@@ -1,61 +0,0 @@ | |||
1 | PR = "r14" | ||
2 | DESCRIPTION = "The GNU cc and gcc C compilers." | ||
3 | HOMEPAGE = "http://www.gnu.org/software/gcc/" | ||
4 | SECTION = "devel" | ||
5 | LICENSE = "GPL" | ||
6 | |||
7 | inherit autotools gettext | ||
8 | |||
9 | require gcc-package.inc | ||
10 | |||
11 | SRC_URI = "http://ftp.gnu.org/pub/gnu/gcc/gcc-4.1.1/gcc-4.1.1.tar.bz2 \ | ||
12 | file://100-uclibc-conf.patch;patch=1 \ | ||
13 | file://110-arm-eabi.patch;patch=1 \ | ||
14 | file://200-uclibc-locale.patch;patch=1 \ | ||
15 | file://300-libstdc++-pic.patch;patch=1 \ | ||
16 | file://301-missing-execinfo_h.patch;patch=1 \ | ||
17 | file://302-c99-snprintf.patch;patch=1 \ | ||
18 | file://303-c99-complex-ugly-hack.patch;patch=1 \ | ||
19 | file://304-index_macro.patch;patch=1 \ | ||
20 | file://602-sdk-libstdc++-includes.patch;patch=1 \ | ||
21 | file://740-sh-pr24836.patch;patch=1 \ | ||
22 | file://800-arm-bigendian.patch;patch=1 \ | ||
23 | file://801-arm-bigendian-eabi.patch;patch=1 \ | ||
24 | file://arm-nolibfloat.patch;patch=1 \ | ||
25 | file://arm-softfloat.patch;patch=1 \ | ||
26 | file://gcc41-configure.in.patch;patch=1 \ | ||
27 | file://arm-thumb.patch;patch=1 \ | ||
28 | file://arm-thumb-cache.patch;patch=1 \ | ||
29 | file://ldflags.patch;patch=1 \ | ||
30 | file://cse.patch;patch=1 \ | ||
31 | file://zecke-xgcc-cpp.patch;patch=1 \ | ||
32 | file://unbreak-armv4t.patch;patch=1 \ | ||
33 | file://fix-ICE-in-arm_unwind_emit_set.diff;patch=1 \ | ||
34 | file://gcc-4.1.1-pr13685-1.patch;patch=1 \ | ||
35 | file://gcc-ignore-cache.patch;patch=1 \ | ||
36 | " | ||
37 | |||
38 | SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch;patch=1 " | ||
39 | |||
40 | #This is a dirty hack to get gcc 4.1.1 to compile for glibc AND uclibc on ppc | ||
41 | #the patch that is need it to get gcc support soft-floats with glibc, makes gcc fail with uclibc | ||
42 | SRC_URI_append_linux = " file://ppc-gcc-41-20060515.patch;patch=1 \ | ||
43 | file://ppc-sfp-long-double-gcc411-7.patch;patch=1 " | ||
44 | |||
45 | |||
46 | #Set the fortran bits | ||
47 | # 'fortran' or '', not 'f77' like gcc3 had | ||
48 | FORTRAN = "" | ||
49 | HAS_GFORTRAN = "no" | ||
50 | HAS_G2C = "no" | ||
51 | |||
52 | #Set the java bits | ||
53 | JAVA_arm = "" | ||
54 | JAVA = "" | ||
55 | |||
56 | LANGUAGES = "c,c++${FORTRAN}${JAVA}" | ||
57 | require gcc3-build.inc | ||
58 | |||
59 | |||
60 | EXTRA_OECONF += " --disable-libssp " | ||
61 | |||