summaryrefslogtreecommitdiffstats
path: root/meta/packages/gcc
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-07-24 20:30:37 +0000
committerRichard Purdie <richard@openedhand.com>2008-07-24 20:30:37 +0000
commit87796f6ce02df30375057fac934685d109f99be3 (patch)
tree419fb9887ca981ada36fc0071c8078f35d4f82f2 /meta/packages/gcc
parentf9651fac68352c9cfa6c616ae50f711c32e7bf32 (diff)
downloadpoky-87796f6ce02df30375057fac934685d109f99be3.tar.gz
gcc: Add toolchain build process changes from OE which adds gcc-cross-intermediate and removes glibc-intermediate based on a patch from Khem Raj as will be aplied to OE.dev making the build process much more rebust/stable/correct.
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4943 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/gcc')
-rw-r--r--meta/packages/gcc/gcc-3.4.4.inc1
-rw-r--r--meta/packages/gcc/gcc-3.4.4/gcc-libgcc2-inhibit-libc.patch21
-rw-r--r--meta/packages/gcc/gcc-configure-cross.inc4
-rw-r--r--meta/packages/gcc/gcc-cross-initial.inc8
-rw-r--r--meta/packages/gcc/gcc-cross-intermediate.inc21
-rw-r--r--meta/packages/gcc/gcc-cross-intermediate_3.4.4.bb2
-rw-r--r--meta/packages/gcc/gcc-cross-intermediate_4.1.2.bb5
-rw-r--r--meta/packages/gcc/gcc-cross-intermediate_4.2.3.bb5
-rw-r--r--meta/packages/gcc/gcc-cross-intermediate_4.3.1.bb14
-rw-r--r--meta/packages/gcc/gcc-cross-intermediate_csl-arm-2005q3.bb2
-rw-r--r--meta/packages/gcc/gcc-cross-intermediate_csl-arm-2006q1.bb7
-rw-r--r--meta/packages/gcc/gcc-cross-intermediate_csl-arm-2007q3.bb12
-rw-r--r--meta/packages/gcc/gcc-cross-intermediate_csl-arm-2008q1.bb12
-rw-r--r--meta/packages/gcc/gcc-cross_3.4.4.bb2
-rw-r--r--meta/packages/gcc/gcc-cross_4.1.2.bb2
-rw-r--r--meta/packages/gcc/gcc-cross_4.2.3.bb2
-rw-r--r--meta/packages/gcc/gcc-cross_4.3.1.bb2
17 files changed, 107 insertions, 15 deletions
diff --git a/meta/packages/gcc/gcc-3.4.4.inc b/meta/packages/gcc/gcc-3.4.4.inc
index 704d9bc5c8..5700a7c831 100644
--- a/meta/packages/gcc/gcc-3.4.4.inc
+++ b/meta/packages/gcc/gcc-3.4.4.inc
@@ -17,6 +17,7 @@ SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
17 file://always-fixincperm.patch;patch=1 \ 17 file://always-fixincperm.patch;patch=1 \
18 file://GCOV_PREFIX_STRIP-cross-profile_3.4.patch;patch=1 \ 18 file://GCOV_PREFIX_STRIP-cross-profile_3.4.patch;patch=1 \
19 file://zecke-xgcc-cpp.patch;patch=1 \ 19 file://zecke-xgcc-cpp.patch;patch=1 \
20 file://gcc-libgcc2-inhibit-libc.patch;patch=1 \
20 file://gcc4-mtune-compat.patch;patch=1" 21 file://gcc4-mtune-compat.patch;patch=1"
21 22
22SRC_URI += "file://gcc34-configure.in.patch;patch=1" 23SRC_URI += "file://gcc34-configure.in.patch;patch=1"
diff --git a/meta/packages/gcc/gcc-3.4.4/gcc-libgcc2-inhibit-libc.patch b/meta/packages/gcc/gcc-3.4.4/gcc-libgcc2-inhibit-libc.patch
new file mode 100644
index 0000000000..f3f7048b8a
--- /dev/null
+++ b/meta/packages/gcc/gcc-3.4.4/gcc-libgcc2-inhibit-libc.patch
@@ -0,0 +1,21 @@
1---
2 gcc/config/i386/linux.h | 2 ++
3 1 file changed, 2 insertions(+)
4
5Index: gcc-3.4.4/gcc/config/i386/linux.h
6===================================================================
7--- gcc-3.4.4.orig/gcc/config/i386/linux.h 2008-07-17 23:40:00.000000000 -0700
8+++ gcc-3.4.4/gcc/config/i386/linux.h 2008-07-17 23:40:41.000000000 -0700
9@@ -218,6 +218,7 @@ Boston, MA 02111-1307, USA. */
10 /* Do code reading to identify a signal frame, and set the frame
11 state data appropriately. See unwind-dw2.c for the structs. */
12
13+#ifndef inhibit_libc
14 #ifdef IN_LIBGCC2
15 /* There's no sys/ucontext.h for some (all?) libc1, so no
16 signal-turned-exceptions for them. There's also no configure-run for
17@@ -282,3 +283,4 @@ Boston, MA 02111-1307, USA. */
18 } while (0)
19 #endif /* not USE_GNULIBC_1 */
20 #endif /* IN_LIBGCC2 */
21+#endif
diff --git a/meta/packages/gcc/gcc-configure-cross.inc b/meta/packages/gcc/gcc-configure-cross.inc
index c05cf3dff8..da66e8e851 100644
--- a/meta/packages/gcc/gcc-configure-cross.inc
+++ b/meta/packages/gcc/gcc-configure-cross.inc
@@ -7,10 +7,6 @@ EXTRA_OECONF_PATHS = "--with-local-prefix=${STAGING_DIR_TARGET}${layout_prefix}
7 --with-sysroot=${STAGING_DIR_TARGET} \ 7 --with-sysroot=${STAGING_DIR_TARGET} \
8 --with-build-sysroot=${STAGING_DIR_TARGET}" 8 --with-build-sysroot=${STAGING_DIR_TARGET}"
9 9
10do_configure_prepend () {
11 rm -f ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/libgcc_eh.a
12}
13
14do_compile_prepend () { 10do_compile_prepend () {
15 export CC="${BUILD_CC}" 11 export CC="${BUILD_CC}"
16 export AR_FOR_TARGET="${TARGET_SYS}-ar" 12 export AR_FOR_TARGET="${TARGET_SYS}-ar"
diff --git a/meta/packages/gcc/gcc-cross-initial.inc b/meta/packages/gcc/gcc-cross-initial.inc
index e0675263ea..15e5fa62fc 100644
--- a/meta/packages/gcc/gcc-cross-initial.inc
+++ b/meta/packages/gcc/gcc-cross-initial.inc
@@ -1,6 +1,4 @@
1DEPENDS = "virtual/${TARGET_PREFIX}binutils" 1DEPENDS = "virtual/${TARGET_PREFIX}binutils"
2# @todo Please add comment on why this is (still?) needed?
3DEPENDS += "${@['virtual/${TARGET_PREFIX}libc-initial',''][bb.data.getVar('TARGET_ARCH', d, 1) in ['arm', 'armeb', 'mips', 'mipsel', 'powerpc']]}"
4PROVIDES = "virtual/${TARGET_PREFIX}gcc-initial" 2PROVIDES = "virtual/${TARGET_PREFIX}gcc-initial"
5PACKAGES = "" 3PACKAGES = ""
6 4
@@ -8,6 +6,7 @@ PACKAGES = ""
8# sysroot is needed in case we use libc-initial 6# sysroot is needed in case we use libc-initial
9EXTRA_OECONF = "--with-local-prefix=${STAGING_DIR_TARGET}${layout_prefix} \ 7EXTRA_OECONF = "--with-local-prefix=${STAGING_DIR_TARGET}${layout_prefix} \
10 --with-newlib \ 8 --with-newlib \
9 --without-headers \
11 --disable-shared \ 10 --disable-shared \
12 --disable-threads \ 11 --disable-threads \
13 --disable-multilib \ 12 --disable-multilib \
@@ -19,11 +18,6 @@ EXTRA_OECONF = "--with-local-prefix=${STAGING_DIR_TARGET}${layout_prefix} \
19 --with-build-sysroot=${STAGING_DIR_TARGET} \ 18 --with-build-sysroot=${STAGING_DIR_TARGET} \
20 ${@get_gcc_fpu_setting(bb, d)}" 19 ${@get_gcc_fpu_setting(bb, d)}"
21 20
22do_stage_prepend () {
23 mkdir -p ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}
24 ln -sf libgcc.a ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/libgcc_eh.a
25}
26
27do_install () { 21do_install () {
28 : 22 :
29} 23}
diff --git a/meta/packages/gcc/gcc-cross-intermediate.inc b/meta/packages/gcc/gcc-cross-intermediate.inc
new file mode 100644
index 0000000000..4fa12886f1
--- /dev/null
+++ b/meta/packages/gcc/gcc-cross-intermediate.inc
@@ -0,0 +1,21 @@
1DEPENDS = "virtual/${TARGET_PREFIX}binutils"
2DEPENDS += "virtual/${TARGET_PREFIX}libc-initial"
3PROVIDES = "virtual/${TARGET_PREFIX}gcc-intermediate"
4PACKAGES = ""
5
6# This is intended to be a -very- basic config
7# sysroot is needed in case we use libc-initial
8EXTRA_OECONF = "--with-local-prefix=${STAGING_DIR_TARGET}${layout_prefix} \
9 --enable-shared \
10 --disable-multilib \
11 --disable-threads \
12 --enable-languages=c \
13 --enable-target-optspace \
14 --program-prefix=${TARGET_PREFIX} \
15 --with-sysroot=${STAGING_DIR_TARGET} \
16 --with-build-sysroot=${STAGING_DIR_TARGET} \
17 ${@get_gcc_fpu_setting(bb, d)}"
18
19do_install () {
20 :
21}
diff --git a/meta/packages/gcc/gcc-cross-intermediate_3.4.4.bb b/meta/packages/gcc/gcc-cross-intermediate_3.4.4.bb
new file mode 100644
index 0000000000..eb59de9461
--- /dev/null
+++ b/meta/packages/gcc/gcc-cross-intermediate_3.4.4.bb
@@ -0,0 +1,2 @@
1require gcc-cross_${PV}.bb
2require gcc-cross-intermediate.inc
diff --git a/meta/packages/gcc/gcc-cross-intermediate_4.1.2.bb b/meta/packages/gcc/gcc-cross-intermediate_4.1.2.bb
new file mode 100644
index 0000000000..3e103aa24e
--- /dev/null
+++ b/meta/packages/gcc/gcc-cross-intermediate_4.1.2.bb
@@ -0,0 +1,5 @@
1require gcc-cross_${PV}.bb
2require gcc-cross-intermediate.inc
3
4EXTRA_OECONF += "--disable-libmudflap \
5 --disable-libssp"
diff --git a/meta/packages/gcc/gcc-cross-intermediate_4.2.3.bb b/meta/packages/gcc/gcc-cross-intermediate_4.2.3.bb
new file mode 100644
index 0000000000..7acca81c3b
--- /dev/null
+++ b/meta/packages/gcc/gcc-cross-intermediate_4.2.3.bb
@@ -0,0 +1,5 @@
1require gcc-cross_${PV}.bb
2require gcc-cross-intermediate.inc
3
4EXTRA_OECONF += "--disable-libmudflap --disable-libgomp \
5 --disable-libssp"
diff --git a/meta/packages/gcc/gcc-cross-intermediate_4.3.1.bb b/meta/packages/gcc/gcc-cross-intermediate_4.3.1.bb
new file mode 100644
index 0000000000..b0932f520d
--- /dev/null
+++ b/meta/packages/gcc/gcc-cross-intermediate_4.3.1.bb
@@ -0,0 +1,14 @@
1require gcc-cross_${PV}.bb
2require gcc-cross-intermediate.inc
3
4DEPENDS += "gmp-native mpfr-native"
5
6EXTRA_OECONF += " --disable-libmudflap \
7 --disable-libgomp \
8 --disable-libssp"
9
10# Hack till we fix *libc properly
11do_stage_append() {
12 ln -sf ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include-fixed/* ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include/
13}
14
diff --git a/meta/packages/gcc/gcc-cross-intermediate_csl-arm-2005q3.bb b/meta/packages/gcc/gcc-cross-intermediate_csl-arm-2005q3.bb
new file mode 100644
index 0000000000..6e9c252e7e
--- /dev/null
+++ b/meta/packages/gcc/gcc-cross-intermediate_csl-arm-2005q3.bb
@@ -0,0 +1,2 @@
1require gcc-cross_csl-arm-2005q3.bb
2require gcc-cross-intermediate.inc
diff --git a/meta/packages/gcc/gcc-cross-intermediate_csl-arm-2006q1.bb b/meta/packages/gcc/gcc-cross-intermediate_csl-arm-2006q1.bb
new file mode 100644
index 0000000000..2d4b55f997
--- /dev/null
+++ b/meta/packages/gcc/gcc-cross-intermediate_csl-arm-2006q1.bb
@@ -0,0 +1,7 @@
1require gcc-cross_${PV}.bb
2require gcc-cross-intermediate.inc
3
4S = "${WORKDIR}/gcc-2006q1"
5
6EXTRA_OECONF += "--disable-libmudflap \
7 --disable-libssp"
diff --git a/meta/packages/gcc/gcc-cross-intermediate_csl-arm-2007q3.bb b/meta/packages/gcc/gcc-cross-intermediate_csl-arm-2007q3.bb
new file mode 100644
index 0000000000..114d9831c6
--- /dev/null
+++ b/meta/packages/gcc/gcc-cross-intermediate_csl-arm-2007q3.bb
@@ -0,0 +1,12 @@
1require gcc-cross_${PV}.bb
2require gcc-cross-intermediate.inc
3
4S = "${WORKDIR}/gcc-4.2"
5
6EXTRA_OECONF += "--disable-libssp --disable-bootstrap --disable-libgomp --disable-libmudflap "
7
8# Hack till we fix *libc properly
9do_stage_append() {
10 ln -sf ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include-fixed/* ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include/
11}
12
diff --git a/meta/packages/gcc/gcc-cross-intermediate_csl-arm-2008q1.bb b/meta/packages/gcc/gcc-cross-intermediate_csl-arm-2008q1.bb
new file mode 100644
index 0000000000..114d9831c6
--- /dev/null
+++ b/meta/packages/gcc/gcc-cross-intermediate_csl-arm-2008q1.bb
@@ -0,0 +1,12 @@
1require gcc-cross_${PV}.bb
2require gcc-cross-intermediate.inc
3
4S = "${WORKDIR}/gcc-4.2"
5
6EXTRA_OECONF += "--disable-libssp --disable-bootstrap --disable-libgomp --disable-libmudflap "
7
8# Hack till we fix *libc properly
9do_stage_append() {
10 ln -sf ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include-fixed/* ${CROSS_DIR}/lib/gcc/${TARGET_SYS}/${BINV}/include/
11}
12
diff --git a/meta/packages/gcc/gcc-cross_3.4.4.bb b/meta/packages/gcc/gcc-cross_3.4.4.bb
index c9b5cc9924..c7a4cfe857 100644
--- a/meta/packages/gcc/gcc-cross_3.4.4.bb
+++ b/meta/packages/gcc/gcc-cross_3.4.4.bb
@@ -1,4 +1,4 @@
1PR = "r9" 1PR = "r10"
2 2
3require gcc-${PV}.inc 3require gcc-${PV}.inc
4require gcc-cross.inc 4require gcc-cross.inc
diff --git a/meta/packages/gcc/gcc-cross_4.1.2.bb b/meta/packages/gcc/gcc-cross_4.1.2.bb
index 43f21735e7..c9e3279ffc 100644
--- a/meta/packages/gcc/gcc-cross_4.1.2.bb
+++ b/meta/packages/gcc/gcc-cross_4.1.2.bb
@@ -1,4 +1,4 @@
1PR = "r16" 1PR = "r17"
2 2
3require gcc-${PV}.inc 3require gcc-${PV}.inc
4require gcc-cross4.inc 4require gcc-cross4.inc
diff --git a/meta/packages/gcc/gcc-cross_4.2.3.bb b/meta/packages/gcc/gcc-cross_4.2.3.bb
index 11e04594fc..72f72835c3 100644
--- a/meta/packages/gcc/gcc-cross_4.2.3.bb
+++ b/meta/packages/gcc/gcc-cross_4.2.3.bb
@@ -1,4 +1,4 @@
1PR = "r6" 1PR = "r7"
2 2
3require gcc-${PV}.inc 3require gcc-${PV}.inc
4require gcc-cross4.inc 4require gcc-cross4.inc
diff --git a/meta/packages/gcc/gcc-cross_4.3.1.bb b/meta/packages/gcc/gcc-cross_4.3.1.bb
index 9821d3cd83..11e04594fc 100644
--- a/meta/packages/gcc/gcc-cross_4.3.1.bb
+++ b/meta/packages/gcc/gcc-cross_4.3.1.bb
@@ -1,4 +1,4 @@
1PR = "r5" 1PR = "r6"
2 2
3require gcc-${PV}.inc 3require gcc-${PV}.inc
4require gcc-cross4.inc 4require gcc-cross4.inc