summaryrefslogtreecommitdiffstats
path: root/meta/packages/gcc
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-03-06 14:59:25 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-03-06 14:59:25 +0000
commit64e621cf18a2a5970b172187926152893ef72174 (patch)
tree2a04bc9aa28457197ed806b1c6e5370de1f628b9 /meta/packages/gcc
parent96c69763a6f096757987cdcab2426b359f330ffd (diff)
downloadpoky-64e621cf18a2a5970b172187926152893ef72174.tar.gz
gcc: remove precompiled c++ headers as they take lot of space and are not required
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3969 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/gcc')
-rw-r--r--meta/packages/gcc/gcc-package.inc3
-rw-r--r--meta/packages/gcc/gcc_4.2.2.bb2
2 files changed, 4 insertions, 1 deletions
diff --git a/meta/packages/gcc/gcc-package.inc b/meta/packages/gcc/gcc-package.inc
index 011c4fab63..0140126ba6 100644
--- a/meta/packages/gcc/gcc-package.inc
+++ b/meta/packages/gcc/gcc-package.inc
@@ -126,6 +126,9 @@ do_install () {
126 ln -sf gcc cc 126 ln -sf gcc cc
127 ln -sf ${bindir}/${TARGET_SYS}-cpp ${D}${base_libdir}/cpp 127 ln -sf ${bindir}/${TARGET_SYS}-cpp ${D}${base_libdir}/cpp
128 ln -sf ${bindir}/${TARGET_SYS}-cpp ${D}${bindir}/cpp 128 ln -sf ${bindir}/${TARGET_SYS}-cpp ${D}${bindir}/cpp
129
130 # Remove precompiled c++ headers as they are really big
131 rm -rf ${D}${includedir}/c++/${BINV}/${TARGET_SYS}/bits/*.gch
129} 132}
130 133
131# The gcc package contains symlinks that trip up insane 134# The gcc package contains symlinks that trip up insane
diff --git a/meta/packages/gcc/gcc_4.2.2.bb b/meta/packages/gcc/gcc_4.2.2.bb
index 0a0e9cdd16..d322de1296 100644
--- a/meta/packages/gcc/gcc_4.2.2.bb
+++ b/meta/packages/gcc/gcc_4.2.2.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "The GNU cc and gcc C compilers."
2HOMEPAGE = "http://www.gnu.org/software/gcc/" 2HOMEPAGE = "http://www.gnu.org/software/gcc/"
3SECTION = "devel" 3SECTION = "devel"
4LICENSE = "GPL" 4LICENSE = "GPL"
5PR = "r6" 5PR = "r7"
6 6
7inherit autotools gettext 7inherit autotools gettext
8 8