summaryrefslogtreecommitdiffstats
path: root/meta/packages/gcc
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2010-07-30 14:05:16 -0700
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-10 15:02:09 +0100
commit1842635ee89b1ffb3b6fda2c9fecaff973900f0a (patch)
tree99cdf8ed7bb8c20e5ea209f15c7fc56d4fb280e2 /meta/packages/gcc
parent8fd7cc38b54a62cdc00f505cbfcb25a37013f641 (diff)
downloadpoky-1842635ee89b1ffb3b6fda2c9fecaff973900f0a.tar.gz
gcc-4.5.0: import some ppc & mips fixes from oe recipes
for ppc glibc build failes with -os (optimize for size) gcc option. so the fix disables this gcc options on ppc. MIPS fix is added in the hope of helping webkit-gtk build failure (gcc seg fault). And fix the PR bumps for all affected recipes Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/packages/gcc')
-rw-r--r--meta/packages/gcc/gcc-common.inc5
-rw-r--r--meta/packages/gcc/gcc-configure-common.inc11
-rw-r--r--meta/packages/gcc/gcc-cross-canadian_4.5.0.bb2
-rw-r--r--meta/packages/gcc/gcc-cross-initial.inc2
-rw-r--r--meta/packages/gcc/gcc-cross-initial_4.5.0.bb2
-rw-r--r--meta/packages/gcc/gcc-cross-intermediate.inc2
-rw-r--r--meta/packages/gcc/gcc-cross-intermediate_4.5.0.bb2
-rw-r--r--meta/packages/gcc/gcc-cross_4.5.0.bb2
-rw-r--r--meta/packages/gcc/gcc-crosssdk-initial_4.5.0.bb2
-rw-r--r--meta/packages/gcc/gcc-crosssdk-intermediate_4.5.0.bb2
-rw-r--r--meta/packages/gcc/gcc-crosssdk_4.5.0.bb2
-rw-r--r--meta/packages/gcc/gcc-runtime_4.5.0.bb2
-rw-r--r--meta/packages/gcc/gcc_4.5.0.bb2
13 files changed, 25 insertions, 13 deletions
diff --git a/meta/packages/gcc/gcc-common.inc b/meta/packages/gcc/gcc-common.inc
index ea0a48ea0c..1e9c65e662 100644
--- a/meta/packages/gcc/gcc-common.inc
+++ b/meta/packages/gcc/gcc-common.inc
@@ -14,6 +14,11 @@ def get_gcc_fpu_setting(bb, d):
14 return "--with-float=soft" 14 return "--with-float=soft"
15 return "" 15 return ""
16 16
17def get_gcc_mips_plt_setting(bb, d):
18 if bb.data.getVar('TARGET_ARCH', d, 1) in [ 'mips', 'mipsel' ] and 'mplt' in bb.data.getVar('DISTRO_FEATURES',d,1).split() :
19 return "--with-mips-plt"
20 return ""
21
17# We really need HOST_SYS here for some packages and TARGET_SYS for others. 22# We really need HOST_SYS here for some packages and TARGET_SYS for others.
18# For now, libgcc is most important so we fix for that - RP. 23# For now, libgcc is most important so we fix for that - RP.
19SHLIBSDIR = "${STAGING_DIR_TARGET}/shlibs" 24SHLIBSDIR = "${STAGING_DIR_TARGET}/shlibs"
diff --git a/meta/packages/gcc/gcc-configure-common.inc b/meta/packages/gcc/gcc-configure-common.inc
index 3400296c2d..ab42bc5608 100644
--- a/meta/packages/gcc/gcc-configure-common.inc
+++ b/meta/packages/gcc/gcc-configure-common.inc
@@ -12,6 +12,12 @@ JAVA_sh3 ?= ""
12# gcc 3.x expects 'f77', 4.0 expects 'f95', 4.1 and 4.2 expect 'fortran' 12# gcc 3.x expects 'f77', 4.0 expects 'f95', 4.1 and 4.2 expect 'fortran'
13FORTRAN ?= ",f77" 13FORTRAN ?= ",f77"
14LANGUAGES ?= "c,c++${FORTRAN}${JAVA}" 14LANGUAGES ?= "c,c++${FORTRAN}${JAVA}"
15# disable --enable-target-optspace for powerpc SPE
16# at -Os libgcc.so.1 creates references into
17# hidden symbols in libgcc.a which linker complains
18# when linking shared libraries further in the build like (gnutls)
19
20OPTSPACE = "${@base_contains('TARGET_ARCH', 'powerpc', '', '--enable-target-optspace',d)}"
15 21
16EXTRA_OECONF_BASE ?= "" 22EXTRA_OECONF_BASE ?= ""
17EXTRA_OECONF_PATHS ?= "" 23EXTRA_OECONF_PATHS ?= ""
@@ -23,7 +29,6 @@ GCCMULTILIB = "--disable-multilib"
23EXTRA_OECONF = "${@['--enable-clocale=generic', ''][bb.data.getVar('USE_NLS', d, 1) != 'no']} \ 29EXTRA_OECONF = "${@['--enable-clocale=generic', ''][bb.data.getVar('USE_NLS', d, 1) != 'no']} \
24 --with-gnu-ld \ 30 --with-gnu-ld \
25 --enable-shared \ 31 --enable-shared \
26 --enable-target-optspace \
27 --enable-languages=${LANGUAGES} \ 32 --enable-languages=${LANGUAGES} \
28 --enable-threads=posix \ 33 --enable-threads=posix \
29 ${GCCMULTILIB} \ 34 ${GCCMULTILIB} \
@@ -32,9 +37,11 @@ EXTRA_OECONF = "${@['--enable-clocale=generic', ''][bb.data.getVar('USE_NLS', d,
32 --enable-symvers=gnu \ 37 --enable-symvers=gnu \
33 --enable-libstdcxx-pch \ 38 --enable-libstdcxx-pch \
34 --program-prefix=${TARGET_PREFIX} \ 39 --program-prefix=${TARGET_PREFIX} \
40 ${OPTSPACE} \
35 ${EXTRA_OECONF_BASE} \ 41 ${EXTRA_OECONF_BASE} \
36 ${EXTRA_OECONF_FPU} \ 42 ${EXTRA_OECONF_FPU} \
37 ${EXTRA_OECONF_PATHS}" 43 ${EXTRA_OECONF_PATHS} \
44 ${@get_gcc_mips_plt_setting(bb, d)}"
38 45
39# Build uclibc compilers without cxa_atexit support 46# Build uclibc compilers without cxa_atexit support
40EXTRA_OECONF_append_linux = " --enable-__cxa_atexit" 47EXTRA_OECONF_append_linux = " --enable-__cxa_atexit"
diff --git a/meta/packages/gcc/gcc-cross-canadian_4.5.0.bb b/meta/packages/gcc/gcc-cross-canadian_4.5.0.bb
index 3eea4bcafe..92708d44e7 100644
--- a/meta/packages/gcc/gcc-cross-canadian_4.5.0.bb
+++ b/meta/packages/gcc/gcc-cross-canadian_4.5.0.bb
@@ -5,7 +5,7 @@ require gcc-cross-canadian.inc
5require gcc-configure-sdk.inc 5require gcc-configure-sdk.inc
6require gcc-package-sdk.inc 6require gcc-package-sdk.inc
7 7
8PR = "r3" 8PR = "r4"
9 9
10DEPENDS += "gmp-nativesdk mpfr-nativesdk libmpc-nativesdk elfutils-nativesdk" 10DEPENDS += "gmp-nativesdk mpfr-nativesdk libmpc-nativesdk elfutils-nativesdk"
11RDEPENDS_${PN} += "mpfr-nativesdk libmpc-nativesdk elfutils-nativesdk" 11RDEPENDS_${PN} += "mpfr-nativesdk libmpc-nativesdk elfutils-nativesdk"
diff --git a/meta/packages/gcc/gcc-cross-initial.inc b/meta/packages/gcc/gcc-cross-initial.inc
index ceedb6f8a9..f582de9843 100644
--- a/meta/packages/gcc/gcc-cross-initial.inc
+++ b/meta/packages/gcc/gcc-cross-initial.inc
@@ -12,7 +12,7 @@ EXTRA_OECONF = "--with-local-prefix=${STAGING_DIR_TARGET}${target_prefix} \
12 --disable-multilib \ 12 --disable-multilib \
13 --disable-__cxa_atexit \ 13 --disable-__cxa_atexit \
14 --enable-languages=c \ 14 --enable-languages=c \
15 --enable-target-optspace \ 15 ${OPTSPACE} \
16 --program-prefix=${TARGET_PREFIX} \ 16 --program-prefix=${TARGET_PREFIX} \
17 --with-sysroot=${STAGING_DIR_TARGET} \ 17 --with-sysroot=${STAGING_DIR_TARGET} \
18 --with-build-sysroot=${STAGING_DIR_TARGET} \ 18 --with-build-sysroot=${STAGING_DIR_TARGET} \
diff --git a/meta/packages/gcc/gcc-cross-initial_4.5.0.bb b/meta/packages/gcc/gcc-cross-initial_4.5.0.bb
index 38e0964fed..081b7d60fb 100644
--- a/meta/packages/gcc/gcc-cross-initial_4.5.0.bb
+++ b/meta/packages/gcc/gcc-cross-initial_4.5.0.bb
@@ -1,5 +1,5 @@
1require gcc-cross_${PV}.bb 1require gcc-cross_${PV}.bb
2require gcc-cross-initial.inc 2require gcc-cross-initial.inc
3 3
4PR = "r3" 4PR = "r4"
5 5
diff --git a/meta/packages/gcc/gcc-cross-intermediate.inc b/meta/packages/gcc/gcc-cross-intermediate.inc
index bab9d4a224..72a42411b1 100644
--- a/meta/packages/gcc/gcc-cross-intermediate.inc
+++ b/meta/packages/gcc/gcc-cross-intermediate.inc
@@ -10,7 +10,7 @@ EXTRA_OECONF = "--with-local-prefix=${STAGING_DIR_TARGET}${target_prefix} \
10 --disable-multilib \ 10 --disable-multilib \
11 --disable-threads \ 11 --disable-threads \
12 --enable-languages=c \ 12 --enable-languages=c \
13 --enable-target-optspace \ 13 ${OPTSPACE} \
14 --program-prefix=${TARGET_PREFIX} \ 14 --program-prefix=${TARGET_PREFIX} \
15 --with-sysroot=${STAGING_DIR_TARGET} \ 15 --with-sysroot=${STAGING_DIR_TARGET} \
16 --with-build-sysroot=${STAGING_DIR_TARGET} \ 16 --with-build-sysroot=${STAGING_DIR_TARGET} \
diff --git a/meta/packages/gcc/gcc-cross-intermediate_4.5.0.bb b/meta/packages/gcc/gcc-cross-intermediate_4.5.0.bb
index e65d5df671..9a30cb5119 100644
--- a/meta/packages/gcc/gcc-cross-intermediate_4.5.0.bb
+++ b/meta/packages/gcc/gcc-cross-intermediate_4.5.0.bb
@@ -1,4 +1,4 @@
1require gcc-cross_${PV}.bb 1require gcc-cross_${PV}.bb
2require gcc-cross-intermediate.inc 2require gcc-cross-intermediate.inc
3PR = "r3" 3PR = "r4"
4 4
diff --git a/meta/packages/gcc/gcc-cross_4.5.0.bb b/meta/packages/gcc/gcc-cross_4.5.0.bb
index 3d75bd4a19..04e4f8d212 100644
--- a/meta/packages/gcc/gcc-cross_4.5.0.bb
+++ b/meta/packages/gcc/gcc-cross_4.5.0.bb
@@ -1,4 +1,4 @@
1PR = "r3" 1PR = "r4"
2 2
3require gcc-${PV}.inc 3require gcc-${PV}.inc
4require gcc-cross4.inc 4require gcc-cross4.inc
diff --git a/meta/packages/gcc/gcc-crosssdk-initial_4.5.0.bb b/meta/packages/gcc/gcc-crosssdk-initial_4.5.0.bb
index fec53b931c..970824805f 100644
--- a/meta/packages/gcc/gcc-crosssdk-initial_4.5.0.bb
+++ b/meta/packages/gcc/gcc-crosssdk-initial_4.5.0.bb
@@ -1,4 +1,4 @@
1require gcc-cross-initial_${PV}.bb 1require gcc-cross-initial_${PV}.bb
2require gcc-crosssdk-initial.inc 2require gcc-crosssdk-initial.inc
3 3
4PR = "r3" 4PR = "r4"
diff --git a/meta/packages/gcc/gcc-crosssdk-intermediate_4.5.0.bb b/meta/packages/gcc/gcc-crosssdk-intermediate_4.5.0.bb
index 161d870e63..d235969591 100644
--- a/meta/packages/gcc/gcc-crosssdk-intermediate_4.5.0.bb
+++ b/meta/packages/gcc/gcc-crosssdk-intermediate_4.5.0.bb
@@ -1,4 +1,4 @@
1require gcc-cross-intermediate_${PV}.bb 1require gcc-cross-intermediate_${PV}.bb
2require gcc-crosssdk-intermediate.inc 2require gcc-crosssdk-intermediate.inc
3 3
4PR = "r3" 4PR = "r4"
diff --git a/meta/packages/gcc/gcc-crosssdk_4.5.0.bb b/meta/packages/gcc/gcc-crosssdk_4.5.0.bb
index 70690881aa..bae238970a 100644
--- a/meta/packages/gcc/gcc-crosssdk_4.5.0.bb
+++ b/meta/packages/gcc/gcc-crosssdk_4.5.0.bb
@@ -1,4 +1,4 @@
1require gcc-cross_${PV}.bb 1require gcc-cross_${PV}.bb
2require gcc-crosssdk.inc 2require gcc-crosssdk.inc
3 3
4PR = "r3" 4PR = "r4"
diff --git a/meta/packages/gcc/gcc-runtime_4.5.0.bb b/meta/packages/gcc/gcc-runtime_4.5.0.bb
index c1e680d3c0..9eb658b12c 100644
--- a/meta/packages/gcc/gcc-runtime_4.5.0.bb
+++ b/meta/packages/gcc/gcc-runtime_4.5.0.bb
@@ -1,4 +1,4 @@
1PR = "r3" 1PR = "r4"
2 2
3require gcc-${PV}.inc 3require gcc-${PV}.inc
4require gcc-configure-runtime.inc 4require gcc-configure-runtime.inc
diff --git a/meta/packages/gcc/gcc_4.5.0.bb b/meta/packages/gcc/gcc_4.5.0.bb
index 7c1869f503..c14914cddb 100644
--- a/meta/packages/gcc/gcc_4.5.0.bb
+++ b/meta/packages/gcc/gcc_4.5.0.bb
@@ -1,4 +1,4 @@
1PR = "r3" 1PR = "r4"
2 2
3require gcc-${PV}.inc 3require gcc-${PV}.inc
4require gcc-configure-target.inc 4require gcc-configure-target.inc