summaryrefslogtreecommitdiffstats
path: root/meta/packages/gcc/gcc_3.3.4.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-03-17 11:53:45 +0000
committerRichard Purdie <richard@openedhand.com>2008-03-17 11:53:45 +0000
commita619546dc4c209b75e15f4384a974a3f397c1327 (patch)
tree263f104aee409f6050adbee39ff5e65ccd6864ce /meta/packages/gcc/gcc_3.3.4.bb
parentf2888e8164ff305ffdca06c057e764499e445128 (diff)
downloadpoky-a619546dc4c209b75e15f4384a974a3f397c1327.tar.gz
gcc: Drop 3.3.4
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4018 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/gcc/gcc_3.3.4.bb')
-rw-r--r--meta/packages/gcc/gcc_3.3.4.bb169
1 files changed, 0 insertions, 169 deletions
diff --git a/meta/packages/gcc/gcc_3.3.4.bb b/meta/packages/gcc/gcc_3.3.4.bb
deleted file mode 100644
index 00adcac3ec..0000000000
--- a/meta/packages/gcc/gcc_3.3.4.bb
+++ /dev/null
@@ -1,169 +0,0 @@
1SECTION = "devel"
2PR = "r2"
3inherit autotools gettext
4
5DESCRIPTION = "The GNU cc and gcc C compilers."
6HOMEPAGE = "http://www.gnu.org/software/gcc/"
7LICENSE = "GPL"
8
9# libgcc libstdc++ libg2c are listed in our FILES_*, but are actually
10# packaged in the respective cross packages.
11PACKAGES = "${PN} ${PN}-symlinks \
12 ${PN}-c++ ${PN}-c++-symlinks \
13 ${PN}-f77 ${PN}-f77-symlinks \
14 libstdc++-dev libg2c-dev \
15 ${PN}-doc"
16
17FILES_${PN} = "${bindir}/${TARGET_PREFIX}gcc \
18 ${bindir}/${TARGET_PREFIX}cpp \
19 ${bindir}/${TARGET_PREFIX}gcov \
20 ${bindir}/${TARGET_PREFIX}gccbug \
21 ${libdir}/gcc-lib/${TARGET_SYS}/${PV}/cc1 \
22 ${libdir}/gcc-lib/${TARGET_SYS}/${PV}/collect2 \
23 ${libdir}/gcc-lib/${TARGET_SYS}/${PV}/crt* \
24 ${libdir}/gcc-lib/${TARGET_SYS}/${PV}/specs \
25 ${libdir}/gcc-lib/${TARGET_SYS}/${PV}/lib* \
26 ${libdir}/gcc-lib/${TARGET_SYS}/${PV}/include"
27
28FILES_${PN}-symlinks = "${bindir}/cc \
29 ${bindir}/gcc \
30 ${bindir}/cpp \
31 ${bindir}/gcov \
32 ${bindir}/gccbug"
33
34FILES_${PN}-c++ = "${bindir}/${TARGET_PREFIX}g++ \
35 ${libdir}/gcc-lib/${TARGET_SYS}/${PV}/cc1plus"
36
37FILES_${PN}-c++-symlinks = "${bindir}/c++ \
38 ${bindir}/g++"
39
40FILES_libgcc = "/lib/libgcc_s.so.*"
41
42# Called from within gcc-cross, so libdir is set wrong
43#FILES_libstdc++ = "${libdir}/libstdc++.so.*"
44FILES_libstdc++ = "${libdir}/libstdc++.so.*"
45
46FILES_libstdc++-dev = "${includedir}/c++/${PV} \
47 ${libdir}/libstdc++.so \
48 ${libdir}/libstdc++.la \
49 ${libdir}/libstdc++.a \
50 ${libdir}/libsupc++.la \
51 ${libdir}/libsupc++.a"
52
53FILES_${PN}-doc = "${infodir} \
54 ${mandir} \
55 ${libdir}/gcc-lib/${TARGET_SYS}/${PV}/include/README"
56
57SRC_URI = "${GNU_MIRROR}/gcc/releases/gcc-${PV}/gcc-${PV}.tar.bz2 \
58 file://arm-gotoff.dpatch;patch=1;pnum=0 \
59 file://arm-ldm.dpatch;patch=1;pnum=0 \
60 file://arm-tune.patch;patch=1;pnum=0 \
61 file://arm-ldm-peephole.patch;patch=1;pnum=0 \
62 file://libibery-crosstool.patch;patch=1;pnum=1 \
63 file://reverse-compare.patch;patch=1 \
64 file://gcc34-15089.patch;patch=1 \
65 file://gcc-uclibc-3.3-100-conf.patch;patch=1 \
66 file://gcc-uclibc-3.3-110-conf.patch;patch=1 \
67 file://gcc-uclibc-3.3-120-softfloat.patch;patch=1 \
68 file://gcc-uclibc-3.3-200-code.patch;patch=1 \
69 file://bash3.patch;patch=1"
70
71PREMIRRORS_prepend () {
72${GNU_MIRROR}/gcc/releases/ ftp://gcc.gnu.org/pub/gcc/releases/
73${GNU_MIRROR}/gcc/releases/ http://gcc.get-software.com/releases/
74}
75
76S = "${WORKDIR}/gcc-${PV}"
77B = "${S}/build.${HOST_SYS}.${TARGET_SYS}"
78
79EXTRA_OECONF = "${@['--enable-clocale=generic', ''][bb.data.getVar('USE_NLS', d, 1) != 'no']} \
80 --with-gnu-ld \
81 --enable-shared \
82 --enable-multilib \
83 --enable-target-optspace \
84 --enable-languages=c,c++,f77 \
85 --enable-threads=posix \
86 --enable-c99 \
87 --enable-long-long \
88 --enable-symvers=gnu \
89 --program-prefix=${TARGET_PREFIX} \
90 ${EXTRA_OECONF_PATHS} \
91 ${EXTRA_OECONF_DEP}"
92
93EXTRA_OECONF_PATHS = "--with-local-prefix=${prefix}/local \
94 --with-gxx-include-dir=${includedir}/c++/${PV}"
95
96EXTRA_OECONF_DEP = ""
97EXTRA_OECONF_uclibc = "--disable-__cxa_atexit"
98EXTRA_OECONF_glibc = "--enable-__cxa_atexit"
99EXTRA_OECONF += "${@get_gcc_fpu_setting(bb, d)}"
100
101require gcc-fpu.inc
102
103python __anonymous () {
104 import bb, re
105 if (re.match('linux-uclibc$', bb.data.getVar('TARGET_OS', d, 1)) != None):
106 bb.data.setVar('EXTRA_OECONF_DEP', '${EXTRA_OECONF_uclibc}', d)
107 elif (re.match('linux$', bb.data.getVar('TARGET_OS', d, 1)) != None):
108 bb.data.setVar('EXTRA_OECONF_DEP', '${EXTRA_OECONF_glibc}', d)
109}
110
111do_configure () {
112 # Setup these vars for cross building only
113 if [ "${BUILD_SYS}" != "${HOST_SYS}" ]; then
114 export CC_FOR_TARGET="${CCACHE} ${HOST_PREFIX}gcc"
115 export GCC_FOR_TARGET="${CCACHE} ${HOST_PREFIX}gcc"
116 export CXX_FOR_TARGET="${CCACHE} ${HOST_PREFIX}g++"
117 export AS_FOR_TARGET="${HOST_PREFIX}as"
118 export LD_FOR_TARGET="${HOST_PREFIX}ld"
119 export NM_FOR_TARGET="${HOST_PREFIX}nm"
120 export AR_FOR_TARGET="${HOST_PREFIX}ar"
121 export RANLIB_FOR_TARGET="${HOST_PREFIX}ranlib"
122 fi
123 (cd ${S} && gnu-configize) || die "failure running gnu-configize"
124 oe_runconf
125}
126
127do_install () {
128 autotools_do_install
129
130 # Cleanup some of the gcc-lib stuff
131 rm -rf ${D}${libdir}/gcc-lib/${TARGET_SYS}/${PV}/install-tools
132
133 # Move libgcc_s into /lib
134 mkdir -p ${D}${base_libdir}
135 mv -f ${D}${libdir}/libgcc_s.so.* ${D}${base_libdir}
136 rm -f ${D}${libdir}/libgcc_s.so
137 ln -sf `echo ${libdir}/gcc-lib/${TARGET_SYS}/${PV} | tr -s / |
138 sed -e 's,^/,,' -e 's,[^/]*,..,g'`/lib/libgcc_s.so.? \
139 ${D}${libdir}/gcc-lib/${TARGET_SYS}/${PV}/libgcc_s.so
140
141 # Cleanup manpages..
142 rm -rf ${D}${mandir}/man7
143 mv ${D}${mandir}/man1/cpp.1 \
144 ${D}${mandir}/man1/${TARGET_SYS}-cpp.1
145 mv ${D}${mandir}/man1/gcov.1 \
146 ${D}${mandir}/man1/${TARGET_SYS}-gcov.1
147
148 # We use libiberty from binutils
149 rm -f ${D}${libdir}/libiberty.a
150
151 cd ${D}${bindir}
152
153 # We care about g++ not c++
154 rm -f *c++
155
156 # We don't care about the gcc-<version> ones for this
157 rm -f *gcc-?.?*
158
159 # These sometimes show up, they are strange, we remove them
160 rm -f ${TARGET_ARCH}-*${TARGET_ARCH}-*
161
162 # Symlinks so we can use these trivially on the target
163 ln -sf ${TARGET_SYS}-g77 g77
164 ln -sf ${TARGET_SYS}-g++ g++
165 ln -sf ${TARGET_SYS}-gcc gcc
166 ln -sf g77 f77
167 ln -sf g++ c++
168 ln -sf gcc cc
169}