summaryrefslogtreecommitdiffstats
path: root/meta/packages/gcc/gcc-csl-arm-2008q1.inc
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-07-18 08:21:43 +0000
committerRichard Purdie <richard@openedhand.com>2008-07-18 08:21:43 +0000
commit94241d92478a0d1c9b36d63c886994cee72dcfec (patch)
tree2f865356c3edf9a07935a38a0d48a4534b3b26d3 /meta/packages/gcc/gcc-csl-arm-2008q1.inc
parent382427b65dce609add09edd7c66d110111b83736 (diff)
downloadpoky-94241d92478a0d1c9b36d63c886994cee72dcfec.tar.gz
Add gcc CSL 2008q1 from OE.dev
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4866 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/gcc/gcc-csl-arm-2008q1.inc')
-rw-r--r--meta/packages/gcc/gcc-csl-arm-2008q1.inc50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/packages/gcc/gcc-csl-arm-2008q1.inc b/meta/packages/gcc/gcc-csl-arm-2008q1.inc
new file mode 100644
index 0000000000..d4f6ef1e37
--- /dev/null
+++ b/meta/packages/gcc/gcc-csl-arm-2008q1.inc
@@ -0,0 +1,50 @@
1require gcc-common.inc
2
3BINV = "4.2.3"
4PV = "4.2.3+csl-arm-2008q1-126"
5
6FILESDIR = "${FILE_DIRNAME}/gcc-csl-arm"
7
8SRC_URI = "http://www.codesourcery.com/public/gnu_toolchain/arm-none-eabi/arm-2008q1-126-arm-none-eabi.src.tar.bz2 \
9# file://100-uclibc-conf.patch;patch=1 \
10# file://103-uclibc-conf-noupstream.patch;patch=1 \
11# file://200-uclibc-locale.patch;patch=1 \
12# file://203-uclibc-locale-no__x.patch;patch=1 \
13# file://204-uclibc-locale-wchar_fix.patch;patch=1 \
14# file://205-uclibc-locale-update.patch;patch=1 \
15# file://300-libstdc++-pic.patch;patch=1 \
16# file://302-c99-snprintf.patch;patch=1 \
17# file://303-c99-complex-ugly-hack.patch;patch=1 \
18# file://304-index_macro.patch;patch=1 \
19# file://305-libmudflap-susv3-legacy.patch;patch=1 \
20# file://306-libstdc++-namespace.patch;patch=1 \
21# file://307-locale_facets.patch;patch=1 \
22# file://402-libbackend_dep_gcov-iov.h.patch;patch=1 \
23# file://602-sdk-libstdc++-includes.patch;patch=1 \
24 file://gcc41-configure.in.patch;patch=1 \
25 file://arm-nolibfloat.patch;patch=1 \
26 file://arm-softfloat.patch;patch=1 \
27 file://zecke-xgcc-cpp.patch;patch=1 \
28# file://gfortran.patch;patch=1 \
29# file://fortran-static-linking.patch;patch=1 \
30# file://gcc-configure-no-fortran.patch;patch=1;pnum=1 \
31# file://gcc-new-makeinfo.patch;patch=1 \
32"
33
34
35S = "${WORKDIR}/gcc-4.2"
36
37do_unpack2() {
38 cd ${WORKDIR}
39 tar -xvjf ./arm-2008q1-126-arm-none-eabi/gcc-2008q1-126.tar.bz2
40}
41
42# Language Overrides
43FORTRAN = ""
44#FORTRAN_linux-gnueabi = ",fortran"
45#JAVA = ",java"
46
47EXTRA_OECONF_BASE = "--enable-libssp --disable-bootstrap --disable-libgomp --disable-libmudflap"
48ARM_INSTRUCTION_SET = "arm"
49
50addtask unpack2 after do_unpack before do_patch