summaryrefslogtreecommitdiffstats
path: root/meta/packages/gcc/gcc-csl-arm-2007q3.inc
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-06-06 14:34:02 +0000
committerRichard Purdie <richard@openedhand.com>2008-06-06 14:34:02 +0000
commitd03981d6c1e03400febfaa83ceddce84b10ac2e1 (patch)
tree0046ecda45428664573a455e4625b39b17ff1a7a /meta/packages/gcc/gcc-csl-arm-2007q3.inc
parent76c8b40e44022dc238f81bb9107761d3f7bb30fe (diff)
downloadpoky-d03981d6c1e03400febfaa83ceddce84b10ac2e1.tar.gz
gcc: Add csl 2007q3 from OE.dev
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4605 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/gcc/gcc-csl-arm-2007q3.inc')
-rw-r--r--meta/packages/gcc/gcc-csl-arm-2007q3.inc51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/packages/gcc/gcc-csl-arm-2007q3.inc b/meta/packages/gcc/gcc-csl-arm-2007q3.inc
new file mode 100644
index 0000000000..601b4f0110
--- /dev/null
+++ b/meta/packages/gcc/gcc-csl-arm-2007q3.inc
@@ -0,0 +1,51 @@
1require gcc-common.inc
2
3BINV = "4.2.1"
4PV = "4.2.1+csl-arm-2007q3-53"
5
6FILESPATH = "${FILE_DIRNAME}/gcc-csl-arm-2007q3:${FILE_DIRNAME}/gcc-csl-arm"
7
8SRC_URI = "http://www.codesourcery.com/public/gnu_toolchain/arm-none-eabi/arm-2007q3-53-arm-none-eabi.src.tar.bz2 \
9 file://gcc-new-makeinfo.patch;patch=1 \
10# file://100-uclibc-conf.patch;patch=1 \
11# file://103-uclibc-conf-noupstream.patch;patch=1 \
12# file://200-uclibc-locale.patch;patch=1 \
13# file://203-uclibc-locale-no__x.patch;patch=1 \
14# file://204-uclibc-locale-wchar_fix.patch;patch=1 \
15# file://205-uclibc-locale-update.patch;patch=1 \
16# file://300-libstdc++-pic.patch;patch=1 \
17# file://302-c99-snprintf.patch;patch=1 \
18# file://303-c99-complex-ugly-hack.patch;patch=1 \
19# file://304-index_macro.patch;patch=1 \
20# file://305-libmudflap-susv3-legacy.patch;patch=1 \
21# file://306-libstdc++-namespace.patch;patch=1 \
22# file://307-locale_facets.patch;patch=1 \
23# file://402-libbackend_dep_gcov-iov.h.patch;patch=1 \
24# file://602-sdk-libstdc++-includes.patch;patch=1 \
25 file://gcc41-configure.in.patch;patch=1 \
26 file://arm-nolibfloat.patch;patch=1 \
27 file://arm-softfloat.patch;patch=1 \
28 file://zecke-xgcc-cpp.patch;patch=1 \
29# file://gfortran.patch;patch=1 \
30# file://fortran-static-linking.patch;patch=1 \
31# file://gcc-configure-no-fortran.patch;patch=1;pnum=1 \
32# file://gcc-new-makeinfo.patch;patch=1 \
33"
34
35
36S = "${WORKDIR}/gcc-4.2"
37
38do_unpack2() {
39 cd ${WORKDIR}
40 tar -xvjf ./arm-2007q3-53-arm-none-eabi/gcc-2007q3-53.tar.bz2
41}
42
43# Language Overrides
44FORTRAN = ""
45#FORTRAN_linux-gnueabi = ",fortran"
46#JAVA = ",java"
47
48EXTRA_OECONF_BASE = "--enable-libssp --disable-bootstrap --disable-libgomp --disable-libmudflap"
49ARM_INSTRUCTION_SET = "arm"
50
51addtask unpack2 after do_unpack before do_patch