summaryrefslogtreecommitdiffstats
path: root/meta/packages/gcc/gcc-cross_csl-arm-2007q3.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-09-16 23:09:44 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-09-17 22:24:36 +0100
commitaf85ce4b4e675feb5796f87137c86d70c2f15b9a (patch)
treef19dbb9bcf1eec671b26685458f7cc47ebb3721e /meta/packages/gcc/gcc-cross_csl-arm-2007q3.bb
parent046ae6a38d829048663fe1afb1f67de1fbe2e3b5 (diff)
downloadpoky-af85ce4b4e675feb5796f87137c86d70c2f15b9a.tar.gz
Remove layout_* variables
Remove layout_* variables and replace them with variables specific to the different classes. The layout variables were only useful for the native/cross classes and caused more confusion than they solved. They didn't scale to the sdk class. It now clear a small set of native/cross variables fulfil the needs. This patch also changes native.bbclass to use "/" as the STAGING_DIR which makes sense since we're installing binaries into the locations we're compiling them for. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/gcc/gcc-cross_csl-arm-2007q3.bb')
-rw-r--r--meta/packages/gcc/gcc-cross_csl-arm-2007q3.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/packages/gcc/gcc-cross_csl-arm-2007q3.bb b/meta/packages/gcc/gcc-cross_csl-arm-2007q3.bb
index 4fde67b006..b00bebc5c0 100644
--- a/meta/packages/gcc/gcc-cross_csl-arm-2007q3.bb
+++ b/meta/packages/gcc/gcc-cross_csl-arm-2007q3.bb
@@ -7,7 +7,7 @@ require gcc-package-cross.inc
7 7
8SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 " 8SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
9 9
10EXTRA_OECONF += "--disable-multilib --disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${layout_exec_prefix}" 10EXTRA_OECONF += "--disable-multilib --disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native}"
11 11
12#We don't want i686 linux ending up in the CFLAGS_FOR_TARGET like this: -isystem/OE/angstrom-tmp/staging/i686-linux/usr/include 12#We don't want i686 linux ending up in the CFLAGS_FOR_TARGET like this: -isystem/OE/angstrom-tmp/staging/i686-linux/usr/include
13CFLAGS = "" 13CFLAGS = ""
@@ -16,11 +16,11 @@ LDFLAGS = ""
16 16
17# staging-linkage and cross-linkage recipes don't work anymore, so do it by hand for this backwards CSL toolchain 17# staging-linkage and cross-linkage recipes don't work anymore, so do it by hand for this backwards CSL toolchain
18do_compile_prepend() { 18do_compile_prepend() {
19 ln -sf ${STAGING_DIR_TARGET}${layout_libdir}/crt*.o ${CROSS_DIR}/${TARGET_SYS}/lib/ 19 ln -sf ${STAGING_DIR_TARGET}${target_libdir}/crt*.o ${CROSS_DIR}/${TARGET_SYS}/lib/
20 ln -sf ${STAGING_DIR_TARGET}${layout_libdir}/ld-* ${CROSS_DIR}/${TARGET_SYS}/lib/ 20 ln -sf ${STAGING_DIR_TARGET}${target_libdir}/ld-* ${CROSS_DIR}/${TARGET_SYS}/lib/
21 ln -sf ${STAGING_DIR_TARGET}/lib/libc* ${CROSS_DIR}/${TARGET_SYS}/lib/ 21 ln -sf ${STAGING_DIR_TARGET}/lib/libc* ${CROSS_DIR}/${TARGET_SYS}/lib/
22 sed -i -e 's:gcc_no_link=yes:gcc_no_link=no:' ${S}/libstdc++-v3/configure 22 sed -i -e 's:gcc_no_link=yes:gcc_no_link=no:' ${S}/libstdc++-v3/configure
23 23
24} 24}
25 25
26ARCH_FLAGS_FOR_TARGET += " -L${STAGING_DIR_TARGET}${layout_libdir} -isystem${STAGING_DIR_TARGET}${layout_includedir}" 26ARCH_FLAGS_FOR_TARGET += " -L${STAGING_DIR_TARGET}${target_libdir} -isystem${STAGING_DIR_TARGET}${target_includedir}"