summaryrefslogtreecommitdiffstats
path: root/meta/packages/gcc/gcc-cross-initial_3.3.4.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-07-21 10:10:31 +0000
committerRichard Purdie <richard@openedhand.com>2006-07-21 10:10:31 +0000
commitb2f192faabe412adce79534e22efe9fb69ee40e2 (patch)
tree7076c49d4286f8a1733650bd8fbc7161af200d57 /meta/packages/gcc/gcc-cross-initial_3.3.4.bb
parent2cf0eadf9f730027833af802d7e6c90b44248f80 (diff)
downloadpoky-b2f192faabe412adce79534e22efe9fb69ee40e2.tar.gz
Rename /openembedded/ -> /meta/
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@530 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/gcc/gcc-cross-initial_3.3.4.bb')
-rw-r--r--meta/packages/gcc/gcc-cross-initial_3.3.4.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/packages/gcc/gcc-cross-initial_3.3.4.bb b/meta/packages/gcc/gcc-cross-initial_3.3.4.bb
new file mode 100644
index 0000000000..e3b365da18
--- /dev/null
+++ b/meta/packages/gcc/gcc-cross-initial_3.3.4.bb
@@ -0,0 +1,28 @@
1SECTION = "devel"
2include gcc-cross_${PV}.bb
3
4DEPENDS = "virtual/${TARGET_PREFIX}binutils"
5DEPENDS += "${@['virtual/${TARGET_PREFIX}libc-initial',''][bb.data.getVar('TARGET_ARCH', d, 1) in ['arm', 'armeb', 'mips', 'mipsel']]}"
6PROVIDES = "virtual/${TARGET_PREFIX}gcc-initial"
7
8# This is intended to be a -very- basic config
9EXTRA_OECONF = "--with-local-prefix=${CROSS_DIR}/${TARGET_SYS} \
10 --with-newlib \
11 --disable-shared \
12 --disable-threads \
13 --disable-multilib \
14 --disable-__cxa_atexit \
15 --enable-languages=c \
16 --enable-target-optspace \
17 --program-prefix=${TARGET_PREFIX} \
18 ${@get_gcc_fpu_setting(bb, d)}"
19
20do_stage_prepend () {
21 mkdir -p ${CROSS_DIR}/lib/gcc-lib/${TARGET_SYS}/${PV}
22 ln -sf libgcc.a ${CROSS_DIR}/lib/gcc-lib/${TARGET_SYS}/${PV}/libgcc_eh.a
23}
24
25# Override the method from gcc-cross so we don't try to install libgcc
26do_install () {
27 oe_runmake 'DESTDIR=${D}' install
28}