diff options
author | Nitin A Kamble <nitin.a.kamble@intel.com> | 2010-07-19 02:36:13 -0700 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-07-24 01:38:36 +0100 |
commit | c7c5c34188599bae19991f842a836fe125fa3283 (patch) | |
tree | 5e2e97d48c73cc9d0206a0d57bf2446b8dec8af1 /meta/packages/gcc/gcc-4.5.0/pr35942.patch | |
parent | 722e27e44806558b2ef3e6b7072451981fa5823e (diff) | |
download | poky-c7c5c34188599bae19991f842a836fe125fa3283.tar.gz |
gcc family : upgrade to 4.5.0
Imported OE patches into the poky recipes.
- Use elfutils instead of libelf
Converted OE's svn source into tar ball & a patch.
Added a patch to revert the baseversion to 4.5.0
Merge OE & poky extra_oeconf_options
Fix the zlib (inside gcc) make issue by providing the --with-system-zlib switch in EXTRA_OECONF
Found out that some header file dirs were soft linked to non-existing
locations like c_std. Changed the configure options to point them to
existing locations like c_global.
gcc-cross-canadian_4.5.0: fix configure issue
Thanks to Saul Wold for providing poky gcc patches rebased to the 4.5.0
sources.
Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/packages/gcc/gcc-4.5.0/pr35942.patch')
-rw-r--r-- | meta/packages/gcc/gcc-4.5.0/pr35942.patch | 38 |
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/packages/gcc/gcc-4.5.0/pr35942.patch b/meta/packages/gcc/gcc-4.5.0/pr35942.patch new file mode 100644 index 0000000000..da610f5189 --- /dev/null +++ b/meta/packages/gcc/gcc-4.5.0/pr35942.patch | |||
@@ -0,0 +1,38 @@ | |||
1 | Fix PR 35942: remove -lstdc++ from libtool postdeps for CXX. | ||
2 | |||
3 | libstdc++-v3/ChangeLog: | ||
4 | 2010-01-04 Ralf Wildenhues <Ralf.Wildenhues@gmx.de> | ||
5 | |||
6 | PR libstdc++/35942 | ||
7 | * configure.ac: Remove -lstdc++ from libtool's postdeps_CXX. | ||
8 | * configure: Regenerate. | ||
9 | |||
10 | |||
11 | Index: gcc-4.3.3/libstdc++-v3/configure | ||
12 | =================================================================== | ||
13 | --- gcc-4.3.3.orig/libstdc++-v3/configure 2010-03-26 17:57:51.000000000 +0000 | ||
14 | +++ gcc-4.3.3/libstdc++-v3/configure 2010-03-26 17:57:58.000000000 +0000 | ||
15 | @@ -13759,6 +13759,9 @@ | ||
16 | |||
17 | |||
18 | |||
19 | +# Eliminate -lstdc++ addition to postdeps for cross compiles. | ||
20 | +postdeps_CXX=`echo " $postdeps_CXX " | sed 's, -lstdc++ ,,g'` | ||
21 | + | ||
22 | # Possibly disable most of the library. | ||
23 | ## TODO: Consider skipping unncessary tests altogether in this case, rather | ||
24 | ## than just ignoring the results. Faster /and/ more correct, win win. | ||
25 | Index: gcc-4.3.3/libstdc++-v3/configure.ac | ||
26 | =================================================================== | ||
27 | --- gcc-4.3.3.orig/libstdc++-v3/configure.ac 2010-03-26 17:57:54.000000000 +0000 | ||
28 | +++ gcc-4.3.3/libstdc++-v3/configure.ac 2010-03-26 17:57:58.000000000 +0000 | ||
29 | @@ -89,6 +89,9 @@ | ||
30 | AC_SUBST(enable_shared) | ||
31 | AC_SUBST(enable_static) | ||
32 | |||
33 | +# Eliminate -lstdc++ addition to postdeps for cross compiles. | ||
34 | +postdeps_CXX=`echo " $postdeps_CXX " | sed 's, -lstdc++ ,,g'` | ||
35 | + | ||
36 | # Possibly disable most of the library. | ||
37 | ## TODO: Consider skipping unncessary tests altogether in this case, rather | ||
38 | ## than just ignoring the results. Faster /and/ more correct, win win. | ||