summaryrefslogtreecommitdiffstats
path: root/meta/packages/gcc/gcc-4.3.3.inc
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-05-22 09:42:20 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-05-22 09:42:20 +0100
commite6a3149428ef2d42d9a9df78a19c2e52496f3deb (patch)
tree368294cd96f741990717234a6819cc60c1b413f6 /meta/packages/gcc/gcc-4.3.3.inc
parentf887fcd665505453412a9f2e2508404e6ec4eea8 (diff)
downloadpoky-e6a3149428ef2d42d9a9df78a19c2e52496f3deb.tar.gz
gcc: Add 4.3.3 and switch to for Moblin
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/gcc/gcc-4.3.3.inc')
-rw-r--r--meta/packages/gcc/gcc-4.3.3.inc70
1 files changed, 70 insertions, 0 deletions
diff --git a/meta/packages/gcc/gcc-4.3.3.inc b/meta/packages/gcc/gcc-4.3.3.inc
new file mode 100644
index 0000000000..0df0e22ffd
--- /dev/null
+++ b/meta/packages/gcc/gcc-4.3.3.inc
@@ -0,0 +1,70 @@
1# No uclibc, armeb and thumb patches - really needs checking
2DEFAULT_PREFERENCE = "-99"
3
4require gcc-common.inc
5
6DEPENDS = "mpfr gmp"
7
8SRC_URI = "ftp://ftp.gnu.org/pub/gnu/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
9 file://fedora/gcc43-c++-builtin-redecl.patch;patch=1;pnum=0 \
10 file://fedora/gcc43-ia64-libunwind.patch;patch=1;pnum=0 \
11 file://fedora/gcc43-java-nomulti.patch;patch=1;pnum=0 \
12 file://fedora/gcc43-ppc32-retaddr.patch;patch=1;pnum=0 \
13 file://fedora/gcc43-pr27898.patch;patch=1;pnum=0 \
14 file://fedora/gcc43-pr32139.patch;patch=1;pnum=0 \
15 file://fedora/gcc43-pr33763.patch;patch=1;pnum=0 \
16 file://fedora/gcc43-rh330771.patch;patch=1;pnum=0 \
17 file://fedora/gcc43-rh341221.patch;patch=1;pnum=0 \
18 file://fedora/gcc43-cpp-pragma.patch;patch=1;pnum=0 \
19 file://fedora/gcc43-java-debug-iface-type.patch;patch=1;pnum=0 \
20 file://fedora/gcc43-libgomp-speedup.patch;patch=1;pnum=0 \
21 file://fedora/gcc43-i386-libgomp.patch;patch=1;pnum=0 \
22 file://fedora/gcc43-rh251682.patch;patch=1;pnum=0 \
23 file://debian/arm-unbreak-eabi-armv4t.dpatch;patch=1 \
24 file://debian/libstdc++-pic.dpatch;patch=1;pnum=0 \
25 file://debian/gcc-ice-hack.dpatch;patch=1;pnum=0 \
26 file://debian/pr30961.dpatch;patch=1;pnum=0 \
27# file://100-uclibc-conf.patch;patch=1 \
28# file://103-uclibc-conf-noupstream.patch;patch=1 \
29# file://200-uclibc-locale.patch;patch=1 \
30# file://203-uclibc-locale-no__x.patch;patch=1 \
31# file://204-uclibc-locale-wchar_fix.patch;patch=1 \
32# file://205-uclibc-locale-update.patch;patch=1 \
33 file://301-missing-execinfo_h.patch;patch=1 \
34# file://302-c99-snprintf.patch;patch=1 \
35# file://303-c99-complex-ugly-hack.patch;patch=1 \
36 file://304-index_macro.patch;patch=1 \
37 file://305-libmudflap-susv3-legacy.patch;patch=1 \
38# file://306-libstdc++-namespace.patch;patch=1 \
39# file://307-locale_facets.patch;patch=1 \
40# file://402-libbackend_dep_gcov-iov.h.patch;patch=1 \
41 file://602-sdk-libstdc++-includes.patch;patch=1 \
42 file://740-sh-pr24836.patch;patch=1 \
43# file://800-arm-bigendian.patch;patch=1 \
44# file://801-arm-bigendian-eabi.patch;patch=1 \
45 file://904-flatten-switch-stmt-00.patch;patch=1 \
46 file://arm-nolibfloat.patch;patch=1 \
47 file://arm-softfloat.patch;patch=1 \
48# file://gcc41-configure.in.patch;patch=1 \
49# file://arm-thumb.patch;patch=1 \
50# file://arm-thumb-cache.patch;patch=1 \
51 file://ldflags.patch;patch=1 \
52 file://zecke-xgcc-cpp.patch;patch=1 \
53 file://cache-amnesia.patch;patch=1 \
54# file://gfortran.patch;patch=1 \
55# file://gcc-4.0.2-e300c2c3.patch;patch=1 \
56# file://pr34130.patch;patch=1 \
57# file://fortran-static-linking.patch;patch=1 \
58# file://intermask-bigendian.patch;patch=1 \
59 file://gcc-arm-frename-registers.patch;patch=1 \
60# file://gcc-release-branch/PR-36500-fix-neon.patch;patch=1 \
61"
62
63SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch;patch=1 "
64
65# Language Overrides
66FORTRAN = ""
67JAVA = ""
68
69EXTRA_OECONF_BASE = " --enable-cheaders=c_std --enable-libssp --disable-bootstrap --disable-libgomp --disable-libmudflap"
70