summaryrefslogtreecommitdiffstats
path: root/meta/packages/gcc/gcc-4.3.2/fortran-static-linking.patch
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-09-19 17:29:23 +0000
committerRichard Purdie <richard@openedhand.com>2008-09-19 17:29:23 +0000
commitb7b275518b11fa4ad468dfe07721200c0b20a9ce (patch)
tree994890c22bf842448781d4118740642d4d6297e5 /meta/packages/gcc/gcc-4.3.2/fortran-static-linking.patch
parent571ddc976b38b38a93adb418e79ddae80f527c15 (diff)
downloadpoky-b7b275518b11fa4ad468dfe07721200c0b20a9ce.tar.gz
gcc: Add 4.3.2 recipes
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5202 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/gcc/gcc-4.3.2/fortran-static-linking.patch')
-rw-r--r--meta/packages/gcc/gcc-4.3.2/fortran-static-linking.patch48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/packages/gcc/gcc-4.3.2/fortran-static-linking.patch b/meta/packages/gcc/gcc-4.3.2/fortran-static-linking.patch
new file mode 100644
index 0000000000..3dd6321dc3
--- /dev/null
+++ b/meta/packages/gcc/gcc-4.3.2/fortran-static-linking.patch
@@ -0,0 +1,48 @@
1f951 (fortran) links to MPFR and GMP of our staging area but when executing
2the command the libs can not be found. Use rpath like all the other apps in
3our staging bin/ directory.
4
5Patch the configure to avoid the regeneration...
6
7Index: gcc-4.2.2/configure
8===================================================================
9--- gcc-4.2.2.orig/configure 2008-01-15 23:23:41.000000000 +0100
10+++ gcc-4.2.2/configure 2008-01-15 23:25:20.000000000 +0100
11@@ -2278,14 +2278,14 @@
12
13
14 if test "x$with_mpfr" != x; then
15- gmplibs="-L$with_mpfr/lib $gmplibs"
16+ gmplibs="-static -L$with_mpfr/lib $gmplibs"
17 gmpinc="-I$with_mpfr/include"
18 fi
19 if test "x$with_mpfr_include" != x; then
20 gmpinc="-I$with_mpfr_include"
21 fi
22 if test "x$with_mpfr_lib" != x; then
23- gmplibs="-L$with_mpfr_lib $gmplibs"
24+ gmplibs="-static -L$with_mpfr_lib $gmplibs"
25 fi
26
27 # Specify a location for gmp
28Index: gcc-4.2.2/configure.in
29===================================================================
30--- gcc-4.2.2.orig/configure.in 2008-01-15 23:23:41.000000000 +0100
31+++ gcc-4.2.2/configure.in 2008-01-15 23:24:36.000000000 +0100
32@@ -1066,14 +1066,14 @@
33 AC_ARG_WITH(mpfr_lib, [ --with-mpfr-lib=PATH Specify the directory for the installed MPFR library])
34
35 if test "x$with_mpfr" != x; then
36- gmplibs="-L$with_mpfr/lib $gmplibs"
37+ gmplibs="-static -L$with_mpfr/lib $gmplibs"
38 gmpinc="-I$with_mpfr/include"
39 fi
40 if test "x$with_mpfr_include" != x; then
41 gmpinc="-I$with_mpfr_include"
42 fi
43 if test "x$with_mpfr_lib" != x; then
44- gmplibs="-L$with_mpfr_lib $gmplibs"
45+ gmplibs="-static -L$with_mpfr_lib $gmplibs"
46 fi
47
48 # Specify a location for gmp