summaryrefslogtreecommitdiffstats
path: root/meta/packages/fontconfig
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-07-21 10:10:31 +0000
committerRichard Purdie <richard@openedhand.com>2006-07-21 10:10:31 +0000
commitb2f192faabe412adce79534e22efe9fb69ee40e2 (patch)
tree7076c49d4286f8a1733650bd8fbc7161af200d57 /meta/packages/fontconfig
parent2cf0eadf9f730027833af802d7e6c90b44248f80 (diff)
downloadpoky-b2f192faabe412adce79534e22efe9fb69ee40e2.tar.gz
Rename /openembedded/ -> /meta/
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@530 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/fontconfig')
-rw-r--r--meta/packages/fontconfig/files/local.conf12
-rw-r--r--meta/packages/fontconfig/files/stop-fc-cache.patch8
-rw-r--r--meta/packages/fontconfig/fontconfig-2.2.95/fc-glyphname.patch19
-rw-r--r--meta/packages/fontconfig/fontconfig-2.2.95/fc-lang.patch18
-rw-r--r--meta/packages/fontconfig/fontconfig-native_2.2.95.bb15
-rw-r--r--meta/packages/fontconfig/fontconfig_2.2.95.bb36
6 files changed, 108 insertions, 0 deletions
diff --git a/meta/packages/fontconfig/files/local.conf b/meta/packages/fontconfig/files/local.conf
new file mode 100644
index 0000000000..ddd7cf9d03
--- /dev/null
+++ b/meta/packages/fontconfig/files/local.conf
@@ -0,0 +1,12 @@
1<?xml version="1.0"?>
2<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
3<!-- /etc/fonts/local.conf file for local customizations -->
4<fontconfig>
5<!-- Enable sub-pixel rendering -->
6 <match target="font">
7 <test qual="all" name="rgba">
8 <const>unknown</const>
9 </test>
10 <edit name="rgba" mode="assign"><const>rgb</const></edit>
11 </match>
12</fontconfig>
diff --git a/meta/packages/fontconfig/files/stop-fc-cache.patch b/meta/packages/fontconfig/files/stop-fc-cache.patch
new file mode 100644
index 0000000000..7b549118f9
--- /dev/null
+++ b/meta/packages/fontconfig/files/stop-fc-cache.patch
@@ -0,0 +1,8 @@
1--- fontconfig-2.2.95/Makefile.am.old 2006-02-07 01:01:01.000000000 +0000
2+++ fontconfig-2.2.95/Makefile.am 2006-02-07 01:01:15.000000000 +0000
3@@ -50,4 +50,4 @@
4 echo " $(INSTALL_DATA) local.conf $(DESTDIR)$(configdir)/local.conf"; \
5 $(INSTALL_DATA) local.conf $(DESTDIR)$(configdir)/local.conf; \
6 fi; fi; fi
7- if [ x$(DESTDIR) = x ]; then fc-cache/fc-cache -f -v; fi
8+# if [ x$(DESTDIR) = x ]; then fc-cache/fc-cache -f -v; fi
diff --git a/meta/packages/fontconfig/fontconfig-2.2.95/fc-glyphname.patch b/meta/packages/fontconfig/fontconfig-2.2.95/fc-glyphname.patch
new file mode 100644
index 0000000000..1afd9324ff
--- /dev/null
+++ b/meta/packages/fontconfig/fontconfig-2.2.95/fc-glyphname.patch
@@ -0,0 +1,19 @@
1--- fontconfig/fc-glyphname/Makefile.am~ 2004-04-14 17:06:35.000000000 +0100
2+++ fontconfig/fc-glyphname/Makefile.am 2004-05-15 11:41:35.000000000 +0100
3@@ -27,6 +27,7 @@
4 TMPL=fcglyphname.tmpl.h
5 STMPL=${top_srcdir}/fc-glyphname/${TMPL}
6 TARG=fcglyphname.h
7+FC_GLYPHNAME=./fc-glyphname
8
9 noinst_PROGRAMS=fc-glyphname
10
11@@ -41,7 +42,7 @@
12
13 $(TARG): $(STMPL) fc-glyphname $(SGLYPHNAME)
14 rm -f $(TARG)
15- ./fc-glyphname $(SGLYPHNAME) < $(STMPL) > $(TARG)
16+ $(FC_GLYPHNAME) $(SGLYPHNAME) < $(STMPL) > $(TARG)
17
18 CLEANFILES=$(TARG)
19
diff --git a/meta/packages/fontconfig/fontconfig-2.2.95/fc-lang.patch b/meta/packages/fontconfig/fontconfig-2.2.95/fc-lang.patch
new file mode 100644
index 0000000000..d08242a377
--- /dev/null
+++ b/meta/packages/fontconfig/fontconfig-2.2.95/fc-lang.patch
@@ -0,0 +1,18 @@
1--- fontconfig/fc-lang/Makefile.am~ 2004-04-14 17:06:36.000000000 +0100
2+++ fontconfig/fc-lang/Makefile.am 2004-05-15 11:22:44.000000000 +0100
3@@ -27,6 +27,7 @@
4 TMPL=fclang.tmpl.h
5 STMPL=${top_srcdir}/fc-lang/fclang.tmpl.h
6 TARG=fclang.h
7+FC_LANG=./fc-lang
8
9 noinst_PROGRAMS=fc-lang
10
11@@ -40,6 +41,6 @@
12
13 $(TARG):$(ORTH) fc-lang $(STMPL)
14 rm -f $(TARG)
15- ./fc-lang -d ${srcdir} $(ORTH) < $(STMPL) > $(TARG)
16+ $(FC_LANG) -d ${srcdir} $(ORTH) < $(STMPL) > $(TARG)
17
18 CLEANFILES=$(TARG)
diff --git a/meta/packages/fontconfig/fontconfig-native_2.2.95.bb b/meta/packages/fontconfig/fontconfig-native_2.2.95.bb
new file mode 100644
index 0000000000..6872db92f1
--- /dev/null
+++ b/meta/packages/fontconfig/fontconfig-native_2.2.95.bb
@@ -0,0 +1,15 @@
1SECTION = "base"
2LICENSE = "BSD"
3include fontconfig_${PV}.bb
4inherit native
5DEPENDS = "freetype-native expat-native zlib-native"
6FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/fontconfig-${PV}"
7SRC_URI += " file://stop-fc-cache.patch;patch=1"
8
9EXTRA_OEMAKE = ""
10
11do_stage () {
12 oe_runmake install
13 install fc-lang/fc-lang ${STAGING_BINDIR}
14 install fc-glyphname/fc-glyphname ${STAGING_BINDIR}
15}
diff --git a/meta/packages/fontconfig/fontconfig_2.2.95.bb b/meta/packages/fontconfig/fontconfig_2.2.95.bb
new file mode 100644
index 0000000000..78b35b1793
--- /dev/null
+++ b/meta/packages/fontconfig/fontconfig_2.2.95.bb
@@ -0,0 +1,36 @@
1SECTION = "libs"
2LICENSE = "BSD"
3DESCRIPTION = "A library for configuring and customizing font access."
4DEPENDS = "expat freetype freetype-native zlib fontconfig-native"
5
6SRC_URI = "http://pdx.freedesktop.org/fontconfig/release/fontconfig-${PV}.tar.gz \
7 file://fc-glyphname.patch;patch=1 \
8 file://fc-lang.patch;patch=1 \
9 file://local.conf"
10PR = "r2"
11
12PACKAGES =+ "fontconfig-utils "
13FILES_fontconfig-utils = "${bindir}/*"
14
15PKG_fontconfig-utils=fontconfig-utils
16
17S = "${WORKDIR}/fontconfig-${PV}"
18
19inherit autotools pkgconfig
20
21export HASDOCBOOK="no"
22
23EXTRA_OECONF = " --disable-docs "
24EXTRA_OEMAKE = "FC_LANG=fc-lang FC_GLYPHNAME=fc-glyphname"
25
26do_stage () {
27 oe_libinstall -so -a -C src libfontconfig ${STAGING_LIBDIR}
28 install -d ${STAGING_INCDIR}/fontconfig
29 for i in ${S}/fontconfig/*.h; do install -m 0644 $i ${STAGING_INCDIR}/fontconfig/; done
30}
31
32do_install () {
33 autotools_do_install
34 install -m 0644 ${WORKDIR}/local.conf ${D}${sysconfdir}/fonts/local.conf
35}
36