summaryrefslogtreecommitdiffstats
path: root/meta/packages/file
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-11-20 15:26:57 +0000
committerRichard Purdie <richard@openedhand.com>2006-11-20 15:26:57 +0000
commit208688156147758579614dafc16d5637088c153b (patch)
tree666acc5aefe2cee027210b87f274fe13a9715939 /meta/packages/file
parente09dab061470154bb14d172f79c5589d232b3c12 (diff)
downloadpoky-208688156147758579614dafc16d5637088c153b.tar.gz
file-native: Add 4.18 from OE.dev
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@886 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/file')
-rw-r--r--meta/packages/file/file-native_4.18.bb8
-rw-r--r--meta/packages/file/file_4.18.bb22
2 files changed, 30 insertions, 0 deletions
diff --git a/meta/packages/file/file-native_4.18.bb b/meta/packages/file/file-native_4.18.bb
new file mode 100644
index 0000000000..63554b01fb
--- /dev/null
+++ b/meta/packages/file/file-native_4.18.bb
@@ -0,0 +1,8 @@
1require file_${PV}.bb
2inherit native
3
4# avoid dependency loop
5DEPENDS = ""
6PR = "r1"
7
8SRC_URI += "file://native-fix.diff;patch=1"
diff --git a/meta/packages/file/file_4.18.bb b/meta/packages/file/file_4.18.bb
new file mode 100644
index 0000000000..697d4ffb9f
--- /dev/null
+++ b/meta/packages/file/file_4.18.bb
@@ -0,0 +1,22 @@
1DESCRIPTION = "File attempts to classify files depending \
2on their contents and prints a description if a match is found."
3SECTION = "console/utils"
4LICENSE = "BSD-ADV"
5DEPENDS = "file-native"
6
7SRC_URI = "ftp://ftp.astron.com/pub/file/file-${PV}.tar.gz \
8 file://dump \
9 file://filesystems"
10S = "${WORKDIR}/file-${PV}"
11
12inherit autotools
13
14do_configure_prepend() {
15 sed -i -e 's,$(top_builddir)/src/file,file,' ${S}/magic/Makefile.am
16 cp ${WORKDIR}/dump ${S}/magic/Magdir/
17 cp ${WORKDIR}/filesystems ${S}/magic/Magdir/
18}
19
20do_stage() {
21 autotools_stage_all
22}