summaryrefslogtreecommitdiffstats
path: root/meta/packages/fakeroot/fakeroot-native_1.2.13.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-07-21 10:10:31 +0000
committerRichard Purdie <richard@openedhand.com>2006-07-21 10:10:31 +0000
commitb2f192faabe412adce79534e22efe9fb69ee40e2 (patch)
tree7076c49d4286f8a1733650bd8fbc7161af200d57 /meta/packages/fakeroot/fakeroot-native_1.2.13.bb
parent2cf0eadf9f730027833af802d7e6c90b44248f80 (diff)
downloadpoky-b2f192faabe412adce79534e22efe9fb69ee40e2.tar.gz
Rename /openembedded/ -> /meta/
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@530 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/fakeroot/fakeroot-native_1.2.13.bb')
-rw-r--r--meta/packages/fakeroot/fakeroot-native_1.2.13.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/packages/fakeroot/fakeroot-native_1.2.13.bb b/meta/packages/fakeroot/fakeroot-native_1.2.13.bb
new file mode 100644
index 0000000000..cc3dfd2231
--- /dev/null
+++ b/meta/packages/fakeroot/fakeroot-native_1.2.13.bb
@@ -0,0 +1,19 @@
1SECTION = "base"
2PR = "r0"
3include fakeroot_${PV}.bb
4inherit native
5
6SRC_URI += "file://fix-prefix.patch;patch=1"
7S = "${WORKDIR}/fakeroot-${PV}"
8
9EXTRA_OECONF = " --program-prefix="
10
11# Compatability for the rare systems not using or having SYSV
12python () {
13 if bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
14 bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ', d)
15}
16
17do_stage_append () {
18 oe_libinstall -so libfakeroot ${STAGING_LIBDIR}/libfakeroot/
19}