summaryrefslogtreecommitdiffstats
path: root/meta/packages/fakechroot
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-08-28 07:35:22 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-08-28 07:35:22 +0000
commit102af610b9aea879115e0ed89a5336358c7ef8ee (patch)
treec6ac29526a897758af107686a4eb1a99617e15f0 /meta/packages/fakechroot
parent1ec9176a05c20d4643ab5f41e4f462afe278f23d (diff)
downloadpoky-102af610b9aea879115e0ed89a5336358c7ef8ee.tar.gz
fakechroot: fix duplicated readlink
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5115 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/fakechroot')
-rw-r--r--meta/packages/fakechroot/fakechroot-native_2.5.bb2
-rw-r--r--meta/packages/fakechroot/fakechroot_2.5.bb3
-rw-r--r--meta/packages/fakechroot/files/fix-readlink.patch32
3 files changed, 35 insertions, 2 deletions
diff --git a/meta/packages/fakechroot/fakechroot-native_2.5.bb b/meta/packages/fakechroot/fakechroot-native_2.5.bb
index efd41c7126..8cb88bdaae 100644
--- a/meta/packages/fakechroot/fakechroot-native_2.5.bb
+++ b/meta/packages/fakechroot/fakechroot-native_2.5.bb
@@ -1,5 +1,5 @@
1SECTION = "base" 1SECTION = "base"
2PR = "r0" 2PR = "r1"
3require fakechroot_${PV}.bb 3require fakechroot_${PV}.bb
4inherit native 4inherit native
5 5
diff --git a/meta/packages/fakechroot/fakechroot_2.5.bb b/meta/packages/fakechroot/fakechroot_2.5.bb
index c791512185..dfe90779bd 100644
--- a/meta/packages/fakechroot/fakechroot_2.5.bb
+++ b/meta/packages/fakechroot/fakechroot_2.5.bb
@@ -2,6 +2,7 @@ SECTION = "base"
2DESCRIPTION = "Gives a fake root environment which can support chroot" 2DESCRIPTION = "Gives a fake root environment which can support chroot"
3LICENSE = "GPL" 3LICENSE = "GPL"
4 4
5SRC_URI = "${DEBIAN_MIRROR}/main/f/fakechroot/fakechroot_${PV}.orig.tar.gz" 5SRC_URI = "${DEBIAN_MIRROR}/main/f/fakechroot/fakechroot_${PV}.orig.tar.gz \
6 file://fix-readlink.patch;patch=1"
6 7
7inherit autotools 8inherit autotools
diff --git a/meta/packages/fakechroot/files/fix-readlink.patch b/meta/packages/fakechroot/files/fix-readlink.patch
new file mode 100644
index 0000000000..f218956790
--- /dev/null
+++ b/meta/packages/fakechroot/files/fix-readlink.patch
@@ -0,0 +1,32 @@
1---
2 src/libfakechroot.c | 4 ++--
3 1 file changed, 2 insertions(+), 2 deletions(-)
4
5--- fakechroot-2.5.orig/src/libfakechroot.c
6+++ fakechroot-2.5/src/libfakechroot.c
7@@ -596,11 +596,11 @@ void fakechroot_init (void)
8 nextsym(open64, "open64");
9 #if !defined(HAVE___OPENDIR2)
10 nextsym(opendir, "opendir");
11 #endif
12 nextsym(pathconf, "pathconf");
13- nextsym(readlink, "readlink");
14+ nextsym(readlink, "own_readlink");
15 nextsym(realpath, "realpath");
16 nextsym(remove, "remove");
17 #ifdef HAVE_REMOVEXATTR
18 nextsym(removexattr, "removexattr");
19 #endif
20@@ -1864,11 +1864,11 @@ long pathconf (const char *path, int nam
21 return next_pathconf(path, name);
22 }
23
24
25 /* #include <unistd.h> */
26-int readlink (const char *path, char *buf, READLINK_TYPE_ARG3)
27+int own_readlink (const char *path, char *buf, READLINK_TYPE_ARG3)
28 {
29 int status;
30 char tmp[FAKECHROOT_MAXPATH], *tmpptr;
31 char *fakechroot_path, *fakechroot_ptr, fakechroot_buf[FAKECHROOT_MAXPATH];
32