diff options
author | Richard Purdie <richard@openedhand.com> | 2007-02-22 08:38:46 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2007-02-22 08:38:46 +0000 |
commit | 21690b1b6efe1815e79b80ec9ba5c700daf9ebc9 (patch) | |
tree | dcb76ee869da12d8e3e7a208a53335332c82ec54 /meta/packages/exmap-console/exmap-console_svn.bb | |
parent | 4caa95d0fca863acd39780d704667528b11cd879 (diff) | |
download | poky-21690b1b6efe1815e79b80ec9ba5c700daf9ebc9.tar.gz |
exmap-console: Use filename to set PV, remove duplication from svn version, set DEPENDS correctly
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1285 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/exmap-console/exmap-console_svn.bb')
-rw-r--r-- | meta/packages/exmap-console/exmap-console_svn.bb | 58 |
1 files changed, 5 insertions, 53 deletions
diff --git a/meta/packages/exmap-console/exmap-console_svn.bb b/meta/packages/exmap-console/exmap-console_svn.bb index 9e93847e6d..684ff6aac3 100644 --- a/meta/packages/exmap-console/exmap-console_svn.bb +++ b/meta/packages/exmap-console/exmap-console_svn.bb | |||
@@ -1,59 +1,11 @@ | |||
1 | DESCRIPTION = "console-based exmap" | 1 | require exmap-console.inc |
2 | HOMEPAGE = "http://www.o-hand.com" | ||
3 | SECTION = "devel" | ||
4 | LICENSE = "GPL" | ||
5 | PR = "r10" | ||
6 | 2 | ||
3 | PR = "r10" | ||
7 | PV = "0.4+svn${SRCDATE}" | 4 | PV = "0.4+svn${SRCDATE}" |
8 | MYPV := "${PV}" | ||
9 | |||
10 | SRC_URI = \ | ||
11 | "svn://svn.o-hand.com/repos/misc/trunk;module=exmap-console;proto=http" | ||
12 | 5 | ||
13 | inherit module-base | 6 | SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=exmap-console;proto=http" |
14 | inherit autotools | ||
15 | |||
16 | PACKAGES += "exmap-server kernel-module-exmap" | ||
17 | |||
18 | FILES_${PN}= "${bindir}/exmap ${bindir}/exmapd" | ||
19 | PACKAGE_ARCH_exmap-console = "${TARGET_ARCH}" | ||
20 | RDEPENDS_exmap-console += "kernel-module-exmap" | ||
21 | |||
22 | FILES_exmap-server = "${bindir}/exmapserver" | ||
23 | PACKAGE_ARCH_exmap-server = "${TARGET_ARCH}" | ||
24 | RDEPENDS_exmap-server += "kernel-module-exmap" | ||
25 | |||
26 | FILES_kernel-module-exmap = "${base_libdir}" | ||
27 | PACKAGE_ARCH_kernel-module-exmap = "${MACHINE_ARCH}" | ||
28 | PV_kernel-module-exmap = "${MYPV}-${KERNEL_VERSION}" | ||
29 | RDEPENDS_kernel-module-exmap += "kernel (${KERNEL_VERSION})" | ||
30 | DEPENDS_kernel-module-exmap += "virtual/kernel" | ||
31 | 7 | ||
32 | S = "${WORKDIR}/exmap-console" | 8 | S = "${WORKDIR}/exmap-console" |
33 | 9 | ||
34 | export MODULE_PATH="${D}${base_libdir}/modules/${KERNEL_VERSION}" | 10 | MYPV := "${PV}" |
35 | 11 | PV_kernel-module-exmap = "${MYPV}-${KERNEL_VERSION}" | |
36 | do_compile() { | ||
37 | cd ${S}/src | ||
38 | make | ||
39 | |||
40 | cd ${S}/kernel | ||
41 | unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS | ||
42 | oe_runmake KERNEL_PATH=${STAGING_KERNEL_DIR} \ | ||
43 | KERNEL_SRC=${STAGING_KERNEL_DIR} \ | ||
44 | KERNEL_VERSION=${KERNEL_VERSION} \ | ||
45 | CC="${KERNEL_CC}" LD="${KERNEL_LD}" \ | ||
46 | ${MAKE_TARGETS} | ||
47 | } | ||
48 | |||
49 | pkg_postinst_append_kernel-module-exmap () { | ||
50 | if [ -n "$D" ]; then | ||
51 | exit 1 | ||
52 | fi | ||
53 | depmod -a | ||
54 | update-modules || true | ||
55 | } | ||
56 | |||
57 | pkg_postrm_append_kernel-module-exmap () { | ||
58 | update-modules || true | ||
59 | } | ||