diff options
author | Nitin A Kamble <nitin.a.kamble@intel.com> | 2010-06-24 06:38:08 -0700 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-07-01 14:13:06 +0100 |
commit | 87381753d4b010ea86624cc373293e77a131235d (patch) | |
tree | 2eec06c975a21f66f81cead5f81923c9d88e97ec /meta/packages/elfutils | |
parent | 7e01b2f759b7222b081f7ab058012441ed296ea6 (diff) | |
download | poky-87381753d4b010ea86624cc373293e77a131235d.tar.gz |
elfutils: add a patch to fix latest prelink build
Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/packages/elfutils')
-rw-r--r-- | meta/packages/elfutils/elfutils-0.131/prelink_build_fix.patch | 70 | ||||
-rw-r--r-- | meta/packages/elfutils/elfutils_0.131.bb | 5 |
2 files changed, 74 insertions, 1 deletions
diff --git a/meta/packages/elfutils/elfutils-0.131/prelink_build_fix.patch b/meta/packages/elfutils/elfutils-0.131/prelink_build_fix.patch new file mode 100644 index 0000000000..3c3cf79d91 --- /dev/null +++ b/meta/packages/elfutils/elfutils-0.131/prelink_build_fix.patch | |||
@@ -0,0 +1,70 @@ | |||
1 | newer prelink building (configure) fails like this | ||
2 | checking libelf.h usability... no | ||
3 | checking libelf.h presence... yes | ||
4 | configure: WARNING: libelf.h: present but cannot be compiled | ||
5 | |||
6 | Found a bug report suggesting fix for the issue here: | ||
7 | http://bugs.gentoo.org/204502 | ||
8 | The bug report says: | ||
9 | ------- Comment #7 From SpanKY 2008-01-06 04:53:16 0000 [reply] ------- | ||
10 | do `sed -i 's:off64_t:__off64_t:'` on libelf.h ... that lets me build prelink | ||
11 | |||
12 | 2010/06/24 | ||
13 | Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com> | ||
14 | |||
15 | Index: elfutils-0.131/libelf/libelf.h | ||
16 | =================================================================== | ||
17 | --- elfutils-0.131.orig/libelf/libelf.h | ||
18 | +++ elfutils-0.131/libelf/libelf.h | ||
19 | @@ -95,7 +95,7 @@ typedef struct | ||
20 | Elf_Type d_type; /* Type of this piece of data. */ | ||
21 | unsigned int d_version; /* ELF version. */ | ||
22 | size_t d_size; /* Size in bytes. */ | ||
23 | - off64_t d_off; /* Offset into section. */ | ||
24 | + __off64_t d_off; /* Offset into section. */ | ||
25 | size_t d_align; /* Alignment in section. */ | ||
26 | } Elf_Data; | ||
27 | |||
28 | @@ -157,7 +157,7 @@ typedef struct | ||
29 | uid_t ar_uid; /* User ID. */ | ||
30 | gid_t ar_gid; /* Group ID. */ | ||
31 | mode_t ar_mode; /* File mode. */ | ||
32 | - off64_t ar_size; /* File size. */ | ||
33 | + __off64_t ar_size; /* File size. */ | ||
34 | char *ar_rawname; /* Original name of archive member. */ | ||
35 | } Elf_Arhdr; | ||
36 | |||
37 | @@ -198,13 +198,13 @@ extern Elf_Cmd elf_next (Elf *__elf); | ||
38 | extern int elf_end (Elf *__elf); | ||
39 | |||
40 | /* Update ELF descriptor and write file to disk. */ | ||
41 | -extern off64_t elf_update (Elf *__elf, Elf_Cmd __cmd); | ||
42 | +extern __off64_t elf_update (Elf *__elf, Elf_Cmd __cmd); | ||
43 | |||
44 | /* Determine what kind of file is associated with ELF. */ | ||
45 | extern Elf_Kind elf_kind (Elf *__elf) __attribute__ ((__pure__)); | ||
46 | |||
47 | /* Get the base offset for an object file. */ | ||
48 | -extern off64_t elf_getbase (Elf *__elf); | ||
49 | +extern __off64_t elf_getbase (Elf *__elf); | ||
50 | |||
51 | |||
52 | /* Retrieve file identification data. */ | ||
53 | @@ -302,7 +302,7 @@ extern Elf_Data *elf_newdata (Elf_Scn *_ | ||
54 | would be for TYPE. The resulting Elf_Data pointer is valid until | ||
55 | elf_end (ELF) is called. */ | ||
56 | extern Elf_Data *elf_getdata_rawchunk (Elf *__elf, | ||
57 | - off64_t __offset, size_t __size, | ||
58 | + __off64_t __offset, size_t __size, | ||
59 | Elf_Type __type); | ||
60 | |||
61 | |||
62 | @@ -314,7 +314,7 @@ extern char *elf_strptr (Elf *__elf, siz | ||
63 | extern Elf_Arhdr *elf_getarhdr (Elf *__elf); | ||
64 | |||
65 | /* Return offset in archive for current file ELF. */ | ||
66 | -extern off64_t elf_getaroff (Elf *__elf); | ||
67 | +extern __off64_t elf_getaroff (Elf *__elf); | ||
68 | |||
69 | /* Select archive element at OFFSET. */ | ||
70 | extern size_t elf_rand (Elf *__elf, size_t __offset); | ||
diff --git a/meta/packages/elfutils/elfutils_0.131.bb b/meta/packages/elfutils/elfutils_0.131.bb index 4169b31d27..4ecbf57458 100644 --- a/meta/packages/elfutils/elfutils_0.131.bb +++ b/meta/packages/elfutils/elfutils_0.131.bb | |||
@@ -3,10 +3,13 @@ LICENSE = "OSL" | |||
3 | DESCRIPTION = "A collection of utilities and DSOs to handle compiled objects." | 3 | DESCRIPTION = "A collection of utilities and DSOs to handle compiled objects." |
4 | DEPENDS = "libtool" | 4 | DEPENDS = "libtool" |
5 | 5 | ||
6 | PR = "r1" | ||
7 | |||
6 | SRC_URI = "http://distro.ibiblio.org/pub/linux/distributions/gentoo/distfiles/elfutils-${PV}.tar.gz \ | 8 | SRC_URI = "http://distro.ibiblio.org/pub/linux/distributions/gentoo/distfiles/elfutils-${PV}.tar.gz \ |
7 | file://warnings.patch;patch=1 \ | 9 | file://warnings.patch;patch=1 \ |
8 | file://gcc-4.3_support.diff;patch=1 \ | 10 | file://gcc-4.3_support.diff;patch=1 \ |
9 | file://gnu_inline.diff;patch=1" | 11 | file://gnu_inline.diff;patch=1 \ |
12 | file://prelink_build_fix.patch" | ||
10 | 13 | ||
11 | inherit autotools | 14 | inherit autotools |
12 | 15 | ||