diff options
author | Samuel Ortiz <sameo@openedhand.com> | 2008-10-08 16:06:09 +0000 |
---|---|---|
committer | Samuel Ortiz <sameo@openedhand.com> | 2008-10-08 16:06:09 +0000 |
commit | 3dc1ade034ee427f87a8b6691ed3492e2a2f72e4 (patch) | |
tree | 75536b4c45094e011c3daf2bee9fcda618102a53 /meta/packages/eee-acpi-scripts | |
parent | 93cd99156acebc734f0ffc55c6120d595f5ff210 (diff) | |
download | poky-3dc1ade034ee427f87a8b6691ed3492e2a2f72e4.tar.gz |
eee-acpi: power button support
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5464 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/eee-acpi-scripts')
-rw-r--r-- | meta/packages/eee-acpi-scripts/eee-acpi-scripts_git.bb | 3 | ||||
-rw-r--r-- | meta/packages/eee-acpi-scripts/files/powerbtn.patch | 20 |
2 files changed, 22 insertions, 1 deletions
diff --git a/meta/packages/eee-acpi-scripts/eee-acpi-scripts_git.bb b/meta/packages/eee-acpi-scripts/eee-acpi-scripts_git.bb index 380b3ebb9d..4c26504bd3 100644 --- a/meta/packages/eee-acpi-scripts/eee-acpi-scripts_git.bb +++ b/meta/packages/eee-acpi-scripts/eee-acpi-scripts_git.bb | |||
@@ -3,12 +3,13 @@ DESCRIPTION = "eeePC specific ACPI scripts" | |||
3 | LICENSE="GPL" | 3 | LICENSE="GPL" |
4 | 4 | ||
5 | PV = "0.0+git${SRCREV}" | 5 | PV = "0.0+git${SRCREV}" |
6 | PR = "r2" | 6 | PR = "r3" |
7 | 7 | ||
8 | RDEPENDS = "pm-utils" | 8 | RDEPENDS = "pm-utils" |
9 | 9 | ||
10 | SRC_URI = "git://git.debian.org/git/debian-eeepc/eeepc-acpi-scripts.git;protocol=git \ | 10 | SRC_URI = "git://git.debian.org/git/debian-eeepc/eeepc-acpi-scripts.git;protocol=git \ |
11 | file://remove-doc-check.patch;patch=1 \ | 11 | file://remove-doc-check.patch;patch=1 \ |
12 | file://powerbtn.patch;patch=1 \ | ||
12 | file://policy-funcs " | 13 | file://policy-funcs " |
13 | 14 | ||
14 | S = "${WORKDIR}/git" | 15 | S = "${WORKDIR}/git" |
diff --git a/meta/packages/eee-acpi-scripts/files/powerbtn.patch b/meta/packages/eee-acpi-scripts/files/powerbtn.patch new file mode 100644 index 0000000000..3f79c3e610 --- /dev/null +++ b/meta/packages/eee-acpi-scripts/files/powerbtn.patch | |||
@@ -0,0 +1,20 @@ | |||
1 | --- | ||
2 | actions/power.sh | 3 +++ | ||
3 | events/powerbtn | 2 ++ | ||
4 | 2 files changed, 5 insertions(+) | ||
5 | |||
6 | Index: git/events/powerbtn | ||
7 | =================================================================== | ||
8 | --- /dev/null 1970-01-01 00:00:00.000000000 +0000 | ||
9 | +++ git/events/powerbtn 2008-10-08 17:43:35.000000000 +0200 | ||
10 | @@ -0,0 +1,2 @@ | ||
11 | +event=button/power PWRF | ||
12 | +action=/etc/acpi/actions/power.sh | ||
13 | Index: git/actions/power.sh | ||
14 | =================================================================== | ||
15 | --- /dev/null 1970-01-01 00:00:00.000000000 +0000 | ||
16 | +++ git/actions/power.sh 2008-10-08 17:45:26.000000000 +0200 | ||
17 | @@ -0,0 +1,3 @@ | ||
18 | +#!/bin/sh | ||
19 | + | ||
20 | +/sbin/shutdown -h now "Power button pressed" | ||