summaryrefslogtreecommitdiffstats
path: root/meta/packages/dhcp/files
diff options
context:
space:
mode:
authorQing He <qing.he@intel.com>2010-07-14 22:09:26 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-23 23:53:30 +0100
commit95bb97aeb652bfe9fdd775ebda6036dc9d6770f0 (patch)
tree173a18250ca42b9d4614d531fb9bf5794f2b7c6f /meta/packages/dhcp/files
parent00a42b73b62b602f96afe23b015c6e07098b9926 (diff)
downloadpoky-95bb97aeb652bfe9fdd775ebda6036dc9d6770f0.tar.gz
dhcp: upgrade to 4.1.1-P1
from version 4.1.0 changes: original .bb file is based on dhcp3, whose build system differs from dhcp 4.x, add a new dhcp4.inc and preserve dhcp3.inc for reference, this should fix the conf file location bug of dhclient/dhcpd 4.1.0 - defining _PATH_DHC{LIENT,PD}_CONF in make parameter no longer works, put these definition to includes/site.h - delete upstream version of conf files, which are not used, and with an installation path hardcoded to ${sysconfdir} - similar thing happen for leases file, use new configure option to specify - RANLIB, LIBDIR, etc. as make parameter are no longer necessary Signed-off-by: Qing He <qing.he@intel.com>
Diffstat (limited to 'meta/packages/dhcp/files')
-rw-r--r--meta/packages/dhcp/files/dhcp-3.0.3-dhclient-dbus.patch84
-rw-r--r--meta/packages/dhcp/files/fixincludes.patch10
-rw-r--r--meta/packages/dhcp/files/noattrmode.patch20
3 files changed, 0 insertions, 114 deletions
diff --git a/meta/packages/dhcp/files/dhcp-3.0.3-dhclient-dbus.patch b/meta/packages/dhcp/files/dhcp-3.0.3-dhclient-dbus.patch
deleted file mode 100644
index 579d72f484..0000000000
--- a/meta/packages/dhcp/files/dhcp-3.0.3-dhclient-dbus.patch
+++ /dev/null
@@ -1,84 +0,0 @@
1--- client/scripts/bsdos
2+++ client/scripts/bsdos
3@@ -47,6 +47,11 @@
4 . /etc/dhcp/dhclient-exit-hooks
5 fi
6 # probably should do something with exit status of the local script
7+ if [ x$dhc_dbus != x -a $exit_status -eq 0 ]; then
8+ dbus-send --system --dest=com.redhat.dhcp \
9+ --type=method_call /com/redhat/dhcp/$interface com.redhat.dhcp.set \
10+ 'string:'"`env | grep -Ev '^(PATH|SHLVL|_|PWD|dhc_dbus)\='`"
11+ fi
12 exit $exit_status
13 }
14
15--- client/scripts/freebsd
16+++ client/scripts/freebsd
17@@ -57,6 +57,11 @@
18 . /etc/dhcp/dhclient-exit-hooks
19 fi
20 # probably should do something with exit status of the local script
21+ if [ x$dhc_dbus != x -a $exit_status -eq 0 ]; then
22+ dbus-send --system --dest=com.redhat.dhcp \
23+ --type=method_call /com/redhat/dhcp/$interface com.redhat.dhcp.set \
24+ 'string:'"`env | grep -Ev '^(PATH|SHLVL|_|PWD|dhc_dbus)\='`"
25+ fi
26 exit $exit_status
27 }
28
29--- client/scripts/linux
30+++ client/scripts/linux
31@@ -69,6 +69,11 @@
32 . /etc/dhcp/dhclient-exit-hooks
33 fi
34 # probably should do something with exit status of the local script
35+ if [ x$dhc_dbus != x -a $exit_status -eq 0 ]; then
36+ dbus-send --system --dest=com.redhat.dhcp \
37+ --type=method_call /com/redhat/dhcp/$interface com.redhat.dhcp.set \
38+ 'string:'"`env | grep -Ev '^(PATH|SHLVL|_|PWD|dhc_dbus)\='`"
39+ fi
40 exit $exit_status
41 }
42
43--- client/scripts/netbsd
44+++ client/scripts/netbsd
45@@ -47,6 +47,11 @@
46 . /etc/dhcp/dhclient-exit-hooks
47 fi
48 # probably should do something with exit status of the local script
49+ if [ x$dhc_dbus != x -a $exit_status -eq 0 ]; then
50+ dbus-send --system --dest=com.redhat.dhcp \
51+ --type=method_call /com/redhat/dhcp/$interface com.redhat.dhcp.set \
52+ 'string:'"`env | grep -Ev '^(PATH|SHLVL|_|PWD|dhc_dbus)\='`"
53+ fi
54 exit $exit_status
55 }
56
57--- client/scripts/openbsd
58+++ client/scripts/openbsd
59@@ -47,6 +47,11 @@
60 . /etc/dhcp/dhclient-exit-hooks
61 fi
62 # probably should do something with exit status of the local script
63+ if [ x$dhc_dbus != x -a $exit_status -eq 0 ]; then
64+ dbus-send --system --dest=com.redhat.dhcp \
65+ --type=method_call /com/redhat/dhcp/$interface com.redhat.dhcp.set \
66+ 'string:'"`env | grep -Ev '^(PATH|SHLVL|_|PWD|dhc_dbus)\='`"
67+ fi
68 exit $exit_status
69 }
70
71--- client/scripts/solaris
72+++ client/scripts/solaris
73@@ -47,6 +47,11 @@
74 . /etc/dhcp/dhclient-exit-hooks
75 fi
76 # probably should do something with exit status of the local script
77+ if [ x$dhc_dbus != x -a $exit_status -eq 0 ]; then
78+ dbus-send --system --dest=com.redhat.dhcp \
79+ --type=method_call /com/redhat/dhcp/$interface com.redhat.dhcp.set \
80+ 'string:'"`env | grep -Ev '^(PATH|SHLVL|_|PWD|dhc_dbus)\='`"
81+ fi
82 exit $exit_status
83 }
84
diff --git a/meta/packages/dhcp/files/fixincludes.patch b/meta/packages/dhcp/files/fixincludes.patch
deleted file mode 100644
index 91d99cce22..0000000000
--- a/meta/packages/dhcp/files/fixincludes.patch
+++ /dev/null
@@ -1,10 +0,0 @@
1--- dhcp-3.0.2/common/tr.c~compile 2005-10-13 14:23:37.000000000 +0200
2+++ dhcp-3.0.2/common/tr.c 2005-10-13 14:23:45.000000000 +0200
3@@ -39,6 +39,7 @@
4 #include "includes/netinet/udp.h"
5 #include "includes/netinet/if_ether.h"
6 #include "netinet/if_tr.h"
7+#include <asm/types.h>
8 #include <sys/time.h>
9
10 /*
diff --git a/meta/packages/dhcp/files/noattrmode.patch b/meta/packages/dhcp/files/noattrmode.patch
deleted file mode 100644
index 5c766d6c06..0000000000
--- a/meta/packages/dhcp/files/noattrmode.patch
+++ /dev/null
@@ -1,20 +0,0 @@
1
2#
3# Patch managed by http://www.holgerschurig.de/patcher.html
4#
5
6--- dhcp-3.0.1/includes/dhcpd.h~compile
7+++ dhcp-3.0.1/includes/dhcpd.h
8@@ -306,9 +306,9 @@
9 # define EPHEMERAL_FLAGS (MS_NULL_TERMINATION | \
10 UNICAST_BROADCAST_HACK)
11
12- binding_state_t __attribute__ ((mode (__byte__))) binding_state;
13- binding_state_t __attribute__ ((mode (__byte__))) next_binding_state;
14- binding_state_t __attribute__ ((mode (__byte__))) desired_binding_state;
15+ binding_state_t binding_state;
16+ binding_state_t next_binding_state;
17+ binding_state_t desired_binding_state;
18
19 struct lease_state *state;
20