diff options
author | Ross Burton <ross@openedhand.com> | 2008-01-15 13:48:16 +0000 |
---|---|---|
committer | Ross Burton <ross@openedhand.com> | 2008-01-15 13:48:16 +0000 |
commit | 9c85e50d28bb7fe1c80c5b231686e54f6ef2ac81 (patch) | |
tree | 2c723e670a4308bc545e4919cd305c02522f667b /meta/packages/dbus | |
parent | ba56fb85c8c75c961671073cc9aeeb9f260f6439 (diff) | |
download | poky-9c85e50d28bb7fe1c80c5b231686e54f6ef2ac81.tar.gz |
dbus: bump -bleeding from 1.1.1 to 1.1.2
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3491 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/dbus')
-rw-r--r-- | meta/packages/dbus/dbus-1.1.2/cross.patch (renamed from meta/packages/dbus/dbus-1.1.1/cross.patch) | 0 | ||||
-rw-r--r-- | meta/packages/dbus/dbus-1.1.2/dbus-1.init (renamed from meta/packages/dbus/dbus-1.1.1/dbus-1.init) | 0 | ||||
-rw-r--r-- | meta/packages/dbus/dbus-1.1.2/fix-install-daemon.patch (renamed from meta/packages/dbus/dbus-1.1.1/fix-install-daemon.patch) | 0 | ||||
-rw-r--r-- | meta/packages/dbus/dbus-1.1.2/fix-validate.patch | 49 | ||||
-rw-r--r-- | meta/packages/dbus/dbus-1.1.2/tmpdir.patch (renamed from meta/packages/dbus/dbus-1.1.1/tmpdir.patch) | 0 | ||||
-rw-r--r-- | meta/packages/dbus/dbus-native_1.1.2.bb (renamed from meta/packages/dbus/dbus-native_1.1.1.bb) | 3 | ||||
-rw-r--r-- | meta/packages/dbus/dbus_1.1.2.bb (renamed from meta/packages/dbus/dbus_1.1.1.bb) | 8 |
7 files changed, 56 insertions, 4 deletions
diff --git a/meta/packages/dbus/dbus-1.1.1/cross.patch b/meta/packages/dbus/dbus-1.1.2/cross.patch index 268a3ae3de..268a3ae3de 100644 --- a/meta/packages/dbus/dbus-1.1.1/cross.patch +++ b/meta/packages/dbus/dbus-1.1.2/cross.patch | |||
diff --git a/meta/packages/dbus/dbus-1.1.1/dbus-1.init b/meta/packages/dbus/dbus-1.1.2/dbus-1.init index 0725083c69..0725083c69 100644 --- a/meta/packages/dbus/dbus-1.1.1/dbus-1.init +++ b/meta/packages/dbus/dbus-1.1.2/dbus-1.init | |||
diff --git a/meta/packages/dbus/dbus-1.1.1/fix-install-daemon.patch b/meta/packages/dbus/dbus-1.1.2/fix-install-daemon.patch index c31786357d..c31786357d 100644 --- a/meta/packages/dbus/dbus-1.1.1/fix-install-daemon.patch +++ b/meta/packages/dbus/dbus-1.1.2/fix-install-daemon.patch | |||
diff --git a/meta/packages/dbus/dbus-1.1.2/fix-validate.patch b/meta/packages/dbus/dbus-1.1.2/fix-validate.patch new file mode 100644 index 0000000000..3bfddca603 --- /dev/null +++ b/meta/packages/dbus/dbus-1.1.2/fix-validate.patch | |||
@@ -0,0 +1,49 @@ | |||
1 | commit ae4a1586969aaca534508837830d7d3de4ade070 | ||
2 | Author: Havoc Pennington <hp@redhat.com> | ||
3 | Date: Mon Jul 30 16:16:47 2007 +0000 | ||
4 | |||
5 | 2007-07-30 Havoc Pennington <hp@redhat.com> | ||
6 | |||
7 | * bus/activation-helper.c (check_bus_name): don't use | ||
8 | _dbus_check_valid_bus_name() which is only around with | ||
9 | --enable-checks, instead use _dbus_validate_bus_name(). | ||
10 | Bug #11766 from Diego <diego@pemas.net> | ||
11 | |||
12 | diff --git a/bus/activation-helper.c b/bus/activation-helper.c | ||
13 | index 1636660..36006a4 100644 | ||
14 | --- a/bus/activation-helper.c | ||
15 | +++ b/bus/activation-helper.c | ||
16 | @@ -381,14 +381,20 @@ exec_for_correct_user (char *exec, char *user, DBusError *error) | ||
17 | } | ||
18 | |||
19 | static dbus_bool_t | ||
20 | -check_bus_name (const char *bus_name, DBusError *error) | ||
21 | +check_bus_name (const char *bus_name, | ||
22 | + DBusError *error) | ||
23 | { | ||
24 | - if (!_dbus_check_is_valid_bus_name (bus_name)) | ||
25 | + DBusString str; | ||
26 | + | ||
27 | + _dbus_string_init_const (&str, bus_name); | ||
28 | + if (!_dbus_validate_bus_name (&str, 0, _dbus_string_get_length (&str))) | ||
29 | { | ||
30 | dbus_set_error (error, DBUS_ERROR_SPAWN_SERVICE_NOT_FOUND, | ||
31 | - "bus name '%s' not found\n", bus_name); | ||
32 | + "bus name '%s' is not a valid bus name\n", | ||
33 | + bus_name); | ||
34 | return FALSE; | ||
35 | } | ||
36 | + | ||
37 | return TRUE; | ||
38 | } | ||
39 | |||
40 | @@ -517,7 +523,8 @@ check_dbus_user (BusConfigParser *parser, DBusError *error) | ||
41 | } | ||
42 | |||
43 | dbus_bool_t | ||
44 | -run_launch_helper (const char *bus_name, DBusError *error) | ||
45 | +run_launch_helper (const char *bus_name, | ||
46 | + DBusError *error) | ||
47 | { | ||
48 | BusConfigParser *parser; | ||
49 | dbus_bool_t retval; | ||
diff --git a/meta/packages/dbus/dbus-1.1.1/tmpdir.patch b/meta/packages/dbus/dbus-1.1.2/tmpdir.patch index 838b903f0a..838b903f0a 100644 --- a/meta/packages/dbus/dbus-1.1.1/tmpdir.patch +++ b/meta/packages/dbus/dbus-1.1.2/tmpdir.patch | |||
diff --git a/meta/packages/dbus/dbus-native_1.1.1.bb b/meta/packages/dbus/dbus-native_1.1.2.bb index 72e2190f78..e2fb483824 100644 --- a/meta/packages/dbus/dbus-native_1.1.1.bb +++ b/meta/packages/dbus/dbus-native_1.1.2.bb | |||
@@ -9,9 +9,10 @@ DEPENDS = "glib-2.0-native libxml2-native expat-native" | |||
9 | 9 | ||
10 | DEFAULT_PREFERENCE = "-1" | 10 | DEFAULT_PREFERENCE = "-1" |
11 | 11 | ||
12 | FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/dbus-1.0.2" | 12 | FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/dbus-${PV}" |
13 | SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \ | 13 | SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \ |
14 | file://cross.patch;patch=1 \ | 14 | file://cross.patch;patch=1 \ |
15 | file://fix-validate.patch;patch=1 \ | ||
15 | " | 16 | " |
16 | 17 | ||
17 | inherit autotools pkgconfig gettext native | 18 | inherit autotools pkgconfig gettext native |
diff --git a/meta/packages/dbus/dbus_1.1.1.bb b/meta/packages/dbus/dbus_1.1.2.bb index f2318d42d2..93846bd822 100644 --- a/meta/packages/dbus/dbus_1.1.1.bb +++ b/meta/packages/dbus/dbus_1.1.2.bb | |||
@@ -6,13 +6,15 @@ DESCRIPTION = "message bus system for applications to talk to one another" | |||
6 | LICENSE = "GPL" | 6 | LICENSE = "GPL" |
7 | DEPENDS = "expat glib-2.0 virtual/libintl" | 7 | DEPENDS = "expat glib-2.0 virtual/libintl" |
8 | 8 | ||
9 | PR = "r4" | 9 | PR = "r0" |
10 | 10 | ||
11 | SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \ | 11 | SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \ |
12 | file://tmpdir.patch;patch=1 \ | 12 | file://tmpdir.patch;patch=1 \ |
13 | file://dbus-1.init \ | 13 | file://dbus-1.init \ |
14 | file://cross.patch;patch=1 \ | 14 | file://cross.patch;patch=1 \ |
15 | file://fix-install-daemon.patch;patch=1" | 15 | file://fix-install-daemon.patch;patch=1 \ |
16 | file://fix-validate.patch;patch=1 \ | ||
17 | " | ||
16 | 18 | ||
17 | inherit autotools pkgconfig update-rc.d gettext | 19 | inherit autotools pkgconfig update-rc.d gettext |
18 | 20 | ||
@@ -40,7 +42,7 @@ chgrp "$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || addgroup "$MESSAGEUSER" | |||
40 | chown "$MESSAGEUSER"."$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || adduser --system --home "$MESSAGEHOME" --no-create-home --disabled-password --ingroup "$MESSAGEUSER" "$MESSAGEUSER" | 42 | chown "$MESSAGEUSER"."$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || adduser --system --home "$MESSAGEHOME" --no-create-home --disabled-password --ingroup "$MESSAGEUSER" "$MESSAGEUSER" |
41 | } | 43 | } |
42 | 44 | ||
43 | EXTRA_OECONF = " --disable-tests --disable-asserts --disable-xml-docs \ | 45 | EXTRA_OECONF = " --disable-tests --disable-checks --disable-xml-docs \ |
44 | --disable-doxygen-docs --with-xml=expat --without-x" | 46 | --disable-doxygen-docs --with-xml=expat --without-x" |
45 | 47 | ||
46 | do_stage () { | 48 | do_stage () { |