diff options
author | Richard Purdie <richard@openedhand.com> | 2006-11-21 14:20:37 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2006-11-21 14:20:37 +0000 |
commit | 0405bf5645e53ae375fd54e8f95b140b374421e0 (patch) | |
tree | 6d0fe0c651f550cb5977eb2f617a7a2941c5230c /meta/packages/dbus | |
parent | 902bcfa157f48a012a8c3135d45d3f9479e63136 (diff) | |
download | poky-0405bf5645e53ae375fd54e8f95b140b374421e0.tar.gz |
Add dbus+dbus-native 1.01, dbus-glib+dbus-glib-native 0.72 from OE.dev
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@929 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/dbus')
-rw-r--r-- | meta/packages/dbus/dbus-1.0.1/cross.patch | 10 | ||||
-rw-r--r-- | meta/packages/dbus/dbus-1.0.1/dbus-1.init | 96 | ||||
-rw-r--r-- | meta/packages/dbus/dbus-1.0.1/fix-install-daemon.patch | 13 | ||||
-rw-r--r-- | meta/packages/dbus/dbus-glib-0.72/cross.patch | 12 | ||||
-rw-r--r-- | meta/packages/dbus/dbus-glib-0.72/no-introspect.patch | 19 | ||||
-rw-r--r-- | meta/packages/dbus/dbus-glib-native-0.72/run-with-tmp-session-bus.patch | 23 | ||||
-rw-r--r-- | meta/packages/dbus/dbus-glib-native_0.72.bb | 22 | ||||
-rw-r--r-- | meta/packages/dbus/dbus-glib/no-examples.patch | 8 | ||||
-rw-r--r-- | meta/packages/dbus/dbus-glib_0.72.bb | 29 | ||||
-rw-r--r-- | meta/packages/dbus/dbus-native_1.0.1.bb | 32 | ||||
-rw-r--r-- | meta/packages/dbus/dbus_1.0.1.bb | 67 |
11 files changed, 331 insertions, 0 deletions
diff --git a/meta/packages/dbus/dbus-1.0.1/cross.patch b/meta/packages/dbus/dbus-1.0.1/cross.patch new file mode 100644 index 0000000000..268a3ae3de --- /dev/null +++ b/meta/packages/dbus/dbus-1.0.1/cross.patch | |||
@@ -0,0 +1,10 @@ | |||
1 | --- /tmp/configure.in 2006-11-09 21:47:10.000000000 +0100 | ||
2 | +++ dbus-0.95/configure.in 2006-11-09 21:48:13.108554000 +0100 | ||
3 | @@ -719,6 +719,7 @@ | ||
4 | exit (0); | ||
5 | ]])], | ||
6 | [ac_cv_have_abstract_sockets=yes], | ||
7 | + [ac_cv_have_abstract_sockets=no], | ||
8 | [ac_cv_have_abstract_sockets=no] | ||
9 | )]) | ||
10 | AC_LANG_POP(C) | ||
diff --git a/meta/packages/dbus/dbus-1.0.1/dbus-1.init b/meta/packages/dbus/dbus-1.0.1/dbus-1.init new file mode 100644 index 0000000000..38e7574ad5 --- /dev/null +++ b/meta/packages/dbus/dbus-1.0.1/dbus-1.init | |||
@@ -0,0 +1,96 @@ | |||
1 | #! /bin/sh | ||
2 | # -*- coding: utf-8 -*- | ||
3 | # Debian init.d script for D-BUS | ||
4 | # Copyright © 2003 Colin Walters <walters@debian.org> | ||
5 | |||
6 | set -e | ||
7 | |||
8 | DAEMON=/usr/bin/dbus-daemon | ||
9 | NAME=dbus | ||
10 | DAEMONUSER=messagebus | ||
11 | PIDDIR=/var/run/dbus | ||
12 | PIDFILE=$PIDDIR/pid | ||
13 | UUIDDIR=/var/lib/dbus | ||
14 | DESC="system message bus" | ||
15 | EVENTDIR=/etc/dbus-1/event.d | ||
16 | |||
17 | test -x $DAEMON || exit 0 | ||
18 | |||
19 | # Source defaults file; edit that file to configure this script. | ||
20 | ENABLED=1 | ||
21 | PARAMS="" | ||
22 | if [ -e /etc/default/dbus ]; then | ||
23 | . /etc/default/dbus | ||
24 | fi | ||
25 | |||
26 | test "$ENABLED" != "0" || exit 0 | ||
27 | |||
28 | start_it_up() | ||
29 | { | ||
30 | if [ ! -d $PIDDIR ]; then | ||
31 | mkdir -p $PIDDIR | ||
32 | chown $DAEMONUSER $PIDDIR | ||
33 | chgrp $DAEMONUSER $PIDDIR | ||
34 | fi | ||
35 | if [ -e $PIDFILE ]; then | ||
36 | PIDDIR=/proc/$(cat $PIDFILE) | ||
37 | if [ -d ${PIDDIR} -a "$(readlink -f ${PIDDIR}/exe)" = "${DAEMON}" ]; then | ||
38 | echo "$DESC already started; not starting." | ||
39 | else | ||
40 | echo "Removing stale PID file $PIDFILE." | ||
41 | rm -f $PIDFILE | ||
42 | fi | ||
43 | fi | ||
44 | |||
45 | if [ ! -d $UUIDDIR ]; then | ||
46 | mkdir -p $UUIDDIR | ||
47 | chown $DAEMONUSER $UUIDDIR | ||
48 | chgrp $DAEMONUSER $UUIDDIR | ||
49 | fi | ||
50 | |||
51 | dbus-uuidgen --ensure | ||
52 | |||
53 | echo -n "Starting $DESC: " | ||
54 | start-stop-daemon --start --quiet --pidfile $PIDFILE \ | ||
55 | --user $DAEMONUSER --exec $DAEMON -- --system $PARAMS | ||
56 | echo "$NAME." | ||
57 | if [ -d $EVENTDIR ]; then | ||
58 | run-parts --arg=start $EVENTDIR | ||
59 | fi | ||
60 | } | ||
61 | |||
62 | shut_it_down() | ||
63 | { | ||
64 | if [ -d $EVENTDIR ]; then | ||
65 | run-parts --reverse --arg=stop $EVENTDIR | ||
66 | fi | ||
67 | echo -n "Stopping $DESC: " | ||
68 | start-stop-daemon --stop --quiet --pidfile $PIDFILE \ | ||
69 | --user $DAEMONUSER | ||
70 | # We no longer include these arguments so that start-stop-daemon | ||
71 | # can do its job even given that we may have been upgraded. | ||
72 | # We rely on the pidfile being sanely managed | ||
73 | # --exec $DAEMON -- --system $PARAMS | ||
74 | echo "$NAME." | ||
75 | rm -f $PIDFILE | ||
76 | } | ||
77 | |||
78 | case "$1" in | ||
79 | start) | ||
80 | start_it_up | ||
81 | ;; | ||
82 | stop) | ||
83 | shut_it_down | ||
84 | ;; | ||
85 | restart|force-reload) | ||
86 | shut_it_down | ||
87 | sleep 1 | ||
88 | start_it_up | ||
89 | ;; | ||
90 | *) | ||
91 | echo "Usage: /etc/init.d/$NAME {start|stop|restart|force-reload}" >&2 | ||
92 | exit 1 | ||
93 | ;; | ||
94 | esac | ||
95 | |||
96 | exit 0 | ||
diff --git a/meta/packages/dbus/dbus-1.0.1/fix-install-daemon.patch b/meta/packages/dbus/dbus-1.0.1/fix-install-daemon.patch new file mode 100644 index 0000000000..c31786357d --- /dev/null +++ b/meta/packages/dbus/dbus-1.0.1/fix-install-daemon.patch | |||
@@ -0,0 +1,13 @@ | |||
1 | Index: dbus-0.94/bus/Makefile.am | ||
2 | =================================================================== | ||
3 | --- dbus-0.94.orig/bus/Makefile.am 2006-10-01 17:36:18.000000000 +0200 | ||
4 | +++ dbus-0.94/bus/Makefile.am 2006-10-14 21:40:05.000000000 +0200 | ||
5 | @@ -110,7 +110,7 @@ | ||
6 | $(mkinstalldirs) $(DESTDIR)$(DBUS_DAEMONDIR); \ | ||
7 | chmod 755 $(DESTDIR)$(DBUS_DAEMONDIR); \ | ||
8 | fi | ||
9 | - $(INSTALL_PROGRAM) dbus-daemon $(DESTDIR)$(DBUS_DAEMONDIR) | ||
10 | + $(INSTALL_PROGRAM) .libs/dbus-daemon $(DESTDIR)$(DBUS_DAEMONDIR) | ||
11 | $(mkinstalldirs) $(DESTDIR)$(localstatedir)/run/dbus | ||
12 | $(mkinstalldirs) $(DESTDIR)$(configdir)/system.d | ||
13 | $(mkinstalldirs) $(DESTDIR)$(datadir)/dbus-1/services | ||
diff --git a/meta/packages/dbus/dbus-glib-0.72/cross.patch b/meta/packages/dbus/dbus-glib-0.72/cross.patch new file mode 100644 index 0000000000..b3f41c8507 --- /dev/null +++ b/meta/packages/dbus/dbus-glib-0.72/cross.patch | |||
@@ -0,0 +1,12 @@ | |||
1 | Index: dbus-glib-0.72/configure.ac | ||
2 | =================================================================== | ||
3 | --- dbus-glib-0.72.orig/configure.ac 2006-10-27 10:05:05.000000000 +0200 | ||
4 | +++ dbus-glib-0.72/configure.ac 2006-10-27 10:05:48.000000000 +0200 | ||
5 | @@ -571,6 +571,7 @@ | ||
6 | exit (0); | ||
7 | ]])], | ||
8 | [have_abstract_sockets=yes], | ||
9 | + [have_abstract_sockets=no], | ||
10 | [have_abstract_sockets=no]) | ||
11 | AC_LANG_POP(C) | ||
12 | AC_MSG_RESULT($have_abstract_sockets) | ||
diff --git a/meta/packages/dbus/dbus-glib-0.72/no-introspect.patch b/meta/packages/dbus/dbus-glib-0.72/no-introspect.patch new file mode 100644 index 0000000000..607f0acc9c --- /dev/null +++ b/meta/packages/dbus/dbus-glib-0.72/no-introspect.patch | |||
@@ -0,0 +1,19 @@ | |||
1 | Index: dbus-glib-0.72/tools/Makefile.am | ||
2 | =================================================================== | ||
3 | --- dbus-glib-0.72.orig/tools/Makefile.am 2006-10-25 21:10:36.000000000 +0200 | ||
4 | +++ dbus-glib-0.72/tools/Makefile.am 2006-10-27 10:07:35.000000000 +0200 | ||
5 | @@ -3,14 +3,8 @@ | ||
6 | nodist_libdbus_glib_HEADERS = dbus-glib-bindings.h | ||
7 | libdbus_glibdir = $(includedir)/dbus-1.0/dbus | ||
8 | |||
9 | -dbus-glib-bindings.h: dbus-bus-introspect.xml $(top_builddir)/dbus/dbus-binding-tool$(EXEEXT) | ||
10 | - $(top_builddir)/dbus/dbus-binding-tool --mode=glib-client --prefix=dbus_bus --output=dbus-glib-bindings.h dbus-bus-introspect.xml | ||
11 | - | ||
12 | BUILT_SOURCES = dbus-glib-bindings.h dbus-bus-introspect.xml | ||
13 | |||
14 | -dbus-bus-introspect.xml: | ||
15 | - DBUS_TOP_BUILDDIR=$(top_builddir) dbus-daemon --introspect > dbus-bus-introspect.xml.tmp && mv dbus-bus-introspect.xml.tmp dbus-bus-introspect.xml | ||
16 | - | ||
17 | EXTRA_DIST = run-with-tmp-session-bus.sh session.conf | ||
18 | |||
19 | CLEANFILES = \ | ||
diff --git a/meta/packages/dbus/dbus-glib-native-0.72/run-with-tmp-session-bus.patch b/meta/packages/dbus/dbus-glib-native-0.72/run-with-tmp-session-bus.patch new file mode 100644 index 0000000000..ba117d0309 --- /dev/null +++ b/meta/packages/dbus/dbus-glib-native-0.72/run-with-tmp-session-bus.patch | |||
@@ -0,0 +1,23 @@ | |||
1 | Index: dbus-glib-0.72/tools/run-with-tmp-session-bus.sh | ||
2 | =================================================================== | ||
3 | --- dbus-glib-0.72.orig/tools/run-with-tmp-session-bus.sh 2006-09-27 14:27:25.000000000 +0200 | ||
4 | +++ dbus-glib-0.72/tools/run-with-tmp-session-bus.sh 2006-10-27 10:13:57.000000000 +0200 | ||
5 | @@ -30,16 +30,15 @@ | ||
6 | echo "escaped service dir is: $ESCAPED_SERVICE_DIR" >&2 | ||
7 | |||
8 | ## create a configuration file based on the standard session.conf | ||
9 | -cat $DBUS_TOP_SRCDIR/tools/session.conf | \ | ||
10 | +cat $datadir/dbus/session.conf | \ | ||
11 | sed -e 's/<servicedir>.*$/<servicedir>'$ESCAPED_SERVICE_DIR'<\/servicedir>/g' | \ | ||
12 | sed -e 's/<include.*$//g' \ | ||
13 | > $CONFIG_FILE | ||
14 | |||
15 | echo "Created configuration file $CONFIG_FILE" >&2 | ||
16 | |||
17 | -export PATH=$DBUS_TOP_BUILDDIR/bus:$PATH | ||
18 | ## the libtool script found by the path search should already do this, but | ||
19 | -export LD_LIBRARY_PATH=$DBUS_TOP_BUILDDIR/dbus/.libs:$LD_LIBRARY_PATH | ||
20 | +export LD_LIBRARY_PATH=$libdir:$LD_LIBRARY_PATH | ||
21 | |||
22 | unset DBUS_SESSION_BUS_ADDRESS | ||
23 | unset DBUS_SESSION_BUS_PID | ||
diff --git a/meta/packages/dbus/dbus-glib-native_0.72.bb b/meta/packages/dbus/dbus-glib-native_0.72.bb new file mode 100644 index 0000000000..842ddeb159 --- /dev/null +++ b/meta/packages/dbus/dbus-glib-native_0.72.bb | |||
@@ -0,0 +1,22 @@ | |||
1 | SECTION = "base" | ||
2 | PR = "r0" | ||
3 | HOMEPAGE = "http://www.freedesktop.org/Software/dbus" | ||
4 | DESCRIPTION = "message bus system for applications to talk to one another" | ||
5 | LICENSE = "GPL" | ||
6 | |||
7 | SRC_URI = "http://dbus.freedesktop.org/releases/dbus-glib/dbus-glib-${PV}.tar.gz \ | ||
8 | file://cross.patch;patch=1 \ | ||
9 | file://run-with-tmp-session-bus.patch;patch=1" | ||
10 | |||
11 | inherit autotools pkgconfig gettext native | ||
12 | |||
13 | S = "${WORKDIR}/dbus-glib-${PV}" | ||
14 | FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/dbus-glib-${PV}" | ||
15 | DEPENDS = "glib-2.0-native dbus-native" | ||
16 | |||
17 | do_stage() { | ||
18 | oe_runmake install | ||
19 | install -d ${STAGING_DATADIR}/dbus | ||
20 | install -m 0644 tools/dbus-bus-introspect.xml ${STAGING_DATADIR}/dbus | ||
21 | install -m 0644 tools/dbus-glib-bindings.h ${STAGING_DATADIR}/dbus | ||
22 | } | ||
diff --git a/meta/packages/dbus/dbus-glib/no-examples.patch b/meta/packages/dbus/dbus-glib/no-examples.patch new file mode 100644 index 0000000000..483153db74 --- /dev/null +++ b/meta/packages/dbus/dbus-glib/no-examples.patch | |||
@@ -0,0 +1,8 @@ | |||
1 | --- dbus-glib-0.70/dbus/Makefile.am.orig 2006-07-23 16:04:43.000000000 +0200 | ||
2 | +++ dbus-glib-0.70/dbus/Makefile.am 2006-07-23 16:04:52.000000000 +0200 | ||
3 | @@ -1,4 +1,4 @@ | ||
4 | -SUBDIRS = . examples | ||
5 | +SUBDIRS = . | ||
6 | |||
7 | INCLUDES=-I$(top_srcdir) $(DBUS_CFLAGS) $(DBUS_GLIB_CFLAGS) $(DBUS_GLIB_TOOL_CFLAGS) -DDBUS_COMPILATION=1 -DDBUS_LOCALEDIR=\"$(prefix)/@DATADIRNAME@/locale\" | ||
8 | |||
diff --git a/meta/packages/dbus/dbus-glib_0.72.bb b/meta/packages/dbus/dbus-glib_0.72.bb new file mode 100644 index 0000000000..641f0263a2 --- /dev/null +++ b/meta/packages/dbus/dbus-glib_0.72.bb | |||
@@ -0,0 +1,29 @@ | |||
1 | SECTION = "base" | ||
2 | PR = "r0" | ||
3 | HOMEPAGE = "http://www.freedesktop.org/Software/dbus" | ||
4 | DESCRIPTION = "message bus system for applications to talk to one another" | ||
5 | LICENSE = "GPL" | ||
6 | DEPENDS = "expat glib-2.0 virtual/libintl dbus-glib-native dbus" | ||
7 | |||
8 | SRC_URI = "http://dbus.freedesktop.org/releases/dbus-glib/dbus-glib-${PV}.tar.gz \ | ||
9 | file://cross.patch;patch=1 \ | ||
10 | file://no-examples.patch;patch=1 \ | ||
11 | file://no-introspect.patch;patch=1" | ||
12 | |||
13 | inherit autotools pkgconfig gettext | ||
14 | |||
15 | FILES_${PN} = "${libdir}/lib*.so.*" | ||
16 | FILES_${PN}-dev += "${libdir}/dbus-1.0/include ${bindir}/dbus-glib-tool" | ||
17 | |||
18 | do_configure_prepend() { | ||
19 | install -m 0644 ${STAGING_DIR}/${BUILD_SYS}/share/dbus/dbus-bus-introspect.xml ${S}/tools/ | ||
20 | install -m 0644 ${STAGING_DIR}/${BUILD_SYS}/share/dbus/dbus-glib-bindings.h ${S}/tools/ | ||
21 | } | ||
22 | |||
23 | do_stage () { | ||
24 | oe_libinstall -so -C dbus libdbus-glib-1 ${STAGING_LIBDIR} | ||
25 | |||
26 | autotools_stage_includes | ||
27 | } | ||
28 | |||
29 | FILES_${PN}-dev += "${bindir}/dbus-binding-tool" | ||
diff --git a/meta/packages/dbus/dbus-native_1.0.1.bb b/meta/packages/dbus/dbus-native_1.0.1.bb new file mode 100644 index 0000000000..7e5e4df9dd --- /dev/null +++ b/meta/packages/dbus/dbus-native_1.0.1.bb | |||
@@ -0,0 +1,32 @@ | |||
1 | DESCRIPTION = "message bus system for applications to talk to one another" | ||
2 | HOMEPAGE = "http://www.freedesktop.org/Software/dbus" | ||
3 | LICENSE = "GPL" | ||
4 | SECTION = "base" | ||
5 | |||
6 | PR = "r0" | ||
7 | |||
8 | DEPENDS = "glib-2.0-native libxml2-native expat-native" | ||
9 | |||
10 | DEFAULT_PREFERENCE = "-1" | ||
11 | |||
12 | FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/dbus-1.0.1" | ||
13 | SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \ | ||
14 | file://cross.patch;patch=1 \ | ||
15 | " | ||
16 | |||
17 | inherit autotools pkgconfig gettext native | ||
18 | |||
19 | S = "${WORKDIR}/dbus-${PV}" | ||
20 | |||
21 | EXTRA_OECONF = "--disable-qt --disable-qt3 --disable-gtk --disable-tests \ | ||
22 | --disable-checks --disable-xml-docs --disable-doxygen-docs \ | ||
23 | --with-xml=expat --without-x" | ||
24 | |||
25 | do_stage () { | ||
26 | oe_runmake install | ||
27 | autotools_stage_all | ||
28 | |||
29 | # for dbus-glib-native introspection generation | ||
30 | install -d ${STAGING_DATADIR}/dbus | ||
31 | install -m 0644 bus/session.conf ${STAGING_DATADIR}/dbus/session.conf | ||
32 | } | ||
diff --git a/meta/packages/dbus/dbus_1.0.1.bb b/meta/packages/dbus/dbus_1.0.1.bb new file mode 100644 index 0000000000..4b25589435 --- /dev/null +++ b/meta/packages/dbus/dbus_1.0.1.bb | |||
@@ -0,0 +1,67 @@ | |||
1 | DEFAULT_PREFERENCE = "-1" | ||
2 | |||
3 | SECTION = "base" | ||
4 | HOMEPAGE = "http://www.freedesktop.org/Software/dbus" | ||
5 | DESCRIPTION = "message bus system for applications to talk to one another" | ||
6 | LICENSE = "GPL" | ||
7 | DEPENDS = "expat glib-2.0 virtual/libintl" | ||
8 | |||
9 | PR = "r1" | ||
10 | |||
11 | DEFAULT_PREFERENCE = "-1" | ||
12 | |||
13 | SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \ | ||
14 | file://tmpdir.patch;patch=1 \ | ||
15 | file://dbus-1.init \ | ||
16 | file://fix-segfault.patch;patch=1 \ | ||
17 | file://cross.patch;patch=1 \ | ||
18 | file://fix-install-daemon.patch;patch=1" | ||
19 | |||
20 | inherit autotools pkgconfig update-rc.d gettext | ||
21 | |||
22 | INITSCRIPT_NAME = "dbus-1" | ||
23 | INITSCRIPT_PARAMS = "defaults" | ||
24 | |||
25 | CONFFILES_${PN} = "${sysconfdir}/dbus-1/system.conf ${sysconfdir}/dbus-1/session.conf" | ||
26 | |||
27 | FILES_${PN} = "${bindir}/dbus-daemon ${bindir}/dbus-launch ${bindir}/dbus-cleanup-sockets ${bindir}/dbus-send ${bindir}/dbus-monitor ${bindir}/dbus-uuidgen ${sysconfdir} ${datadir}/dbus-1/services ${libdir}/lib*.so.*" | ||
28 | FILES_${PN}-dev += "${libdir}/dbus-1.0/include" | ||
29 | |||
30 | pkg_postinst_dbus() { | ||
31 | #!/bin/sh | ||
32 | |||
33 | # can't do adduser stuff offline | ||
34 | if [ "x$D" != "x" ]; then | ||
35 | exit 1 | ||
36 | fi | ||
37 | |||
38 | MESSAGEUSER=messagebus | ||
39 | MESSAGEHOME=/var/run/dbus | ||
40 | |||
41 | mkdir -p $MESSAGEHOME || true | ||
42 | chgrp "$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || addgroup "$MESSAGEUSER" | ||
43 | chown "$MESSAGEUSER"."$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || adduser --system --home "$MESSAGEHOME" --no-create-home --disabled-password --ingroup "$MESSAGEUSER" "$MESSAGEUSER" | ||
44 | } | ||
45 | |||
46 | EXTRA_OECONF = "--disable-qt --disable-qt3 --disable-gtk --disable-tests \ | ||
47 | --disable-checks --disable-xml-docs --disable-doxygen-docs \ | ||
48 | --with-xml=expat --without-x" | ||
49 | |||
50 | do_stage () { | ||
51 | oe_libinstall -so -C dbus libdbus-1 ${STAGING_LIBDIR} | ||
52 | |||
53 | autotools_stage_includes | ||
54 | |||
55 | mkdir -p ${STAGING_LIBDIR}/dbus-1.0/include/dbus/ | ||
56 | install -m 0644 dbus/dbus-arch-deps.h ${STAGING_LIBDIR}/dbus-1.0/include/dbus/ | ||
57 | } | ||
58 | |||
59 | do_install_append () { | ||
60 | install -d ${D}${sysconfdir}/init.d | ||
61 | install -m 0755 ${WORKDIR}/dbus-1.init ${D}${sysconfdir}/init.d/dbus-1 | ||
62 | } | ||
63 | |||
64 | python populate_packages_prepend () { | ||
65 | if (bb.data.getVar('DEBIAN_NAMES', d, 1)): | ||
66 | bb.data.setVar('PKG_dbus', 'dbus-1', d) | ||
67 | } | ||