diff options
author | Ross Burton <ross@openedhand.com> | 2008-01-30 18:42:10 +0000 |
---|---|---|
committer | Ross Burton <ross@openedhand.com> | 2008-01-30 18:42:10 +0000 |
commit | b6bb167b3518f646602ffe9c022b38d1ed411263 (patch) | |
tree | 1b6a8a344114634c7a41899228090a0ed2aed9d4 /meta/packages/dbus/dbus_1.1.4.bb | |
parent | b24a3ca1d9a26e660a759de3f7be31ea7dae8292 (diff) | |
download | poky-b6bb167b3518f646602ffe9c022b38d1ed411263.tar.gz |
Switch to using dbus.inc
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3634 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/dbus/dbus_1.1.4.bb')
-rw-r--r-- | meta/packages/dbus/dbus_1.1.4.bb | 63 |
1 files changed, 1 insertions, 62 deletions
diff --git a/meta/packages/dbus/dbus_1.1.4.bb b/meta/packages/dbus/dbus_1.1.4.bb index 2e86f87302..e90a67e290 100644 --- a/meta/packages/dbus/dbus_1.1.4.bb +++ b/meta/packages/dbus/dbus_1.1.4.bb | |||
@@ -1,64 +1,3 @@ | |||
1 | DEFAULT_PREFERENCE = "-1" | 1 | require dbus.inc |
2 | |||
3 | SECTION = "base" | ||
4 | HOMEPAGE = "http://www.freedesktop.org/Software/dbus" | ||
5 | DESCRIPTION = "message bus system for applications to talk to one another" | ||
6 | LICENSE = "GPL" | ||
7 | DEPENDS = "expat glib-2.0 virtual/libintl libx11" | ||
8 | 2 | ||
9 | PR = "r2" | 3 | PR = "r2" |
10 | |||
11 | SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \ | ||
12 | file://tmpdir.patch;patch=1 \ | ||
13 | file://dbus-1.init \ | ||
14 | file://cross.patch;patch=1 \ | ||
15 | file://fix-install-daemon.patch;patch=1 \ | ||
16 | " | ||
17 | |||
18 | inherit autotools pkgconfig update-rc.d gettext | ||
19 | |||
20 | INITSCRIPT_NAME = "dbus-1" | ||
21 | INITSCRIPT_PARAMS = "defaults" | ||
22 | |||
23 | CONFFILES_${PN} = "${sysconfdir}/dbus-1/system.conf ${sysconfdir}/dbus-1/session.conf" | ||
24 | |||
25 | FILES_${PN} = "${bindir}/dbus-daemon ${bindir}/dbus-launch ${bindir}/dbus-cleanup-sockets ${bindir}/dbus-send ${bindir}/dbus-monitor ${bindir}/dbus-uuidgen ${sysconfdir} ${datadir}/dbus-1/services ${libdir}/lib*.so.*" | ||
26 | FILES_${PN}-dev += "${libdir}/dbus-1.0/include" | ||
27 | |||
28 | pkg_postinst_dbus() { | ||
29 | #!/bin/sh | ||
30 | |||
31 | # can't do adduser stuff offline | ||
32 | if [ "x$D" != "x" ]; then | ||
33 | exit 1 | ||
34 | fi | ||
35 | |||
36 | MESSAGEUSER=messagebus | ||
37 | MESSAGEHOME=/var/run/dbus | ||
38 | |||
39 | mkdir -p $MESSAGEHOME || true | ||
40 | chgrp "$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || addgroup "$MESSAGEUSER" | ||
41 | chown "$MESSAGEUSER"."$MESSAGEUSER" "$MESSAGEHOME" 2>/dev/null || adduser --system --home "$MESSAGEHOME" --no-create-home --disabled-password --ingroup "$MESSAGEUSER" "$MESSAGEUSER" | ||
42 | } | ||
43 | |||
44 | EXTRA_OECONF = " --disable-tests --disable-asserts --disable-xml-docs \ | ||
45 | --disable-doxygen-docs --with-xml=expat --with-x" | ||
46 | |||
47 | do_stage () { | ||
48 | oe_libinstall -so -C dbus libdbus-1 ${STAGING_LIBDIR} | ||
49 | |||
50 | autotools_stage_includes | ||
51 | |||
52 | mkdir -p ${STAGING_LIBDIR}/dbus-1.0/include/dbus/ | ||
53 | install -m 0644 dbus/dbus-arch-deps.h ${STAGING_LIBDIR}/dbus-1.0/include/dbus/ | ||
54 | } | ||
55 | |||
56 | do_install_append () { | ||
57 | install -d ${D}${sysconfdir}/init.d | ||
58 | install -m 0755 ${WORKDIR}/dbus-1.init ${D}${sysconfdir}/init.d/dbus-1 | ||
59 | } | ||
60 | |||
61 | python populate_packages_prepend () { | ||
62 | if (bb.data.getVar('DEBIAN_NAMES', d, 1)): | ||
63 | bb.data.setVar('PKG_dbus', 'dbus-1', d) | ||
64 | } | ||