summaryrefslogtreecommitdiffstats
path: root/meta/packages/coreutils/coreutils_5.3.0.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-02-07 15:16:21 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-02-07 15:16:21 +0000
commit890f796ef7944dcba32dcc25d1e11e73ccf7f1cc (patch)
tree212b9ba8ec4abbd1f3dc76b26370b37eb926aa6d /meta/packages/coreutils/coreutils_5.3.0.bb
parent6a402ce57849a03bc1cf219666a3eccec64ce39e (diff)
downloadpoky-890f796ef7944dcba32dcc25d1e11e73ccf7f1cc.tar.gz
coreutils: added 5.3.0 from OE .dev
- 5.3.0 is patched to be buildable with glibc 2.5 git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1262 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/coreutils/coreutils_5.3.0.bb')
-rw-r--r--meta/packages/coreutils/coreutils_5.3.0.bb82
1 files changed, 82 insertions, 0 deletions
diff --git a/meta/packages/coreutils/coreutils_5.3.0.bb b/meta/packages/coreutils/coreutils_5.3.0.bb
new file mode 100644
index 0000000000..61d25543ab
--- /dev/null
+++ b/meta/packages/coreutils/coreutils_5.3.0.bb
@@ -0,0 +1,82 @@
1require coreutils.inc
2
3PR = "r1"
4
5SRC_URI = "ftp://alpha.gnu.org/gnu/coreutils/coreutils-${PV}.tar.bz2 \
6 file://install-cross.patch;patch=1;pnum=0 \
7 file://man.patch;patch=1 \
8 file://rename-tee-for-glibc2.5.patch;patch=1 \
9 file://uptime-pow-lib.patch;patch=1"
10
11# [ gets a special treatment and is not included in this
12bindir_progs = "basename cksum comm csplit cut dir dircolors dirname du \
13 env expand expr factor fmt fold groups head hostid id install \
14 join link logname md5sum mkfifo nice nl nohup od paste pathchk \
15 pinky pr printenv printf ptx readlink seq sha1sum shred sort \
16 split stat sum tac tail tee test tr tsort tty unexpand uniq \
17 unlink users vdir wc who whoami yes \
18 "
19
20# hostname gets a special treatment and is not included in this
21base_bindir_progs = "cat chgrp chmod chown cp date dd echo false kill \
22 ln ls mkdir mknod mv pwd rm rmdir sleep stty sync touch \
23 true uname \
24 "
25
26sbindir_progs= "chroot"
27
28do_install () {
29 autotools_do_install
30
31 # Renaming the utilities that should go in /usr/bin
32 for i in ${bindir_progs}; do mv ${D}${bindir}/$i ${D}${bindir}/$i.${PN}; done
33
34 # Renaming and moving the utilities that should go in /bin (FHS)
35 install -d ${D}${base_bindir}
36 for i in ${base_bindir_progs}; do mv ${D}${bindir}/$i ${D}${base_bindir}/$i.${PN}; done
37
38 # Renaming and moving the utilities that should go in /usr/sbin (FHS)
39 install -d ${D}${sbindir}
40 for i in ${sbindir_progs}; do mv ${D}${bindir}/$i ${D}${sbindir}/$i.${PN}; done
41
42 # [ requires special handling because [.coreutils will cause the sed stuff
43 # in update-alternatives to fail, therefore use lbracket - the name used
44 # for the actual source file.
45 mv ${D}${bindir}/[ ${D}${bindir}/lbracket.${PN}
46 # hostname and uptime separated. busybox's versions are preferred
47 mv ${D}${bindir}/hostname ${D}${base_bindir}/hostname.${PN}
48 mv ${D}${bindir}/uptime ${D}${bindir}/uptime.${PN}
49
50}
51
52pkg_postinst_${PN} () {
53 # The utilities in /usr/bin
54 for i in ${bindir_progs}; do update-alternatives --install ${bindir}/$i $i $i.${PN} 100; done
55
56 # The utilities in /bin
57 for i in ${base_bindir_progs}; do update-alternatives --install ${base_bindir}/$i $i $i.${PN} 100; done
58
59 # The utilities in /usr/sbin
60 for i in ${sbindir_progs}; do update-alternatives --install ${sbindir}/$i $i $i.${PN} 100; done
61
62 # Special cases. uptime and hostname is broken, prefer busybox's version. [ needs to be treated separately.
63 update-alternatives --install ${bindir}/uptime uptime uptime.${PN} 10
64 update-alternatives --install ${base_bindir}/hostname hostname hostname.${PN} 10
65 update-alternatives --install '${bindir}/[' '[' 'lbracket.${PN}' 100
66}
67
68pkg_prerm_${PN} () {
69 # The utilities in /usr/bin
70 for i in ${bindir_progs}; do update-alternatives --remove $i $i.${PN}; done
71
72 # The utilities in /bin
73 for i in ${base_bindir_progs}; do update-alternatives --remove $i $i.${PN}; done
74
75 # The utilities in /usr/sbin
76 for i in ${sbindir_progs}; do update-alternatives --remove $i $i.${PN}; done
77
78 # The special cases
79 update-alternatives --remove hostname hostname.${PN}
80 update-alternatives --remove uptime uptime.${PN}
81 update-alternatives --remove '[' 'lbracket.${PN}'
82}