diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2009-05-26 00:38:51 +0100 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2009-05-26 00:38:51 +0100 |
commit | 1dfcc21eae77e5fc846e0443096261c0ffc9f25f (patch) | |
tree | 140138f8d94147d9e4b82abc2f5589c8fd07ab0c /meta/packages/connman | |
parent | c321cda0a586d73d68c9043de05012632d0356c0 (diff) | |
download | poky-1dfcc21eae77e5fc846e0443096261c0ffc9f25f.tar.gz |
connman: Various fixes so it starts working properly
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/connman')
-rw-r--r-- | meta/packages/connman/connman_git.bb | 17 | ||||
-rw-r--r-- | meta/packages/connman/files/dbusperms.patch | 12 | ||||
-rw-r--r-- | meta/packages/connman/files/dhclientreorder.patch | 40 | ||||
-rw-r--r-- | meta/packages/connman/files/udevfix.patch | 12 |
4 files changed, 73 insertions, 8 deletions
diff --git a/meta/packages/connman/connman_git.bb b/meta/packages/connman/connman_git.bb index 8a6ea26b82..b86c39a779 100644 --- a/meta/packages/connman/connman_git.bb +++ b/meta/packages/connman/connman_git.bb | |||
@@ -1,23 +1,25 @@ | |||
1 | HOMEPAGE = "http://www.moblin.org/projects/projects_connman.php" | 1 | HOMEPAGE = "http://www.moblin.org/projects/projects_connman.php" |
2 | SUMMARY = "Moblin Connection Manager" | 2 | SUMMARY = "Moblin Connection Manager" |
3 | PV = "0.19+git${SRCREV}" | 3 | PV = "0.19+git${SRCREV}" |
4 | PR = "r6" | 4 | PR = "r14" |
5 | S = "${WORKDIR}/git" | 5 | S = "${WORKDIR}/git" |
6 | LICENSE = "GPL" | 6 | LICENSE = "GPL" |
7 | 7 | ||
8 | DEPENDS = "libgdbus dbus glib-2.0 hal" | 8 | DEPENDS = "libgdbus dbus glib-2.0 hal" |
9 | RDEPENDS = "dhcp-client wpa-supplicant resolvconf" | 9 | RDEPENDS_${PN} = "dhcp-client wpa-supplicant resolvconf" |
10 | 10 | ||
11 | EXTRA_OECONF += " \ | 11 | EXTRA_OECONF += " \ |
12 | --enable-ethernet=builtin --enable-wifi=builtin --enable-dhclient=builtin \ | 12 | --enable-ethernet=builtin --enable-wifi=builtin --enable-dhclient=builtin \ |
13 | --enable-bluetooth=builtin --enable-udev --enable-loopback=builtin \ | 13 | --enable-bluetooth=builtin --enable-udev --enable-loopback=builtin \ |
14 | --enable-dnsproxy=builtin --enable-threads --enable-resolvconf=builtin \ | 14 | --enable-dnsproxy=builtin --enable-threads --enable-resolvconf=builtin \ |
15 | --enable-client --enable-fake \ | 15 | --enable-client --enable-fake --with-dhclient=/sbin/dhclient \ |
16 | ac_cv_path_WPASUPPLICANT=/usr/sbin/wpa_supplicant \ | 16 | ac_cv_path_WPASUPPLICANT=/usr/sbin/wpa_supplicant" |
17 | ac_cv_path_DHCLIENT=/sbin/dhclient " | ||
18 | 17 | ||
19 | SRC_URI = "git://git.kernel.org/pub/scm/network/connman/connman.git;protocol=git \ | 18 | SRC_URI = "git://git.kernel.org/pub/scm/network/connman/connman.git;protocol=git \ |
20 | file://connman-install-tests.patch;patch=1 \ | 19 | file://connman-install-tests.patch;patch=1 \ |
20 | file://udevfix.patch;patch=1 \ | ||
21 | file://dhclientreorder.patch;patch=1 \ | ||
22 | file://dbusperms.patch;patch=1 \ | ||
21 | file://connman " | 23 | file://connman " |
22 | 24 | ||
23 | INITSCRIPT_NAME = "connman" | 25 | INITSCRIPT_NAME = "connman" |
@@ -30,15 +32,14 @@ do_install_append() { | |||
30 | } | 32 | } |
31 | 33 | ||
32 | PACKAGES_DYNAMIC = "${PN}-plugin-*" | 34 | PACKAGES_DYNAMIC = "${PN}-plugin-*" |
33 | PACKAGES += "${PN}-script-dhclient" | ||
34 | FILES_${PN} = "${bindir}/* ${sbindir}/* ${libexecdir}/* ${libdir}/lib*.so.* \ | 35 | FILES_${PN} = "${bindir}/* ${sbindir}/* ${libexecdir}/* ${libdir}/lib*.so.* \ |
35 | ${sysconfdir} ${sharedstatedir} ${localstatedir} \ | 36 | ${sysconfdir} ${sharedstatedir} ${localstatedir} \ |
36 | ${base_bindir}/* ${base_sbindir}/* ${base_libdir}/*.so* ${datadir}/${PN} \ | 37 | ${base_bindir}/* ${base_sbindir}/* ${base_libdir}/*.so* ${datadir}/${PN} \ |
37 | ${datadir}/pixmaps ${datadir}/applications \ | 38 | ${datadir}/pixmaps ${datadir}/applications \ |
38 | ${datadir}/idl ${datadir}/omf ${datadir}/sounds \ | 39 | ${datadir}/idl ${datadir}/omf ${datadir}/sounds \ |
39 | ${libdir}/bonobo/servers \ | 40 | ${libdir}/bonobo/servers \ |
40 | ${datadir}/dbus-1/system-services/*" | 41 | ${datadir}/dbus-1/system-services/* \ |
41 | FILES_${PN}-script-dhclient += "${libdir}/connman/scripts/dhclient*" | 42 | ${libdir}/connman/scripts/dhclient*" |
42 | FILES_${PN}-dbg += "${libdir}/connman/plugins/.debug \ | 43 | FILES_${PN}-dbg += "${libdir}/connman/plugins/.debug \ |
43 | ${libdir}/connman/scripts/.debug" | 44 | ${libdir}/connman/scripts/.debug" |
44 | 45 | ||
diff --git a/meta/packages/connman/files/dbusperms.patch b/meta/packages/connman/files/dbusperms.patch new file mode 100644 index 0000000000..100af0367b --- /dev/null +++ b/meta/packages/connman/files/dbusperms.patch | |||
@@ -0,0 +1,12 @@ | |||
1 | Index: git/src/connman-dbus.conf | ||
2 | =================================================================== | ||
3 | --- git.orig/src/connman-dbus.conf 2009-05-26 00:34:35.000000000 +0100 | ||
4 | +++ git/src/connman-dbus.conf 2009-05-26 00:34:48.000000000 +0100 | ||
5 | @@ -10,6 +10,6 @@ | ||
6 | <allow send_destination="org.moblin.connman"/> | ||
7 | </policy> | ||
8 | <policy context="default"> | ||
9 | - <deny send_destination="org.moblin.connman"/> | ||
10 | + <allow send_destination="org.moblin.connman"/> | ||
11 | </policy> | ||
12 | </busconfig> | ||
diff --git a/meta/packages/connman/files/dhclientreorder.patch b/meta/packages/connman/files/dhclientreorder.patch new file mode 100644 index 0000000000..04da0252df --- /dev/null +++ b/meta/packages/connman/files/dhclientreorder.patch | |||
@@ -0,0 +1,40 @@ | |||
1 | The -n option must appear after the iface options, else dhclient | ||
2 | just prints its help text. Crazy. | ||
3 | |||
4 | RP - 25/5/09 | ||
5 | |||
6 | Index: git/plugins/dhclient.c | ||
7 | =================================================================== | ||
8 | --- git.orig/plugins/dhclient.c 2009-05-26 00:01:02.000000000 +0100 | ||
9 | +++ git/plugins/dhclient.c 2009-05-26 00:01:38.000000000 +0100 | ||
10 | @@ -165,18 +165,18 @@ | ||
11 | argv[0] = DHCLIENT; | ||
12 | argv[1] = "-d"; | ||
13 | argv[2] = "-q"; | ||
14 | - argv[3] = "-n"; | ||
15 | - argv[4] = "-e"; | ||
16 | - argv[5] = address; | ||
17 | - argv[6] = "-pf"; | ||
18 | - argv[7] = pidfile; | ||
19 | - argv[8] = "-lf"; | ||
20 | - argv[9] = leases; | ||
21 | - argv[10] = "-cf"; | ||
22 | - argv[11] = config; | ||
23 | - argv[12] = "-sf"; | ||
24 | - argv[13] = script; | ||
25 | - argv[14] = task->ifname; | ||
26 | + argv[3] = "-e"; | ||
27 | + argv[4] = address; | ||
28 | + argv[5] = "-pf"; | ||
29 | + argv[6] = pidfile; | ||
30 | + argv[7] = "-lf"; | ||
31 | + argv[8] = leases; | ||
32 | + argv[9] = "-cf"; | ||
33 | + argv[10] = config; | ||
34 | + argv[11] = "-sf"; | ||
35 | + argv[12] = script; | ||
36 | + argv[13] = task->ifname; | ||
37 | + argv[14] = "-n"; | ||
38 | argv[15] = NULL; | ||
39 | |||
40 | envp[0] = NULL; | ||
diff --git a/meta/packages/connman/files/udevfix.patch b/meta/packages/connman/files/udevfix.patch new file mode 100644 index 0000000000..803bec5281 --- /dev/null +++ b/meta/packages/connman/files/udevfix.patch | |||
@@ -0,0 +1,12 @@ | |||
1 | Index: git/src/connman.rules | ||
2 | =================================================================== | ||
3 | --- git.orig/src/connman.rules 2009-05-25 14:24:53.000000000 +0100 | ||
4 | +++ git/src/connman.rules 2009-05-25 14:25:16.000000000 +0100 | ||
5 | @@ -3,6 +3,7 @@ | ||
6 | |||
7 | SUBSYSTEM=="net", KERNEL=="eth*", ENV{CONNMAN_TYPE}="ethernet" | ||
8 | SUBSYSTEM=="net", KERNEL=="wlan*", ENV{CONNMAN_TYPE}="wifi" | ||
9 | +SUBSYSTEM=="net", KERNEL=="ra0", ENV{CONNMAN_TYPE}="wifi" | ||
10 | |||
11 | SUBSYSTEM=="net", DRIVERS=="hso", ENV{CONNMAN_TYPE}="hso" | ||
12 | |||