summaryrefslogtreecommitdiffstats
path: root/meta/packages/connman
diff options
context:
space:
mode:
authorJoshua Lock <josh@linux.intel.com>2009-12-03 16:15:26 +0000
committerJoshua Lock <josh@linux.intel.com>2009-12-17 17:41:46 +0000
commit5cd6d1080766027a2d30c0a3ca006e41f341c79c (patch)
tree9106131ae1b5bb9ed108e14ac381576b2e80b70d /meta/packages/connman
parent2aa6a8aaf71166fba002ea5704a466d85792151c (diff)
downloadpoky-5cd6d1080766027a2d30c0a3ca006e41f341c79c.tar.gz
connman: Updates and a recipe for the latest release
Split much of the recipe into connman.inc and created a recipe for the latest 0.47 release. Update the fixed revision and dropped unneeded patches. Signed-off-by: Joshua Lock <josh@linux.intel.com>
Diffstat (limited to 'meta/packages/connman')
-rw-r--r--meta/packages/connman/connman.inc43
-rw-r--r--meta/packages/connman/connman_0.47.bb7
-rw-r--r--meta/packages/connman/connman_git.bb49
3 files changed, 54 insertions, 45 deletions
diff --git a/meta/packages/connman/connman.inc b/meta/packages/connman/connman.inc
new file mode 100644
index 0000000000..e7fde858b8
--- /dev/null
+++ b/meta/packages/connman/connman.inc
@@ -0,0 +1,43 @@
1HOMEPAGE = "http://www.moblin.org/projects/projects_connman.php"
2SUMMARY = "Moblin Connection Manager"
3LICENSE = "GPL"
4
5DEPENDS = "libgdbus dbus glib-2.0 hal"
6RDEPENDS_${PN} = "dhcp-client wpa-supplicant resolvconf"
7
8EXTRA_OECONF += " \
9 --enable-ethernet=builtin --enable-wifi=builtin --enable-dhclient=builtin \
10 --enable-bluetooth=builtin --enable-udev --enable-loopback=builtin \
11 --enable-dnsproxy=builtin --enable-threads --enable-resolvconf=builtin \
12 --enable-client --enable-fake --with-dhclient=/sbin/dhclient \
13 --enable-test \
14 ac_cv_path_WPASUPPLICANT=/usr/sbin/wpa_supplicant"
15
16INITSCRIPT_NAME = "connman"
17INITSCRIPT_PARAMS = "start 05 5 2 . stop 22 0 1 6 ."
18
19inherit autotools_stage pkgconfig update-rc.d
20
21do_install_append() {
22 install -d ${D}${sysconfdir}/init.d/
23 install -m 0755 ${WORKDIR}/connman ${D}${sysconfdir}/init.d/connman
24}
25
26PACKAGES_DYNAMIC = "${PN}-plugin-*"
27FILES_${PN} = "${bindir}/* ${sbindir}/* ${libexecdir}/* ${libdir}/lib*.so.* \
28 ${sysconfdir} ${sharedstatedir} ${localstatedir} \
29 ${base_bindir}/* ${base_sbindir}/* ${base_libdir}/*.so* ${datadir}/${PN} \
30 ${datadir}/pixmaps ${datadir}/applications \
31 ${datadir}/idl ${datadir}/omf ${datadir}/sounds \
32 ${libdir}/bonobo/servers \
33 ${libdir}/${PN}/test/* \
34 ${datadir}/dbus-1/system-services/* \
35 ${libdir}/connman/scripts/dhclient*"
36FILES_${PN}-dbg += "${libdir}/connman/plugins/.debug \
37 ${libdir}/connman/scripts/.debug"
38
39python populate_packages_prepend() {
40 plugin_dir = bb.data.expand('${libdir}/connman/plugins/', d)
41 plugin_name = bb.data.expand('${PN}-plugin-%s', d)
42 do_split_packages(d, plugin_dir, '^lib(.*).so$', plugin_name, '${PN} plugin for %s', extra_depends='' )
43} \ No newline at end of file
diff --git a/meta/packages/connman/connman_0.47.bb b/meta/packages/connman/connman_0.47.bb
new file mode 100644
index 0000000000..4cf903dfee
--- /dev/null
+++ b/meta/packages/connman/connman_0.47.bb
@@ -0,0 +1,7 @@
1require connman.inc
2PV = "0.47"
3
4SRC_URI = "http://www.kernel.org/pub/linux/network/connman/${P}.tar.bz2 \
5 file://dbusperms.patch \
6 file://connman "
7
diff --git a/meta/packages/connman/connman_git.bb b/meta/packages/connman/connman_git.bb
index 7520202e2e..31fe1662c1 100644
--- a/meta/packages/connman/connman_git.bb
+++ b/meta/packages/connman/connman_git.bb
@@ -1,51 +1,10 @@
1HOMEPAGE = "http://www.moblin.org/projects/projects_connman.php" 1require connman.inc
2SUMMARY = "Moblin Connection Manager" 2
3PV = "0.34+git${SRCPV}" 3PV = "0.47+git${SRCPV}"
4PR = "r16" 4PR = "r16"
5S = "${WORKDIR}/git" 5S = "${WORKDIR}/git"
6LICENSE = "GPL"
7
8DEPENDS = "libgdbus dbus glib-2.0 hal"
9RDEPENDS_${PN} = "dhcp-client wpa-supplicant resolvconf"
10
11EXTRA_OECONF += " \
12 --enable-ethernet=builtin --enable-wifi=builtin --enable-dhclient=builtin \
13 --enable-bluetooth=builtin --enable-udev --enable-loopback=builtin \
14 --enable-dnsproxy=builtin --enable-threads --enable-resolvconf=builtin \
15 --enable-client --enable-fake --with-dhclient=/sbin/dhclient \
16 --enable-test \
17 ac_cv_path_WPASUPPLICANT=/usr/sbin/wpa_supplicant"
18 6
19SRC_URI = "git://git.kernel.org/pub/scm/network/connman/connman.git;protocol=git \ 7SRC_URI = "git://git.kernel.org/pub/scm/network/connman/connman.git;protocol=git \
20 file://connman-install-tests-d52de88aff4771283b2ebee4f48a7af15862d0ae.patch;patch=1;rev=d52de88aff4771283b2ebee4f48a7af15862d0ae \ 8 file://dbusperms.patch \
21 file://connman-install-tests.patch;patch=1;rev=fd401dcd103a309e22c00d66f5c91375bfc9cce4 \
22 file://dbusperms.patch;patch=1 \
23 file://connman " 9 file://connman "
24 10
25INITSCRIPT_NAME = "connman"
26INITSCRIPT_PARAMS = "start 05 5 2 . stop 22 0 1 6 ."
27
28inherit autotools_stage pkgconfig update-rc.d
29
30do_install_append() {
31 install -d ${D}${sysconfdir}/init.d/
32 install -m 0755 ${WORKDIR}/connman ${D}${sysconfdir}/init.d/connman
33}
34
35PACKAGES_DYNAMIC = "${PN}-plugin-*"
36FILES_${PN} = "${bindir}/* ${sbindir}/* ${libexecdir}/* ${libdir}/lib*.so.* \
37 ${sysconfdir} ${sharedstatedir} ${localstatedir} \
38 ${base_bindir}/* ${base_sbindir}/* ${base_libdir}/*.so* ${datadir}/${PN} \
39 ${datadir}/pixmaps ${datadir}/applications \
40 ${datadir}/idl ${datadir}/omf ${datadir}/sounds \
41 ${libdir}/bonobo/servers \
42 ${datadir}/dbus-1/system-services/* \
43 ${libdir}/connman/scripts/dhclient*"
44FILES_${PN}-dbg += "${libdir}/connman/plugins/.debug \
45 ${libdir}/connman/scripts/.debug"
46
47python populate_packages_prepend() {
48 plugin_dir = bb.data.expand('${libdir}/connman/plugins/', d)
49 plugin_name = bb.data.expand('${PN}-plugin-%s', d)
50 do_split_packages(d, plugin_dir, '^lib(.*).so$', plugin_name, '${PN} plugin for %s', extra_depends='' )
51}