summaryrefslogtreecommitdiffstats
path: root/meta/packages/connman/files
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/packages/connman/files
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadpoky-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/connman/files')
-rwxr-xr-xmeta/packages/connman/files/connman42
-rw-r--r--meta/packages/connman/files/connman-install-tests-d52de88aff4771283b2ebee4f48a7af15862d0ae.patch13
-rw-r--r--meta/packages/connman/files/connman-install-tests.patch15
-rw-r--r--meta/packages/connman/files/dbusperms.patch12
-rw-r--r--meta/packages/connman/files/udevfix.patch12
5 files changed, 0 insertions, 94 deletions
diff --git a/meta/packages/connman/files/connman b/meta/packages/connman/files/connman
deleted file mode 100755
index f8154f68f9..0000000000
--- a/meta/packages/connman/files/connman
+++ /dev/null
@@ -1,42 +0,0 @@
1#!/bin/sh
2
3DAEMON=/usr/sbin/connmand
4PIDFILE=/var/run/connmand.pid
5DESC="Connection Manager"
6
7if [ -f /etc/default/connman ] ; then
8 . /etc/default/connman
9fi
10
11set -e
12
13do_start() {
14 $DAEMON
15}
16
17do_stop() {
18 start-stop-daemon --stop --name connmand --quiet
19}
20
21case "$1" in
22 start)
23 echo "Starting $DESC"
24 do_start
25 ;;
26 stop)
27 echo "Stopping $DESC"
28 do_stop
29 ;;
30 restart|force-reload)
31 echo "Restarting $DESC"
32 do_stop
33 sleep 1
34 do_start
35 ;;
36 *)
37 echo "Usage: $0 {start|stop|restart|force-reload}" >&2
38 exit 1
39 ;;
40esac
41
42exit 0
diff --git a/meta/packages/connman/files/connman-install-tests-d52de88aff4771283b2ebee4f48a7af15862d0ae.patch b/meta/packages/connman/files/connman-install-tests-d52de88aff4771283b2ebee4f48a7af15862d0ae.patch
deleted file mode 100644
index 57df7196ec..0000000000
--- a/meta/packages/connman/files/connman-install-tests-d52de88aff4771283b2ebee4f48a7af15862d0ae.patch
+++ /dev/null
@@ -1,13 +0,0 @@
1Index: git/test/Makefile.am
2===================================================================
3--- git.orig/test/Makefile.am 2009-05-21 12:07:39.000000000 +0100
4+++ git/test/Makefile.am 2009-05-21 17:29:33.000000000 +0100
5@@ -1,5 +1,7 @@
6
7-EXTRA_DIST = get-state list-profiles list-services \
8+testdir = $(pkgdatadir)/tests
9+
10+test_SCRIPTS = get-state list-profiles list-services \
11 list-connections select-connection \
12 list-devices enable-device disable-device start-scanning \
13 list-networks select-network disable-network create-network \
diff --git a/meta/packages/connman/files/connman-install-tests.patch b/meta/packages/connman/files/connman-install-tests.patch
deleted file mode 100644
index 0ea3758f2d..0000000000
--- a/meta/packages/connman/files/connman-install-tests.patch
+++ /dev/null
@@ -1,15 +0,0 @@
1Index: git/Makefile.am
2===================================================================
3--- git.orig/Makefile.am 2009-08-24 15:56:33.000000000 +0100
4+++ git/Makefile.am 2009-08-24 16:02:38.000000000 +0100
5@@ -115,7 +115,9 @@
6 tools_wifi_scan_LDADD = @GLIB_LIBS@ @NETLINK_LIBS@
7 endif
8
9-EXTRA_DIST += test/get-state test/list-profiles test/list-services \
10+testdir = $(pkgdatadir)/tests
11+
12+test_SCRIPTS = test/get-state test/list-profiles test/list-services \
13 test/connect-service test/list-connections \
14 test/select-connection test/list-devices test/enable-device \
15 test/disable-device test/start-scanning test/list-networks \
diff --git a/meta/packages/connman/files/dbusperms.patch b/meta/packages/connman/files/dbusperms.patch
deleted file mode 100644
index 100af0367b..0000000000
--- a/meta/packages/connman/files/dbusperms.patch
+++ /dev/null
@@ -1,12 +0,0 @@
1Index: git/src/connman-dbus.conf
2===================================================================
3--- git.orig/src/connman-dbus.conf 2009-05-26 00:34:35.000000000 +0100
4+++ git/src/connman-dbus.conf 2009-05-26 00:34:48.000000000 +0100
5@@ -10,6 +10,6 @@
6 <allow send_destination="org.moblin.connman"/>
7 </policy>
8 <policy context="default">
9- <deny send_destination="org.moblin.connman"/>
10+ <allow send_destination="org.moblin.connman"/>
11 </policy>
12 </busconfig>
diff --git a/meta/packages/connman/files/udevfix.patch b/meta/packages/connman/files/udevfix.patch
deleted file mode 100644
index 803bec5281..0000000000
--- a/meta/packages/connman/files/udevfix.patch
+++ /dev/null
@@ -1,12 +0,0 @@
1Index: git/src/connman.rules
2===================================================================
3--- git.orig/src/connman.rules 2009-05-25 14:24:53.000000000 +0100
4+++ git/src/connman.rules 2009-05-25 14:25:16.000000000 +0100
5@@ -3,6 +3,7 @@
6
7 SUBSYSTEM=="net", KERNEL=="eth*", ENV{CONNMAN_TYPE}="ethernet"
8 SUBSYSTEM=="net", KERNEL=="wlan*", ENV{CONNMAN_TYPE}="wifi"
9+SUBSYSTEM=="net", KERNEL=="ra0", ENV{CONNMAN_TYPE}="wifi"
10
11 SUBSYSTEM=="net", DRIVERS=="hso", ENV{CONNMAN_TYPE}="hso"
12