diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2008-12-18 17:00:46 +0000 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2008-12-18 17:00:46 +0000 |
commit | 01121bc89e0406cb3a651abe09c47bdfec10c566 (patch) | |
tree | 770350631e124f241e17479cc4dd559fb979bace /meta/packages/clutter | |
parent | 0f918b445e48ff1d45929251697f476c1053bc43 (diff) | |
download | poky-01121bc89e0406cb3a651abe09c47bdfec10c566.tar.gz |
clutter: Fix enable_tests patch for recent changes
Diffstat (limited to 'meta/packages/clutter')
-rw-r--r-- | meta/packages/clutter/clutter/enable-tests-r2990.patch | 50 | ||||
-rw-r--r-- | meta/packages/clutter/clutter/enable_tests.patch | 44 | ||||
-rw-r--r-- | meta/packages/clutter/clutter_git.bb | 6 |
3 files changed, 16 insertions, 84 deletions
diff --git a/meta/packages/clutter/clutter/enable-tests-r2990.patch b/meta/packages/clutter/clutter/enable-tests-r2990.patch deleted file mode 100644 index 4f449b1177..0000000000 --- a/meta/packages/clutter/clutter/enable-tests-r2990.patch +++ /dev/null | |||
@@ -1,50 +0,0 @@ | |||
1 | --- | ||
2 | tests/Makefile.am | 7 ++++++- | ||
3 | tests/test-actors.c | 2 +- | ||
4 | tests/test-text.c | 2 +- | ||
5 | 3 files changed, 8 insertions(+), 3 deletions(-) | ||
6 | |||
7 | Index: clutter/tests/Makefile.am | ||
8 | =================================================================== | ||
9 | --- clutter.orig/tests/Makefile.am 2008-06-26 16:46:26.000000000 +0100 | ||
10 | +++ clutter/tests/Makefile.am 2008-06-26 16:46:50.000000000 +0100 | ||
11 | @@ -1,4 +1,4 @@ | ||
12 | -noinst_PROGRAMS = test-textures test-events test-offscreen test-scale \ | ||
13 | +bin_PROGRAMS = test-textures test-events test-offscreen test-scale \ | ||
14 | test-actors test-behave test-text test-entry test-project \ | ||
15 | test-perspective test-rotate test-depth \ | ||
16 | test-threads test-timeline test-timeline-dup-frames \ | ||
17 | @@ -17,8 +17,8 @@ | ||
18 | test-invariants | ||
19 | |||
20 | if X11_TESTS | ||
21 | -noinst_PROGRAMS += test-pixmap | ||
22 | -noinst_PROGRAMS += test-devices | ||
23 | +bin_PROGRAMS += test-pixmap | ||
24 | +bin_PROGRAMS += test-devices | ||
25 | endif | ||
26 | |||
27 | INCLUDES = -I$(top_srcdir)/ -I$(top_srcdir)/clutter -I$(top_builddir)/clutter | ||
28 | @@ -73,4 +73,9 @@ | ||
29 | test_invariants_SOURCES = test-invariants.c | ||
30 | test_devices_SOURCES = test-devices.c | ||
31 | |||
32 | +test_textdir = $(pkgdatadir) | ||
33 | +test_text_DATA = test-text.c | ||
34 | +test_actorsdir = $(pkgdatadir) | ||
35 | +test_actors_DATA = redhand.png | ||
36 | + | ||
37 | EXTRA_DIST = redhand.png test-script.json | ||
38 | Index: clutter/tests/test-actors.c | ||
39 | =================================================================== | ||
40 | --- clutter.orig/tests/test-actors.c 2008-06-26 16:46:26.000000000 +0100 | ||
41 | +++ clutter/tests/test-actors.c 2008-06-26 16:46:31.000000000 +0100 | ||
42 | @@ -195,7 +195,7 @@ | ||
43 | /* Create a texture from file, then clone in to same resources */ | ||
44 | if (i == 0) | ||
45 | { | ||
46 | - if ((oh->hand[i] = clutter_texture_new_from_file ("redhand.png", | ||
47 | + if ((oh->hand[i] = clutter_texture_new_from_file ("/usr/share/clutter/redhand.png", | ||
48 | &error)) == NULL) | ||
49 | { | ||
50 | g_error ("image load failed: %s", error->message); | ||
diff --git a/meta/packages/clutter/clutter/enable_tests.patch b/meta/packages/clutter/clutter/enable_tests.patch index 4a99968fa3..8544614790 100644 --- a/meta/packages/clutter/clutter/enable_tests.patch +++ b/meta/packages/clutter/clutter/enable_tests.patch | |||
@@ -4,40 +4,24 @@ | |||
4 | tests/test-text.c | 2 +- | 4 | tests/test-text.c | 2 +- |
5 | 3 files changed, 8 insertions(+), 3 deletions(-) | 5 | 3 files changed, 8 insertions(+), 3 deletions(-) |
6 | 6 | ||
7 | Index: clutter/tests/Makefile.am | 7 | Index: git/tests/interactive/Makefile.am |
8 | =================================================================== | 8 | =================================================================== |
9 | --- clutter.orig/tests/Makefile.am 2008-04-25 16:45:17.000000000 +0100 | 9 | --- git.orig/tests/interactive/Makefile.am 2008-12-18 16:50:45.000000000 +0000 |
10 | +++ clutter/tests/Makefile.am 2008-04-25 16:47:12.000000000 +0100 | 10 | +++ git/tests/interactive/Makefile.am 2008-12-18 16:57:36.000000000 +0000 |
11 | @@ -1,4 +1,4 @@ | 11 | @@ -68,7 +68,7 @@ |
12 | -noinst_PROGRAMS = test-textures test-events test-offscreen test-scale \ | 12 | AM_CFLAGS = $(CLUTTER_CFLAGS) |
13 | +bin_PROGRAMS = test-textures test-events test-offscreen test-scale \ | 13 | AM_LDFLAGS = $(CLUTTER_LIBS) |
14 | test-actors test-behave test-text test-entry test-project \ | ||
15 | test-perspective test-rotate test-depth \ | ||
16 | test-threads test-timeline test-timeline-dup-frames \ | ||
17 | @@ -14,7 +14,7 @@ | ||
18 | test-cogl-tex-polygon test-stage-read-pixels | ||
19 | 14 | ||
20 | if X11_TESTS | 15 | -noinst_PROGRAMS = test-interactive |
21 | -noinst_PROGRAMS += test-pixmap | 16 | +bin_PROGRAMS = test-interactive |
22 | +bin_PROGRAMS += test-pixmap | ||
23 | endif | ||
24 | 17 | ||
25 | INCLUDES = -I$(top_srcdir)/ -I$(top_builddir)/clutter | 18 | test_interactive_SOURCES = \ |
26 | @@ -61,4 +61,9 @@ | 19 | test-main.c \ |
27 | test_cogl_offscreen_SOURCES = test-cogl-offscreen.c | 20 | Index: git/tests/interactive/test-actors.c |
28 | test_stage_read_pixels_SOURCES = test-stage-read-pixels.c | ||
29 | |||
30 | +test_textdir = $(pkgdatadir) | ||
31 | +test_text_DATA = test-text.c | ||
32 | +test_actorsdir = $(pkgdatadir) | ||
33 | +test_actors_DATA = redhand.png | ||
34 | + | ||
35 | EXTRA_DIST = redhand.png test-script.json | ||
36 | Index: clutter/tests/test-actors.c | ||
37 | =================================================================== | 21 | =================================================================== |
38 | --- clutter.orig/tests/test-actors.c 2008-04-25 16:45:17.000000000 +0100 | 22 | --- git.orig/tests/interactive/test-actors.c 2008-12-18 16:58:06.000000000 +0000 |
39 | +++ clutter/tests/test-actors.c 2008-04-25 16:45:17.000000000 +0100 | 23 | +++ git/tests/interactive/test-actors.c 2008-12-18 16:58:13.000000000 +0000 |
40 | @@ -184,7 +184,7 @@ | 24 | @@ -189,7 +189,7 @@ |
41 | /* Create a texture from file, then clone in to same resources */ | 25 | /* Create a texture from file, then clone in to same resources */ |
42 | if (i == 0) | 26 | if (i == 0) |
43 | { | 27 | { |
diff --git a/meta/packages/clutter/clutter_git.bb b/meta/packages/clutter/clutter_git.bb index 28b03a4899..da6654b32f 100644 --- a/meta/packages/clutter/clutter_git.bb +++ b/meta/packages/clutter/clutter_git.bb | |||
@@ -1,12 +1,10 @@ | |||
1 | require clutter.inc | 1 | require clutter.inc |
2 | 2 | ||
3 | PV = "0.8.0+git${SRCREV}" | 3 | PV = "0.8.0+git${SRCREV}" |
4 | PR = "r2" | 4 | PR = "r3" |
5 | 5 | ||
6 | SRC_URI = "git://git.clutter-project.org/clutter.git;protocol=git;branch=master \ | 6 | SRC_URI = "git://git.clutter-project.org/clutter.git;protocol=git;branch=master \ |
7 | file://enable_tests.patch;patch=1;maxrev=2989 \ | 7 | file://enable_tests.patch;patch=1 " |
8 | file://enable-tests-r2990.patch;patch=1;minrev=2990" | ||
9 | |||
10 | S = "${WORKDIR}/git" | 8 | S = "${WORKDIR}/git" |
11 | 9 | ||
12 | 10 | ||