diff options
author | Richard Purdie <richard@openedhand.com> | 2007-07-10 14:06:27 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2007-07-10 14:06:27 +0000 |
commit | e02fb94812ca03db5fea0377661ebde1e3f2222e (patch) | |
tree | 427497fb886e6497d44ca501fa946bf4da1a5434 /meta/packages/clutter | |
parent | 9e9fe202ec1e79e6712f748197bf92e286e3cfe7 (diff) | |
download | poky-e02fb94812ca03db5fea0377661ebde1e3f2222e.tar.gz |
Add clutter, clutter-cairo, clutter-gst, aaina and table, excluded from world builds for now
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2143 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/clutter')
-rw-r--r-- | meta/packages/clutter/aaina.inc | 12 | ||||
-rw-r--r-- | meta/packages/clutter/aaina_svn.bb | 8 | ||||
-rw-r--r-- | meta/packages/clutter/clutter-cairo.inc | 15 | ||||
-rw-r--r-- | meta/packages/clutter/clutter-cairo/enable_examples.patch | 28 | ||||
-rw-r--r-- | meta/packages/clutter/clutter-cairo_svn.bb | 11 | ||||
-rw-r--r-- | meta/packages/clutter/clutter-fpu.inc | 6 | ||||
-rw-r--r-- | meta/packages/clutter/clutter-gst.inc | 19 | ||||
-rw-r--r-- | meta/packages/clutter/clutter-gst/autofoo.patch | 45 | ||||
-rw-r--r-- | meta/packages/clutter/clutter-gst_svn.bb | 11 | ||||
-rw-r--r-- | meta/packages/clutter/clutter.inc | 27 | ||||
-rw-r--r-- | meta/packages/clutter/clutter/enable_tests.patch | 52 | ||||
-rw-r--r-- | meta/packages/clutter/clutter_svn.bb | 11 | ||||
-rw-r--r-- | meta/packages/clutter/table.inc | 17 | ||||
-rw-r--r-- | meta/packages/clutter/table/fixes.patch | 14 | ||||
-rw-r--r-- | meta/packages/clutter/table_svn.bb | 11 |
15 files changed, 287 insertions, 0 deletions
diff --git a/meta/packages/clutter/aaina.inc b/meta/packages/clutter/aaina.inc new file mode 100644 index 0000000000..fbef34f563 --- /dev/null +++ b/meta/packages/clutter/aaina.inc | |||
@@ -0,0 +1,12 @@ | |||
1 | DESCRIPTION = "Aaina Clutter Demo" | ||
2 | HOMEPAGE = "http://www.clutter-project.org/" | ||
3 | LICENSE = "GPL" | ||
4 | |||
5 | DEPENDS = "clutter libxml2 gtk+ neon" | ||
6 | |||
7 | inherit autotools pkgconfig | ||
8 | |||
9 | do_stage () { | ||
10 | autotools_stage_all | ||
11 | } | ||
12 | |||
diff --git a/meta/packages/clutter/aaina_svn.bb b/meta/packages/clutter/aaina_svn.bb new file mode 100644 index 0000000000..d6e81b1d9f --- /dev/null +++ b/meta/packages/clutter/aaina_svn.bb | |||
@@ -0,0 +1,8 @@ | |||
1 | require aaina.inc | ||
2 | |||
3 | PV = "0.3.0+svn${SRCDATE}" | ||
4 | PR = "r1" | ||
5 | |||
6 | SRC_URI = "svn://svn.o-hand.com/repos/clutter/trunk/toys;module=aaina;proto=http" | ||
7 | |||
8 | S = "${WORKDIR}/aaina" | ||
diff --git a/meta/packages/clutter/clutter-cairo.inc b/meta/packages/clutter/clutter-cairo.inc new file mode 100644 index 0000000000..1095a7e8ef --- /dev/null +++ b/meta/packages/clutter/clutter-cairo.inc | |||
@@ -0,0 +1,15 @@ | |||
1 | DESCRIPTION = "Clutter Cairo" | ||
2 | HOMEPAGE = "http://www.clutter-project.org/" | ||
3 | LICENSE = "LGPL" | ||
4 | |||
5 | DEPENDS = "clutter cairo" | ||
6 | |||
7 | PACKAGES =+ "${PN}-examples" | ||
8 | FILES_${PN}-examples = "${bindir}/flowers ${bindir}/clock" | ||
9 | |||
10 | inherit autotools pkgconfig | ||
11 | |||
12 | do_stage () { | ||
13 | autotools_stage_all | ||
14 | } | ||
15 | |||
diff --git a/meta/packages/clutter/clutter-cairo/enable_examples.patch b/meta/packages/clutter/clutter-cairo/enable_examples.patch new file mode 100644 index 0000000000..c1cddf6841 --- /dev/null +++ b/meta/packages/clutter/clutter-cairo/enable_examples.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | --- | ||
2 | examples/Makefile.am | 2 +- | ||
3 | examples/flowers.c | 2 +- | ||
4 | 2 files changed, 2 insertions(+), 2 deletions(-) | ||
5 | |||
6 | Index: clutter-cairo/examples/Makefile.am | ||
7 | =================================================================== | ||
8 | --- clutter-cairo.orig/examples/Makefile.am 2007-07-10 00:25:03.000000000 +0100 | ||
9 | +++ clutter-cairo/examples/Makefile.am 2007-07-10 12:06:49.000000000 +0100 | ||
10 | @@ -1,4 +1,4 @@ | ||
11 | -noinst_PROGRAMS = clock flowers | ||
12 | +bin_PROGRAMS = clock flowers | ||
13 | |||
14 | INCLUDES = -I$(top_srcdir)/ @GCC_FLAGS@ @DEPS_CFLAGS@ | ||
15 | LDFLAGS = @DEPS_LIBS@ $(top_builddir)/libclutter-cairo-@CLUTTER_CAIRO_MAJORMINOR@.la | ||
16 | Index: clutter-cairo/examples/flowers.c | ||
17 | =================================================================== | ||
18 | --- clutter-cairo.orig/examples/flowers.c 2007-07-10 12:30:44.000000000 +0100 | ||
19 | +++ clutter-cairo/examples/flowers.c 2007-07-10 12:30:51.000000000 +0100 | ||
20 | @@ -11,7 +11,7 @@ | ||
21 | |||
22 | #define PETAL_MIN 20 | ||
23 | #define PETAL_VAR 40 | ||
24 | -#define N_FLOWERS 40 /* reduce if you have a small card */ | ||
25 | +#define N_FLOWERS 8 /* reduce if you have a small card */ | ||
26 | |||
27 | typedef struct Flower | ||
28 | { | ||
diff --git a/meta/packages/clutter/clutter-cairo_svn.bb b/meta/packages/clutter/clutter-cairo_svn.bb new file mode 100644 index 0000000000..c4becfd829 --- /dev/null +++ b/meta/packages/clutter/clutter-cairo_svn.bb | |||
@@ -0,0 +1,11 @@ | |||
1 | require clutter-cairo.inc | ||
2 | |||
3 | PV = "0.3.0+svn${SRCDATE}" | ||
4 | PR = "r2" | ||
5 | |||
6 | SRC_URI = "svn://svn.o-hand.com/repos/clutter/trunk;module=${PN};proto=http \ | ||
7 | file://enable_examples.patch;patch=1" | ||
8 | |||
9 | S = "${WORKDIR}/${PN}" | ||
10 | |||
11 | |||
diff --git a/meta/packages/clutter/clutter-fpu.inc b/meta/packages/clutter/clutter-fpu.inc new file mode 100644 index 0000000000..21a16feac2 --- /dev/null +++ b/meta/packages/clutter/clutter-fpu.inc | |||
@@ -0,0 +1,6 @@ | |||
1 | |||
2 | def get_clutter_fpu_setting(bb, d): | ||
3 | if bb.data.getVar('TARGET_FPU', d, 1) in [ 'soft' ]: | ||
4 | return "--without-fpu" | ||
5 | return "" | ||
6 | |||
diff --git a/meta/packages/clutter/clutter-gst.inc b/meta/packages/clutter/clutter-gst.inc new file mode 100644 index 0000000000..caaa7559b8 --- /dev/null +++ b/meta/packages/clutter/clutter-gst.inc | |||
@@ -0,0 +1,19 @@ | |||
1 | DESCRIPTION = "Clutter GStreamer" | ||
2 | HOMEPAGE = "http://www.clutter-project.org/" | ||
3 | LICENSE = "LGPL" | ||
4 | |||
5 | DEPENDS = "clutter gstreamer gst-plugins-base" | ||
6 | |||
7 | PACKAGES =+ "${PN}-examples" | ||
8 | FILES_${PN}-examples = "${bindir}/video-player ${bindir}/video-sink ${bindir}/audio" | ||
9 | |||
10 | inherit autotools pkgconfig | ||
11 | |||
12 | do_configure_prepend() { | ||
13 | touch ${S}/gtk-doc.make | ||
14 | } | ||
15 | |||
16 | do_stage () { | ||
17 | autotools_stage_all | ||
18 | } | ||
19 | |||
diff --git a/meta/packages/clutter/clutter-gst/autofoo.patch b/meta/packages/clutter/clutter-gst/autofoo.patch new file mode 100644 index 0000000000..f5b8ef7d1d --- /dev/null +++ b/meta/packages/clutter/clutter-gst/autofoo.patch | |||
@@ -0,0 +1,45 @@ | |||
1 | --- | ||
2 | configure.ac | 2 +- | ||
3 | doc/reference/Makefile.am | 2 +- | ||
4 | examples/Makefile.am | 14 +++++++------- | ||
5 | 3 files changed, 9 insertions(+), 9 deletions(-) | ||
6 | |||
7 | Index: clutter-gst/examples/Makefile.am | ||
8 | =================================================================== | ||
9 | --- clutter-gst.orig/examples/Makefile.am 2007-07-10 13:01:28.000000000 +0100 | ||
10 | +++ clutter-gst/examples/Makefile.am 2007-07-10 13:07:33.000000000 +0100 | ||
11 | @@ -1,4 +1,4 @@ | ||
12 | -noinst_PROGRAMS = video-player video-sink audio | ||
13 | +bin_PROGRAMS = video-player video-sink audio | ||
14 | |||
15 | INCLUDES = -I$(top_srcdir)/ | ||
16 | |||
17 | @@ -9,12 +9,12 @@ video_player_LDFLAGS = \ | ||
18 | $(GST_LIBS) \ | ||
19 | $(top_builddir)/clutter-gst/libclutter-gst-@CLUTTER_GST_MAJORMINOR@.la | ||
20 | |||
21 | -video_cube_SOURCES = video-cube.c | ||
22 | -video_cube_CFLAGS = $(CLUTTER_GST_CFLAGS) $(GST_CFLAGS) | ||
23 | -video_cube_LDFLAGS = \ | ||
24 | - $(CLUTTER_LIBS) \ | ||
25 | - $(GST_LIBS) \ | ||
26 | - $(top_builddir)/clutter-gst/libclutter-gst-@CLUTTER_GST_MAJORMINOR@.la | ||
27 | +#video_cube_SOURCES = video-cube.c | ||
28 | +#video_cube_CFLAGS = $(CLUTTER_GST_CFLAGS) $(GST_CFLAGS) | ||
29 | +#video_cube_LDFLAGS = \ | ||
30 | +# $(CLUTTER_LIBS) \ | ||
31 | +# $(GST_LIBS) \ | ||
32 | +# $(top_builddir)/clutter-gst/libclutter-gst-@CLUTTER_GST_MAJORMINOR@.la | ||
33 | |||
34 | video_sink_SOURCES = video-sink.c | ||
35 | video_sink_CFLAGS = $(CLUTTER_GST_CFLAGS) $(GST_CFLAGS) | ||
36 | Index: clutter-gst/doc/reference/Makefile.am | ||
37 | =================================================================== | ||
38 | --- clutter-gst.orig/doc/reference/Makefile.am 2007-07-10 13:01:17.000000000 +0100 | ||
39 | +++ clutter-gst/doc/reference/Makefile.am 2007-07-10 13:02:50.000000000 +0100 | ||
40 | @@ -77,4 +77,4 @@ include $(top_srcdir)/gtk-doc.make | ||
41 | |||
42 | # Other files to distribute | ||
43 | # e.g. EXTRA_DIST += version.xml.in | ||
44 | -EXTRA_DIST += version.xml.in | ||
45 | +EXTRA_DIST = version.xml.in | ||
diff --git a/meta/packages/clutter/clutter-gst_svn.bb b/meta/packages/clutter/clutter-gst_svn.bb new file mode 100644 index 0000000000..1bffee0665 --- /dev/null +++ b/meta/packages/clutter/clutter-gst_svn.bb | |||
@@ -0,0 +1,11 @@ | |||
1 | require clutter-gst.inc | ||
2 | |||
3 | PV = "0.3.0+svn${SRCDATE}" | ||
4 | PR = "r3" | ||
5 | |||
6 | SRC_URI = "svn://svn.o-hand.com/repos/clutter/trunk;module=${PN};proto=http \ | ||
7 | file://autofoo.patch;patch=1" | ||
8 | |||
9 | S = "${WORKDIR}/${PN}" | ||
10 | |||
11 | |||
diff --git a/meta/packages/clutter/clutter.inc b/meta/packages/clutter/clutter.inc new file mode 100644 index 0000000000..b5648c4d7a --- /dev/null +++ b/meta/packages/clutter/clutter.inc | |||
@@ -0,0 +1,27 @@ | |||
1 | DESCRIPTION = "Clutter graphics library" | ||
2 | HOMEPAGE = "http://www.clutter-project.org/" | ||
3 | LICENSE = "LGPL" | ||
4 | |||
5 | STDDEPENDS = "virtual/libx11 gtk-doc pango glib-2.0 libxfixes" | ||
6 | BASE_CONF = "--disable-gtk-doc ${@get_clutter_fpu_setting(bb, d)}" | ||
7 | |||
8 | DEPENDS = "${STDDEPENDS}" | ||
9 | EXTRA_OECONF = "${BASE_CONF}" | ||
10 | |||
11 | inherit autotools pkgconfig | ||
12 | |||
13 | #check for TARGET_FPU=soft and inform configure of the result so it can disable some floating points | ||
14 | require clutter-fpu.inc | ||
15 | |||
16 | #Fix up some weirdness in the docs | ||
17 | do_configure_prepend() { | ||
18 | touch ${S}/gtk-doc.make | ||
19 | sed -i s:doc/reference/Makefile::g ${S}/configure.ac | ||
20 | sed -i s:doc::g ${S}/Makefile.am | ||
21 | } | ||
22 | |||
23 | do_stage () { | ||
24 | cp ${S}/clutter.pc ${S}/clutter-0.3.pc | ||
25 | autotools_stage_all | ||
26 | } | ||
27 | |||
diff --git a/meta/packages/clutter/clutter/enable_tests.patch b/meta/packages/clutter/clutter/enable_tests.patch new file mode 100644 index 0000000000..06c2c4e09e --- /dev/null +++ b/meta/packages/clutter/clutter/enable_tests.patch | |||
@@ -0,0 +1,52 @@ | |||
1 | --- | ||
2 | tests/Makefile.am | 7 ++++++- | ||
3 | tests/test-actors.c | 2 +- | ||
4 | tests/test-text.c | 2 +- | ||
5 | 3 files changed, 8 insertions(+), 3 deletions(-) | ||
6 | |||
7 | Index: clutter/tests/Makefile.am | ||
8 | =================================================================== | ||
9 | --- clutter.orig/tests/Makefile.am 2007-07-09 13:51:59.000000000 +0100 | ||
10 | +++ clutter/tests/Makefile.am 2007-07-09 19:14:47.000000000 +0100 | ||
11 | @@ -1,4 +1,4 @@ | ||
12 | -noinst_PROGRAMS = test-textures test-events test-offscreen test-scale \ | ||
13 | +bin_PROGRAMS = test-textures test-events test-offscreen test-scale \ | ||
14 | test-actors test-behave test-text test-entry test-project \ | ||
15 | test-boxes test-perspective | ||
16 | |||
17 | @@ -19,4 +19,9 @@ test_project_SOURCES = test-project.c | ||
18 | test_boxes_SOURCES = test-boxes.c | ||
19 | test_perspective_SOURCES = test-perspective.c | ||
20 | |||
21 | +test_textdir = $(pkgdatadir) | ||
22 | +test_text_DATA = test-text.c | ||
23 | +test_actorsdir = $(pkgdatadir) | ||
24 | +test_actors_DATA = redhand.png | ||
25 | + | ||
26 | EXTRA_DIST = redhand.png | ||
27 | Index: clutter/tests/test-actors.c | ||
28 | =================================================================== | ||
29 | --- clutter.orig/tests/test-actors.c 2007-07-09 19:17:50.000000000 +0100 | ||
30 | +++ clutter/tests/test-actors.c 2007-07-09 19:18:10.000000000 +0100 | ||
31 | @@ -146,7 +146,7 @@ main (int argc, char *argv[]) | ||
32 | stage = clutter_stage_get_default (); | ||
33 | clutter_actor_set_size (stage, 800, 600); | ||
34 | |||
35 | - pixbuf = gdk_pixbuf_new_from_file ("redhand.png", NULL); | ||
36 | + pixbuf = gdk_pixbuf_new_from_file ("/usr/share/clutter/redhand.png", NULL); | ||
37 | |||
38 | if (!pixbuf) | ||
39 | g_error("pixbuf load failed"); | ||
40 | Index: clutter/tests/test-text.c | ||
41 | =================================================================== | ||
42 | --- clutter.orig/tests/test-text.c 2007-07-09 19:17:57.000000000 +0100 | ||
43 | +++ clutter/tests/test-text.c 2007-07-09 19:18:47.000000000 +0100 | ||
44 | @@ -27,7 +27,7 @@ main (int argc, char *argv[]) | ||
45 | |||
46 | stage = clutter_stage_get_default (); | ||
47 | |||
48 | - if (!g_file_get_contents ("test-text.c", &text, &size, NULL)) | ||
49 | + if (!g_file_get_contents ("/usr/share/clutter/test-text.c", &text, &size, NULL)) | ||
50 | g_error("g_file_get_contents() of test-text.c failed"); | ||
51 | |||
52 | clutter_actor_set_size (stage, 800, 600); | ||
diff --git a/meta/packages/clutter/clutter_svn.bb b/meta/packages/clutter/clutter_svn.bb new file mode 100644 index 0000000000..ced1a17017 --- /dev/null +++ b/meta/packages/clutter/clutter_svn.bb | |||
@@ -0,0 +1,11 @@ | |||
1 | require clutter.inc | ||
2 | |||
3 | PV = "0.3.0+svn${SRCDATE}" | ||
4 | PR = "r7" | ||
5 | |||
6 | SRC_URI = "svn://svn.o-hand.com/repos/clutter/trunk;module=clutter;proto=http \ | ||
7 | file://enable_tests.patch;patch=1 " | ||
8 | |||
9 | S = "${WORKDIR}/clutter" | ||
10 | |||
11 | |||
diff --git a/meta/packages/clutter/table.inc b/meta/packages/clutter/table.inc new file mode 100644 index 0000000000..6ee1672197 --- /dev/null +++ b/meta/packages/clutter/table.inc | |||
@@ -0,0 +1,17 @@ | |||
1 | DESCRIPTION = "Table Clutter Demo" | ||
2 | HOMEPAGE = "http://www.clutter-project.org/" | ||
3 | LICENSE = "LGPL" | ||
4 | |||
5 | DEPENDS = "clutter-gst gnome-vfs" | ||
6 | |||
7 | inherit autotools pkgconfig | ||
8 | |||
9 | do_install() { | ||
10 | install -d ${D}${bindir} | ||
11 | install -m 0755 ${S}/table ${D}${bindir}/table | ||
12 | } | ||
13 | |||
14 | #do_stage () { | ||
15 | # autotools_stage_all | ||
16 | #} | ||
17 | |||
diff --git a/meta/packages/clutter/table/fixes.patch b/meta/packages/clutter/table/fixes.patch new file mode 100644 index 0000000000..a7cdc43713 --- /dev/null +++ b/meta/packages/clutter/table/fixes.patch | |||
@@ -0,0 +1,14 @@ | |||
1 | Index: table/Makefile | ||
2 | =================================================================== | ||
3 | --- table.orig/Makefile 2007-07-10 13:24:18.000000000 +0100 | ||
4 | +++ table/Makefile 2007-07-10 13:28:10.000000000 +0100 | ||
5 | @@ -8,7 +8,7 @@ all: table | ||
6 | |||
7 | |||
8 | table: table.o clutter-dominatrix.o clutter-video-player.o | ||
9 | - $(CC) -g -Wall $(CFLAGS) -o $@ table.o clutter-dominatrix.o clutter-video-player.o $(LIBS) | ||
10 | + $(CC) -g -Wall $(CFLAGS) $(LDFLAGS) -o $@ table.o clutter-dominatrix.o clutter-video-player.o $(LIBS) | ||
11 | |||
12 | clean: | ||
13 | rm -fr *.o table | ||
14 | \ No newline at end of file | ||
diff --git a/meta/packages/clutter/table_svn.bb b/meta/packages/clutter/table_svn.bb new file mode 100644 index 0000000000..d0dc86cd9c --- /dev/null +++ b/meta/packages/clutter/table_svn.bb | |||
@@ -0,0 +1,11 @@ | |||
1 | require table.inc | ||
2 | |||
3 | PV = "0.3.0+svn${SRCDATE}" | ||
4 | PR = "r0" | ||
5 | |||
6 | SRC_URI = "svn://svn.o-hand.com/repos/clutter/trunk/toys;module=table;proto=http \ | ||
7 | file://fixes.patch;patch=1" | ||
8 | |||
9 | S = "${WORKDIR}/table" | ||
10 | |||
11 | |||