diff options
author | Richard Purdie <richard@openedhand.com> | 2008-08-12 11:18:59 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2008-08-12 11:18:59 +0000 |
commit | 5bbdd31d82535586f5b1e1984c86a718b16b4380 (patch) | |
tree | e40e5d3221eeafb10282eb6a369fe2dabb6dbbec /meta/packages/clutter | |
parent | 67e520f96faaa1880b5992516e36fe7377887fea (diff) | |
download | poky-5bbdd31d82535586f5b1e1984c86a718b16b4380.tar.gz |
Add moblin-proto, drop ununused clutter-box2d patch
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5056 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/clutter')
-rw-r--r-- | meta/packages/clutter/clutter-box2d/clutter08.patch | 13 | ||||
-rw-r--r-- | meta/packages/clutter/moblin-proto/fix.patch | 44 | ||||
-rw-r--r-- | meta/packages/clutter/moblin-proto_git.bb | 14 |
3 files changed, 58 insertions, 13 deletions
diff --git a/meta/packages/clutter/clutter-box2d/clutter08.patch b/meta/packages/clutter/clutter-box2d/clutter08.patch deleted file mode 100644 index bf830a79c8..0000000000 --- a/meta/packages/clutter/clutter-box2d/clutter08.patch +++ /dev/null | |||
@@ -1,13 +0,0 @@ | |||
1 | Index: clutter-box2d/configure.ac | ||
2 | =================================================================== | ||
3 | --- clutter-box2d.orig/configure.ac 2008-07-16 10:09:40.000000000 +0100 | ||
4 | +++ clutter-box2d/configure.ac 2008-07-16 10:09:51.000000000 +0100 | ||
5 | @@ -70,7 +70,7 @@ | ||
6 | dnl ======================================================================== | ||
7 | |||
8 | |||
9 | -pkg_modules="clutter-0.7 >= 0.7.0" | ||
10 | +pkg_modules="clutter-0.8 >= 0.8.0" | ||
11 | PKG_CHECK_MODULES(DEPS, [$pkg_modules]) | ||
12 | |||
13 | if test "x$GCC" = "xyes"; then | ||
diff --git a/meta/packages/clutter/moblin-proto/fix.patch b/meta/packages/clutter/moblin-proto/fix.patch new file mode 100644 index 0000000000..802b8c4b6c --- /dev/null +++ b/meta/packages/clutter/moblin-proto/fix.patch | |||
@@ -0,0 +1,44 @@ | |||
1 | Index: git/Makefile | ||
2 | =================================================================== | ||
3 | --- git.orig/Makefile 2008-08-11 22:49:48.000000000 +0100 | ||
4 | +++ git/Makefile 2008-08-12 12:16:52.000000000 +0100 | ||
5 | @@ -15,7 +15,7 @@ | ||
6 | |||
7 | SCP_DESTINATION=pug.vpn:tmp | ||
8 | |||
9 | -BINARY=$(shell basename `pwd`)# | ||
10 | +BINARY=moblin-proto | ||
11 | PACKAGE=../$(BINARY).tar.bz2 # you can use both .gz and .bz2 as extension here | ||
12 | |||
13 | #CFLAGS= -Wall -I /home/pippin/src/clutter-box2d/clutter-box2d | ||
14 | @@ -61,7 +61,7 @@ | ||
15 | %.o: %.c $(HFILES) | ||
16 | $(CC) -g $(CFLAGS) $(INCS) -c $< -o$@ | ||
17 | $(BINARY): $(OBJECTS) | ||
18 | - $(CC) -o $@ $(OBJECTS) $(LIBS) | ||
19 | + $(CXX) -o $@ $(OBJECTS) $(LIBS) | ||
20 | |||
21 | #$(BINARY): $(CFILES) | ||
22 | # $(LD) $(CFLAGS) $(INCS) $(CFILES) $(LIBS) -o $@ | ||
23 | Index: git/moblin-desktop.c | ||
24 | =================================================================== | ||
25 | --- git.orig/moblin-desktop.c 2008-08-11 22:49:49.000000000 +0100 | ||
26 | +++ git/moblin-desktop.c 2008-08-12 12:14:44.000000000 +0100 | ||
27 | @@ -620,17 +620,10 @@ | ||
28 | |||
29 | attach_reactivate_on_press (old_app); | ||
30 | |||
31 | -<<<<<<< HEAD:moblin-desktop.c | ||
32 | shuttle = clutter_group_new (); | ||
33 | clutter_group_add (CLUTTER_GROUP(desktop->mainstuff), shuttle); | ||
34 | copy_geometry (desktop->middle, shuttle); | ||
35 | clutter_actor_reparent (old_app, shuttle); | ||
36 | -======= | ||
37 | - box = clutter_group_new (); | ||
38 | - clutter_group_add (CLUTTER_GROUP(desktop->stage), box); | ||
39 | - copy_geometry (desktop->middle, box); | ||
40 | - clutter_actor_reparent (old_app, box); | ||
41 | ->>>>>>> Removed now unneeded forcible shows of apps.:moblin-desktop.c | ||
42 | |||
43 | { | ||
44 | gint x, y; | ||
diff --git a/meta/packages/clutter/moblin-proto_git.bb b/meta/packages/clutter/moblin-proto_git.bb new file mode 100644 index 0000000000..00b5b5e3f3 --- /dev/null +++ b/meta/packages/clutter/moblin-proto_git.bb | |||
@@ -0,0 +1,14 @@ | |||
1 | |||
2 | DEPENDS = "clutter-box2d" | ||
3 | |||
4 | PV = "0.0+git${SRCREV}" | ||
5 | |||
6 | SRC_URI = "git://moblin.org/repos/users/pippin/prototype.git/;protocol=http \ | ||
7 | file://fix.patch;patch=1" | ||
8 | |||
9 | S = "${WORKDIR}/git" | ||
10 | |||
11 | do_install () { | ||
12 | install -d ${D}${bindir} | ||
13 | install ${S}/moblin-proto ${D}${bindir} | ||
14 | } | ||