summaryrefslogtreecommitdiffstats
path: root/meta/packages/clutter/moblin-proto/fix.patch
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-08-12 11:18:59 +0000
committerRichard Purdie <richard@openedhand.com>2008-08-12 11:18:59 +0000
commit5bbdd31d82535586f5b1e1984c86a718b16b4380 (patch)
treee40e5d3221eeafb10282eb6a369fe2dabb6dbbec /meta/packages/clutter/moblin-proto/fix.patch
parent67e520f96faaa1880b5992516e36fe7377887fea (diff)
downloadpoky-5bbdd31d82535586f5b1e1984c86a718b16b4380.tar.gz
Add moblin-proto, drop ununused clutter-box2d patch
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5056 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/clutter/moblin-proto/fix.patch')
-rw-r--r--meta/packages/clutter/moblin-proto/fix.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/packages/clutter/moblin-proto/fix.patch b/meta/packages/clutter/moblin-proto/fix.patch
new file mode 100644
index 0000000000..802b8c4b6c
--- /dev/null
+++ b/meta/packages/clutter/moblin-proto/fix.patch
@@ -0,0 +1,44 @@
1Index: git/Makefile
2===================================================================
3--- git.orig/Makefile 2008-08-11 22:49:48.000000000 +0100
4+++ git/Makefile 2008-08-12 12:16:52.000000000 +0100
5@@ -15,7 +15,7 @@
6
7 SCP_DESTINATION=pug.vpn:tmp
8
9-BINARY=$(shell basename `pwd`)#
10+BINARY=moblin-proto
11 PACKAGE=../$(BINARY).tar.bz2 # you can use both .gz and .bz2 as extension here
12
13 #CFLAGS= -Wall -I /home/pippin/src/clutter-box2d/clutter-box2d
14@@ -61,7 +61,7 @@
15 %.o: %.c $(HFILES)
16 $(CC) -g $(CFLAGS) $(INCS) -c $< -o$@
17 $(BINARY): $(OBJECTS)
18- $(CC) -o $@ $(OBJECTS) $(LIBS)
19+ $(CXX) -o $@ $(OBJECTS) $(LIBS)
20
21 #$(BINARY): $(CFILES)
22 # $(LD) $(CFLAGS) $(INCS) $(CFILES) $(LIBS) -o $@
23Index: git/moblin-desktop.c
24===================================================================
25--- git.orig/moblin-desktop.c 2008-08-11 22:49:49.000000000 +0100
26+++ git/moblin-desktop.c 2008-08-12 12:14:44.000000000 +0100
27@@ -620,17 +620,10 @@
28
29 attach_reactivate_on_press (old_app);
30
31-<<<<<<< HEAD:moblin-desktop.c
32 shuttle = clutter_group_new ();
33 clutter_group_add (CLUTTER_GROUP(desktop->mainstuff), shuttle);
34 copy_geometry (desktop->middle, shuttle);
35 clutter_actor_reparent (old_app, shuttle);
36-=======
37- box = clutter_group_new ();
38- clutter_group_add (CLUTTER_GROUP(desktop->stage), box);
39- copy_geometry (desktop->middle, box);
40- clutter_actor_reparent (old_app, box);
41->>>>>>> Removed now unneeded forcible shows of apps.:moblin-desktop.c
42
43 {
44 gint x, y;