summaryrefslogtreecommitdiffstats
path: root/meta/packages/clutter/clutter/enable_tests.patch
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2008-12-18 17:00:46 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2008-12-18 17:00:46 +0000
commit01121bc89e0406cb3a651abe09c47bdfec10c566 (patch)
tree770350631e124f241e17479cc4dd559fb979bace /meta/packages/clutter/clutter/enable_tests.patch
parent0f918b445e48ff1d45929251697f476c1053bc43 (diff)
downloadpoky-01121bc89e0406cb3a651abe09c47bdfec10c566.tar.gz
clutter: Fix enable_tests patch for recent changes
Diffstat (limited to 'meta/packages/clutter/clutter/enable_tests.patch')
-rw-r--r--meta/packages/clutter/clutter/enable_tests.patch44
1 files changed, 14 insertions, 30 deletions
diff --git a/meta/packages/clutter/clutter/enable_tests.patch b/meta/packages/clutter/clutter/enable_tests.patch
index 4a99968fa3..8544614790 100644
--- a/meta/packages/clutter/clutter/enable_tests.patch
+++ b/meta/packages/clutter/clutter/enable_tests.patch
@@ -4,40 +4,24 @@
4 tests/test-text.c | 2 +- 4 tests/test-text.c | 2 +-
5 3 files changed, 8 insertions(+), 3 deletions(-) 5 3 files changed, 8 insertions(+), 3 deletions(-)
6 6
7Index: clutter/tests/Makefile.am 7Index: git/tests/interactive/Makefile.am
8=================================================================== 8===================================================================
9--- clutter.orig/tests/Makefile.am 2008-04-25 16:45:17.000000000 +0100 9--- git.orig/tests/interactive/Makefile.am 2008-12-18 16:50:45.000000000 +0000
10+++ clutter/tests/Makefile.am 2008-04-25 16:47:12.000000000 +0100 10+++ git/tests/interactive/Makefile.am 2008-12-18 16:57:36.000000000 +0000
11@@ -1,4 +1,4 @@ 11@@ -68,7 +68,7 @@
12-noinst_PROGRAMS = test-textures test-events test-offscreen test-scale \ 12 AM_CFLAGS = $(CLUTTER_CFLAGS)
13+bin_PROGRAMS = test-textures test-events test-offscreen test-scale \ 13 AM_LDFLAGS = $(CLUTTER_LIBS)
14 test-actors test-behave test-text test-entry test-project \
15 test-perspective test-rotate test-depth \
16 test-threads test-timeline test-timeline-dup-frames \
17@@ -14,7 +14,7 @@
18 test-cogl-tex-polygon test-stage-read-pixels
19 14
20 if X11_TESTS 15-noinst_PROGRAMS = test-interactive
21-noinst_PROGRAMS += test-pixmap 16+bin_PROGRAMS = test-interactive
22+bin_PROGRAMS += test-pixmap
23 endif
24 17
25 INCLUDES = -I$(top_srcdir)/ -I$(top_builddir)/clutter 18 test_interactive_SOURCES = \
26@@ -61,4 +61,9 @@ 19 test-main.c \
27 test_cogl_offscreen_SOURCES = test-cogl-offscreen.c 20Index: git/tests/interactive/test-actors.c
28 test_stage_read_pixels_SOURCES = test-stage-read-pixels.c
29
30+test_textdir = $(pkgdatadir)
31+test_text_DATA = test-text.c
32+test_actorsdir = $(pkgdatadir)
33+test_actors_DATA = redhand.png
34+
35 EXTRA_DIST = redhand.png test-script.json
36Index: clutter/tests/test-actors.c
37=================================================================== 21===================================================================
38--- clutter.orig/tests/test-actors.c 2008-04-25 16:45:17.000000000 +0100 22--- git.orig/tests/interactive/test-actors.c 2008-12-18 16:58:06.000000000 +0000
39+++ clutter/tests/test-actors.c 2008-04-25 16:45:17.000000000 +0100 23+++ git/tests/interactive/test-actors.c 2008-12-18 16:58:13.000000000 +0000
40@@ -184,7 +184,7 @@ 24@@ -189,7 +189,7 @@
41 /* Create a texture from file, then clone in to same resources */ 25 /* Create a texture from file, then clone in to same resources */
42 if (i == 0) 26 if (i == 0)
43 { 27 {