diff options
author | Jorn Baayen <jorn@openedhand.com> | 2006-08-25 10:14:14 +0000 |
---|---|---|
committer | Jorn Baayen <jorn@openedhand.com> | 2006-08-25 10:14:14 +0000 |
commit | 55b765064de10fd49f4ea5df29e38e7d8329e570 (patch) | |
tree | 9dfe3fd55db0bed9ab281788f9a2402366e19672 /meta/packages/cairo | |
parent | ad1b593155e92f3c8ef381c0dee089983bb748c7 (diff) | |
download | poky-55b765064de10fd49f4ea5df29e38e7d8329e570.tar.gz |
Added faster cairo_fixed_from_double()
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@638 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/cairo')
-rw-r--r-- | meta/packages/cairo/cairo_1.2.4.bb (renamed from meta/packages/cairo/cairo_1.2.0.bb) | 3 | ||||
-rw-r--r-- | meta/packages/cairo/files/cairo-fixed.patch | 43 |
2 files changed, 45 insertions, 1 deletions
diff --git a/meta/packages/cairo/cairo_1.2.0.bb b/meta/packages/cairo/cairo_1.2.4.bb index 10603e3f2f..bad6da8bde 100644 --- a/meta/packages/cairo/cairo_1.2.0.bb +++ b/meta/packages/cairo/cairo_1.2.4.bb | |||
@@ -6,7 +6,8 @@ DESCRIPTION = "Cairo graphics library" | |||
6 | LICENSE = "MPL LGPL" | 6 | LICENSE = "MPL LGPL" |
7 | PR = "r1" | 7 | PR = "r1" |
8 | 8 | ||
9 | SRC_URI = "http://cairographics.org/releases/cairo-${PV}.tar.gz" | 9 | SRC_URI = "http://cairographics.org/releases/cairo-${PV}.tar.gz \ |
10 | file://cairo-fixed.patch;patch=1" | ||
10 | 11 | ||
11 | inherit autotools pkgconfig | 12 | inherit autotools pkgconfig |
12 | 13 | ||
diff --git a/meta/packages/cairo/files/cairo-fixed.patch b/meta/packages/cairo/files/cairo-fixed.patch new file mode 100644 index 0000000000..8df54d9cb5 --- /dev/null +++ b/meta/packages/cairo/files/cairo-fixed.patch | |||
@@ -0,0 +1,43 @@ | |||
1 | diff -ur cairo-1.2.4/src/cairo-fixed.c cairo-1.2.4-new/src/cairo-fixed.c | ||
2 | --- cairo-1.2.4/src/cairo-fixed.c 2006-06-10 07:07:37.000000000 +0300 | ||
3 | +++ cairo-1.2.4-new/src/cairo-fixed.c 2006-08-25 13:06:26.000000000 +0300 | ||
4 | @@ -43,12 +43,6 @@ | ||
5 | } | ||
6 | |||
7 | cairo_fixed_t | ||
8 | -_cairo_fixed_from_double (double d) | ||
9 | -{ | ||
10 | - return (cairo_fixed_t) floor (d * 65536 + 0.5); | ||
11 | -} | ||
12 | - | ||
13 | -cairo_fixed_t | ||
14 | _cairo_fixed_from_26_6 (uint32_t i) | ||
15 | { | ||
16 | return i << 10; | ||
17 | diff -ur cairo-1.2.4/src/cairoint.h cairo-1.2.4-new/src/cairoint.h | ||
18 | --- cairo-1.2.4/src/cairoint.h 2006-08-18 17:20:16.000000000 +0300 | ||
19 | +++ cairo-1.2.4-new/src/cairoint.h 2006-08-25 13:14:07.000000000 +0300 | ||
20 | @@ -1117,8 +1117,21 @@ | ||
21 | |||
22 | #define CAIRO_FIXED_ONE _cairo_fixed_from_int (1) | ||
23 | |||
24 | -cairo_private cairo_fixed_t | ||
25 | -_cairo_fixed_from_double (double d); | ||
26 | +#define CAIRO_DOUBLE2FIX_MAGIC 103079215104.0 /* 2 ^ (52 - 16) * 1.5 */ | ||
27 | + | ||
28 | +#ifdef WORDS_BIGENDIAN | ||
29 | +#define iman 1 | ||
30 | +#else | ||
31 | +#define iman 0 | ||
32 | +#endif | ||
33 | + | ||
34 | +static inline cairo_fixed_t | ||
35 | +_cairo_fixed_from_double (double d) | ||
36 | +{ | ||
37 | + d = d + CAIRO_DOUBLE2FIX_MAGIC; | ||
38 | + | ||
39 | + return ((cairo_fixed_t *) &d)[iman]; | ||
40 | +} | ||
41 | |||
42 | cairo_private cairo_fixed_t | ||
43 | _cairo_fixed_from_26_6 (uint32_t i); | ||