summaryrefslogtreecommitdiffstats
path: root/meta/packages/bzip2
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2008-06-26 19:34:56 +0000
committerRichard Purdie <richard@openedhand.com>2008-06-26 19:34:56 +0000
commit8722fb9b43a434a310babbfa50c077d472cd3387 (patch)
tree5d421e22613d7bdef69f19dccc0870b61dfc0ba8 /meta/packages/bzip2
parent85221a39bc256f5a8116b35ff9eddd97affafa07 (diff)
downloadpoky-8722fb9b43a434a310babbfa50c077d472cd3387.tar.gz
bzip2: Add 1.0.5 and autotool it
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4736 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/bzip2')
-rw-r--r--meta/packages/bzip2/bzip2-1.0.5/Makefile.am41
-rw-r--r--meta/packages/bzip2/bzip2-1.0.5/configure.ac14
-rw-r--r--meta/packages/bzip2/bzip2_1.0.5.bb39
3 files changed, 94 insertions, 0 deletions
diff --git a/meta/packages/bzip2/bzip2-1.0.5/Makefile.am b/meta/packages/bzip2/bzip2-1.0.5/Makefile.am
new file mode 100644
index 0000000000..b234e80f37
--- /dev/null
+++ b/meta/packages/bzip2/bzip2-1.0.5/Makefile.am
@@ -0,0 +1,41 @@
1
2lib_LTLIBRARIES = libbz2.la
3
4libbz2_la_SOURCES = blocksort.c \
5 huffman.c \
6 crctable.c \
7 randtable.c \
8 compress.c \
9 decompress.c \
10 bzlib.c
11
12bin_PROGRAMS = bzip2 bzip2recover
13
14bzip2_SOURCES = bzip2.c
15bzip2_LDADD = libbz2.la
16bzip2_DEPENDENCIES = libbz2.la
17
18include_HEADERS = bzlib.h
19
20bzip2recover_SOURCES = bzip2recover.c
21bzip2recover_LDADD = libbz2.la
22bzip2recover_DEPENDENCIES = libbz2.la
23
24bin_SCRIPTS = bzgrep bzgrep bzmore bzdiff
25
26man_MANS = bzip2.1 bzgrep.1 bzmore.1 bzdiff.1
27EXTRA_DIST = $(man_MANS)
28
29install-exec-hook:
30 ln -s $(bindir)/bzip2$(EXEEXT) $(DESTDIR)$(bindir)/bunzip2$(EXEEXT)
31 ln -s $(bindir)/bzip2$(EXEEXT) $(DESTDIR)$(bindir)/bzcat$(EXEEXT)
32 ln -s $(bindir)/bzgrep$(EXEEXT) $(DESTDIR)$(bindir)/bzegrep$(EXEEXT)
33 ln -s $(bindir)/bzgrep$(EXEEXT) $(DESTDIR)$(bindir)/bzfgrep$(EXEEXT)
34 ln -s $(bindir)/bzmore$(EXEEXT) $(DESTDIR)$(bindir)/bzless$(EXEEXT)
35 ln -s $(bindir)/bzdiff$(EXEEXT) $(DESTDIR)$(bindir)/bzcmp$(EXEEXT)
36
37install-data-hook:
38 echo ".so man1/bzgrep.1" > $(DESTDIR)$(mandir)/man1/bzegrep.1
39 echo ".so man1/bzgrep.1" > $(DESTDIR)$(mandir)/man1/bzfgrep.1
40 echo ".so man1/bzmore.1" > $(DESTDIR)$(mandir)/man1/bzless.1
41 echo ".so man1/bzdiff.1" > $(DESTDIR)$(mandir)/man1/bzcmp.1
diff --git a/meta/packages/bzip2/bzip2-1.0.5/configure.ac b/meta/packages/bzip2/bzip2-1.0.5/configure.ac
new file mode 100644
index 0000000000..14b1d1809d
--- /dev/null
+++ b/meta/packages/bzip2/bzip2-1.0.5/configure.ac
@@ -0,0 +1,14 @@
1AC_PREREQ([2.57])
2
3AC_INIT(bzip2, 2.0.5, , libXrender)
4AM_INIT_AUTOMAKE()
5AM_MAINTAINER_MODE
6
7#AM_CONFIG_HEADER(config.h)
8
9# Check for progs
10AC_PROG_CC
11AC_PROG_LIBTOOL
12
13AC_OUTPUT([Makefile])
14
diff --git a/meta/packages/bzip2/bzip2_1.0.5.bb b/meta/packages/bzip2/bzip2_1.0.5.bb
new file mode 100644
index 0000000000..04e55e3083
--- /dev/null
+++ b/meta/packages/bzip2/bzip2_1.0.5.bb
@@ -0,0 +1,39 @@
1DESCRIPTION = "Very high-quality data compression program."
2SECTION = "console/utils"
3PR = "r0"
4
5LICENSE = "bzip2"
6SRC_URI = "http://www.bzip.org/1.0.5/bzip2-1.0.5.tar.gz \
7 file://configure.ac \
8 file://Makefile.am"
9
10CFLAGS_append = " -fPIC -fpic -Winline -fno-strength-reduce -D_FILE_OFFSET_BITS=64"
11
12inherit autotools
13
14do_configure_prepend () {
15 cp ${WORKDIR}/configure.ac ${S}/
16 cp ${WORKDIR}/Makefile.am ${S}/
17 cp ${STAGING_DATADIR_NATIVE}/automake*/install-sh ${S}/
18}
19
20do_install_append () {
21 mv ${D}${bindir}/bunzip2 ${D}${bindir}/bunzip2.${PN}
22 mv ${D}${bindir}/bzcat ${D}${bindir}/bzcat.${PN}
23}
24
25do_stage () {
26 install -m 0644 bzlib.h ${STAGING_INCDIR}/
27 oe_libinstall -a -so libbz2 ${STAGING_LIBDIR}
28}
29
30pkg_postinst_${PN} () {
31 update-alternatives --install ${bindir}/bunzip2 bunzip2 bunzip2.${PN} 100
32 update-alternatives --install ${bindir}/bzcat bzcat bzcat.${PN} 100
33}
34
35
36pkg_prerm_${PN} () {
37 update-alternatives --remove bunzip2 bunzip2.${PN}
38 update-alternatives --remove bzcat bzcat.${PN}
39}