diff options
author | Richard Purdie <richard@openedhand.com> | 2006-11-21 10:02:56 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2006-11-21 10:02:56 +0000 |
commit | 03c40cce7cf5c9791661544da396ab61e396ad8a (patch) | |
tree | a0a0a4e984152f1dac0d40ffb559441a5d605d84 /meta/packages/busybox | |
parent | dce65a1c29315c28044e7a50a1bd328b32cbcc6d (diff) | |
download | poky-03c40cce7cf5c9791661544da396ab61e396ad8a.tar.gz |
busybox: Sync with OE.dev
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@902 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/busybox')
4 files changed, 23 insertions, 7 deletions
diff --git a/meta/packages/busybox/busybox-1.01/nylon/defconfig b/meta/packages/busybox/busybox-1.01/nylon/defconfig index 599051bafb..3e4257ef04 100644 --- a/meta/packages/busybox/busybox-1.01/nylon/defconfig +++ b/meta/packages/busybox/busybox-1.01/nylon/defconfig | |||
@@ -51,7 +51,7 @@ CONFIG_GZIP=y | |||
51 | # CONFIG_RPM is not set | 51 | # CONFIG_RPM is not set |
52 | CONFIG_TAR=y | 52 | CONFIG_TAR=y |
53 | CONFIG_FEATURE_TAR_CREATE=y | 53 | CONFIG_FEATURE_TAR_CREATE=y |
54 | CONFIG_FEATURE_TAR_BZIP2=y | 54 | # CONFIG_FEATURE_TAR_BZIP2 is not set |
55 | CONFIG_FEATURE_TAR_FROM=y | 55 | CONFIG_FEATURE_TAR_FROM=y |
56 | CONFIG_FEATURE_TAR_GZIP=y | 56 | CONFIG_FEATURE_TAR_GZIP=y |
57 | CONFIG_FEATURE_TAR_COMPRESS=y | 57 | CONFIG_FEATURE_TAR_COMPRESS=y |
diff --git a/meta/packages/busybox/busybox-1.01/uclibc_posix.patch b/meta/packages/busybox/busybox-1.01/uclibc_posix.patch index aefb994068..186f3f9c3a 100644 --- a/meta/packages/busybox/busybox-1.01/uclibc_posix.patch +++ b/meta/packages/busybox/busybox-1.01/uclibc_posix.patch | |||
@@ -1,12 +1,13 @@ | |||
1 | see http://www.busybox.net/lists/busybox/2004-December/013276.html | 1 | see http://www.busybox.net/lists/busybox/2004-December/013276.html |
2 | and http://bugs.openembedded.org/show_bug.cgi?id=657 | ||
2 | 3 | ||
3 | --- busybox-old/libbb/loop.c 2004-08-16 04:36:28.000000000 -0400 | 4 | --- busybox-1.01/libbb/loop.c 2006/03/13 22:18:47 1.1 |
4 | +++ busybox/libbb/loop.c 2004-12-04 23:45:58.000000000 -0500 | 5 | +++ busybox-1.01/libbb/loop.c 2006/03/13 22:19:57 |
5 | @@ -19,6 +19,7 @@ | 6 | @@ -19,6 +19,7 @@ |
6 | * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA | 7 | * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA |
7 | */ | 8 | */ |
8 | 9 | ||
9 | +#include <asm/posix_types.h> | 10 | +#include <linux/types.h> |
10 | #include <stdio.h> | 11 | #include <stdio.h> |
11 | #include <errno.h> | 12 | #include <errno.h> |
12 | #include <fcntl.h> | 13 | #include <fcntl.h> |
diff --git a/meta/packages/busybox/busybox-1.01/xargs-double-size.patch b/meta/packages/busybox/busybox-1.01/xargs-double-size.patch new file mode 100644 index 0000000000..218d6c0d1c --- /dev/null +++ b/meta/packages/busybox/busybox-1.01/xargs-double-size.patch | |||
@@ -0,0 +1,13 @@ | |||
1 | --- busybox-1.01/findutils/xargs.c.org 2006-09-19 18:18:17.084592997 +0200 | ||
2 | +++ busybox-1.01/findutils/xargs.c 2006-09-19 18:18:09.820275793 +0200 | ||
3 | @@ -466,8 +466,8 @@ | ||
4 | have it at 1 meg). Things will work fine with a large ARG_MAX but it | ||
5 | will probably hurt the system more than it needs to; an array of this | ||
6 | size is allocated. */ | ||
7 | - if (orig_arg_max > 20 * 1024) | ||
8 | - orig_arg_max = 20 * 1024; | ||
9 | + if (orig_arg_max > 40 * 1024) | ||
10 | + orig_arg_max = 40 * 1024; | ||
11 | n_max_chars = orig_arg_max; | ||
12 | } | ||
13 | max_chars = xmalloc(n_max_chars); | ||
diff --git a/meta/packages/busybox/busybox_1.01.bb b/meta/packages/busybox/busybox_1.01.bb index 996b5418a4..9c8b7e60c3 100644 --- a/meta/packages/busybox/busybox_1.01.bb +++ b/meta/packages/busybox/busybox_1.01.bb | |||
@@ -10,7 +10,7 @@ HOMEPAGE = "http://www.busybox.net" | |||
10 | LICENSE = "GPL" | 10 | LICENSE = "GPL" |
11 | SECTION = "base" | 11 | SECTION = "base" |
12 | PRIORITY = "required" | 12 | PRIORITY = "required" |
13 | PR = "r11" | 13 | PR = "r12" |
14 | 14 | ||
15 | SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \ | 15 | SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \ |
16 | file://udhcppidfile.patch;patch=1 \ | 16 | file://udhcppidfile.patch;patch=1 \ |
@@ -28,8 +28,8 @@ SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \ | |||
28 | file://rmmod.patch;patch=1 \ | 28 | file://rmmod.patch;patch=1 \ |
29 | file://udhcpscript.patch;patch=1 \ | 29 | file://udhcpscript.patch;patch=1 \ |
30 | file://thumb-bsdlabel.patch;patch=1 \ | 30 | file://thumb-bsdlabel.patch;patch=1 \ |
31 | file://glibc2.4-icmp6.patch;patch=1 \ | ||
31 | file://uclibc_posix.patch;patch=1 \ | 32 | file://uclibc_posix.patch;patch=1 \ |
32 | file://glibc2.4-icmp6.patch;patch=1 \ | ||
33 | file://defconfig \ | 33 | file://defconfig \ |
34 | file://busybox-cron \ | 34 | file://busybox-cron \ |
35 | file://busybox-httpd \ | 35 | file://busybox-httpd \ |
@@ -40,7 +40,9 @@ SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \ | |||
40 | file://syslog.conf \ | 40 | file://syslog.conf \ |
41 | file://mount.busybox \ | 41 | file://mount.busybox \ |
42 | file://umount.busybox" | 42 | file://umount.busybox" |
43 | |||
43 | SRC_URI_append_slugos += " file://sysctl.conf " | 44 | SRC_URI_append_slugos += " file://sysctl.conf " |
45 | SRC_URI_append_nylon = " file://xargs-double-size.patch;patch=1" | ||
44 | 46 | ||
45 | S = "${WORKDIR}/busybox-${PV}" | 47 | S = "${WORKDIR}/busybox-${PV}" |
46 | 48 | ||
@@ -85,7 +87,7 @@ do_install () { | |||
85 | install -d ${D}${base_bindir} | 87 | install -d ${D}${base_bindir} |
86 | mv ${D}/busybox${base_bindir}/busybox ${D}${base_bindir}/ | 88 | mv ${D}/busybox${base_bindir}/busybox ${D}${base_bindir}/ |
87 | # Move back the sh symlink | 89 | # Move back the sh symlink |
88 | mv ${D}/busybox${base_bindir}/sh ${D}${base_bindir}/ | 90 | test -h ${D}/busybox${base_bindir}/sh && mv ${D}/busybox${base_bindir}/sh ${D}${base_bindir}/ |
89 | 91 | ||
90 | install -m 0755 ${WORKDIR}/syslog ${D}${sysconfdir}/init.d/ | 92 | install -m 0755 ${WORKDIR}/syslog ${D}${sysconfdir}/init.d/ |
91 | install -m 644 ${WORKDIR}/syslog.conf ${D}${sysconfdir}/ | 93 | install -m 644 ${WORKDIR}/syslog.conf ${D}${sysconfdir}/ |