summaryrefslogtreecommitdiffstats
path: root/meta/packages/busybox/busybox_1.01.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-03-03 17:39:29 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-03-03 17:39:29 +0000
commit6314103003cef434c29d2133769195daf5cc9309 (patch)
tree9c450c156ce82a0a424d5654790def0e895a4707 /meta/packages/busybox/busybox_1.01.bb
parent9f9900b9b4ef2d2e855293f7850f81fa0f33a616 (diff)
downloadpoky-6314103003cef434c29d2133769195daf5cc9309.tar.gz
busybox: drop 1.01, make 1.8.2 default
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3888 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/busybox/busybox_1.01.bb')
-rw-r--r--meta/packages/busybox/busybox_1.01.bb172
1 files changed, 0 insertions, 172 deletions
diff --git a/meta/packages/busybox/busybox_1.01.bb b/meta/packages/busybox/busybox_1.01.bb
deleted file mode 100644
index c4968ab6e6..0000000000
--- a/meta/packages/busybox/busybox_1.01.bb
+++ /dev/null
@@ -1,172 +0,0 @@
1DESCRIPTION = "BusyBox combines tiny versions of many common UNIX utilities into a single \
2small executable. It provides minimalist replacements for most of the \
3utilities you usually find in GNU fileutils, shellutils, etc. The utilities \
4in BusyBox generally have fewer options than their full-featured GNU \
5cousins; however, the options that are included provide the expected \
6functionality and behave very much like their GNU counterparts. BusyBox \
7provides a fairly complete POSIX environment for any small or embedded \
8system."
9HOMEPAGE = "http://www.busybox.net"
10LICENSE = "GPL"
11SECTION = "base"
12PRIORITY = "required"
13PR = "r16"
14
15SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
16 file://no_strip.patch;patch=1 \
17 file://udhcppidfile.patch;patch=1 \
18 file://udhcppidfile-breakage.patch;patch=1 \
19 file://add-getkey-applet.patch;patch=1 \
20 file://below.patch;patch=1 \
21 file://dhcp-hostname.patch;patch=1 \
22 file://dhcpretrytime.patch;patch=1 \
23 file://fbset.patch;patch=1 \
24 file://hdparm_M.patch;patch=1 \
25 file://ifupdown-spurious-environ.patch;patch=1 \
26 file://iproute-flush-cache.patch;patch=1;pnum=0 \
27 file://mount-all-type.patch;patch=1 \
28 file://readlink.patch;patch=1 \
29 file://rmmod.patch;patch=1 \
30 file://udhcpscript.patch;patch=1 \
31 file://thumb-bsdlabel.patch;patch=1 \
32 file://glibc2.4-icmp6.patch;patch=1 \
33 file://defconfig \
34 file://busybox-cron \
35 file://busybox-httpd \
36 file://busybox-udhcpd \
37 file://syslog \
38 file://hwclock.sh \
39 file://default.script \
40 file://syslog.conf \
41 file://mount.busybox \
42 file://umount.busybox"
43# file://uclibc_posix.patch;patch=1 \
44
45SRC_URI_append_slugos += " file://sysctl.conf "
46SRC_URI_append_nylon = " file://xargs-double-size.patch;patch=1"
47
48S = "${WORKDIR}/busybox-${PV}"
49
50export EXTRA_CFLAGS = "${CFLAGS}"
51EXTRA_OEMAKE_append = " CROSS=${HOST_PREFIX}"
52PACKAGES =+ "${PN}-httpd ${PN}-udhcpd"
53
54FILES_${PN}-httpd = "${sysconfdir}/init.d/busybox-httpd /srv/www"
55FILES_${PN}-udhcpd = "${sysconfdir}/init.d/busybox-udhcpd"
56
57FILES_${PN} += " ${datadir}/udhcpc"
58
59INITSCRIPT_PACKAGES = "${PN} ${PN}-httpd ${PN}-udhcpd"
60INITSCRIPT_NAME_${PN}-httpd = "busybox-httpd"
61INITSCRIPT_NAME_${PN}-udhcpd = "busybox-udhcpd"
62INITSCRIPT_NAME_${PN} = "syslog"
63CONFFILES_${PN} = "${sysconfdir}/syslog.conf"
64
65# This disables the syslog startup links in slugos (see slugos-init)
66INITSCRIPT_PARAMS_${PN}_slugos = "start 20 ."
67
68inherit cml1 update-rc.d
69
70do_configure () {
71 install -m 0644 ${WORKDIR}/defconfig ${S}/.config
72 cml1_do_configure
73}
74
75do_compile () {
76 unset CFLAGS
77 base_do_compile
78}
79
80do_install () {
81 install -d ${D}${sysconfdir}/init.d
82 oe_runmake 'PREFIX=${D}' install
83
84 # Move everything to /busybox (not supposed to end up in any package)
85 install -d ${D}/busybox
86 mv ${D}${base_bindir} ${D}${base_sbindir} ${D}${prefix} ${D}/busybox/
87 # Move the busybox binary back to /bin
88 install -d ${D}${base_bindir}
89 mv ${D}/busybox${base_bindir}/busybox ${D}${base_bindir}/
90 # Move back the sh symlink
91 test -h ${D}/busybox${base_bindir}/sh && mv ${D}/busybox${base_bindir}/sh ${D}${base_bindir}/
92
93 install -m 0755 ${WORKDIR}/syslog ${D}${sysconfdir}/init.d/
94 install -m 644 ${WORKDIR}/syslog.conf ${D}${sysconfdir}/
95 if grep "CONFIG_CROND=y" ${WORKDIR}/defconfig; then
96 # Move crond back to /usr/sbin/crond
97 install -d ${D}${sbindir}
98 mv ${D}/busybox${sbindir}/crond ${D}${sbindir}/
99
100 install -m 0755 ${WORKDIR}/busybox-cron ${D}${sysconfdir}/init.d/
101 fi
102 if grep "CONFIG_HTTPD=y" ${WORKDIR}/defconfig; then
103 # Move httpd back to /usr/sbin/httpd
104 install -d ${D}${sbindir}
105 mv ${D}/busybox${sbindir}/httpd ${D}${sbindir}/
106
107 install -m 0755 ${WORKDIR}/busybox-httpd ${D}${sysconfdir}/init.d/
108 install -d ${D}/srv/www
109 fi
110 if grep "CONFIG_UDHCPD=y" ${WORKDIR}/defconfig; then
111 # Move udhcpd back to /usr/sbin/udhcpd
112 install -d ${D}${sbindir}
113 mv ${D}/busybox${sbindir}/udhcpd ${D}${sbindir}/
114
115 install -m 0755 ${WORKDIR}/busybox-udhcpd ${D}${sysconfdir}/init.d/
116 fi
117 if grep "CONFIG_HWCLOCK=y" ${WORKDIR}/defconfig; then
118 # Move hwclock back to /sbin/hwclock
119 install -d ${D}${base_sbindir}
120 mv ${D}/busybox${base_sbindir}/hwclock ${D}${base_sbindir}/
121
122 install -m 0755 ${WORKDIR}/hwclock.sh ${D}${sysconfdir}/init.d/
123 fi
124 if grep "CONFIG_UDHCPC=y" ${WORKDIR}/defconfig; then
125 # Move dhcpc back to /usr/sbin/udhcpc
126 install -d ${D}${base_sbindir}
127 mv ${D}/busybox${base_sbindir}/udhcpc ${D}${base_sbindir}/
128
129 install -d ${D}${sysconfdir}/udhcpc.d
130 install -d ${D}${datadir}/udhcpc
131 install -m 0755 ${S}/examples/udhcp/simple.script ${D}${sysconfdir}/udhcpc.d/50default
132 install -m 0755 ${WORKDIR}/default.script ${D}${datadir}/udhcpc/default.script
133 fi
134
135 install -m 0644 ${S}/busybox.links ${D}${sysconfdir}
136}
137
138do_install_append_slugos() {
139 install -m 0644 ${WORKDIR}/sysctl.conf ${D}${sysconfdir}
140}
141
142pkg_postinst_${PN} () {
143 # If we are not making an image we create links for the utilities that doesn't exist
144 # so the update-alternatives script will get the utilities it needs
145 # (update-alternatives have no problem replacing links later anyway)
146 test -n 2> /dev/null || alias test='busybox test'
147 if test "x$D" = "x"; then while read link; do if test ! -h "$link"; then case "$link" in /*/*/*) to="../../bin/busybox";; /bin/*) to="busybox";; /*/*) to="../bin/busybox";; esac; busybox ln -s $to $link; fi; done </etc/busybox.links; fi
148
149 # This adds the links, remember that this has to work when building an image too, hence the $D
150 while read link; do case "$link" in /*/*/*) to="../../bin/busybox";; /bin/*) to="busybox";; /*/*) to="../bin/busybox";; esac; bn=`basename $link`; update-alternatives --install $link $bn $to 50; done <$D/etc/busybox.links
151}
152
153pkg_prerm_${PN} () {
154 # This is so you can make busybox commit suicide - removing busybox with no other packages
155 # providing its files, this will make update-alternatives work, but the update-rc.d part
156 # for syslog, httpd and/or udhcpd will fail if there is no other package providing sh
157 tmpdir=`mktemp -d /tmp/busyboxrm-XXXXXX`
158 ln -s /bin/busybox $tmpdir/[
159 ln -s /bin/busybox $tmpdir/test
160 ln -s /bin/busybox $tmpdir/head
161 ln -s /bin/busybox $tmpdir/sh
162 ln -s /bin/busybox $tmpdir/basename
163 ln -s /bin/busybox $tmpdir/echo
164 ln -s /bin/busybox $tmpdir/mv
165 ln -s /bin/busybox $tmpdir/ln
166 ln -s /bin/busybox $tmpdir/dirname
167 ln -s /bin/busybox $tmpdir/rm
168 ln -s /bin/busybox $tmpdir/sed
169 ln -s /bin/busybox $tmpdir/sort
170 export PATH=$PATH:$tmpdir
171 while read link; do case "$link" in /*/*/*) to="../../bin/busybox";; /bin/*) to="busybox";; /*/*) to="../bin/busybox";; esac; bn=`basename $link`; sh /usr/bin/update-alternatives --remove $bn $to; done </etc/busybox.links
172}