summaryrefslogtreecommitdiffstats
path: root/meta/packages/boost/boost_1.44.0.bb
diff options
context:
space:
mode:
authorQing He <qing.he@intel.com>2010-08-19 13:32:07 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-31 17:18:55 +0100
commitadfd0e04343ad7770642eadf07a7f9185be6e25d (patch)
tree51888646c08a50095710f000ff83102a0f305b81 /meta/packages/boost/boost_1.44.0.bb
parentd1f7c3f9cc59477ef926c35eb980833d5a0246de (diff)
downloadpoky-adfd0e04343ad7770642eadf07a7f9185be6e25d.tar.gz
boost: upgrade to 1.44.0
from version 1.36.0 which won't compile with gcc 4.5.0 also moved to meta form meta-moblin changes: - .so files should go to -dev instead of sub packages - create libboostX-mt.{so,a} symlinks for compatibility - meta package 'boost' should set ALLOW_EMPTY - fix a bug that caused boost-dev being automatically renamed to libboost_prg_exec_monitor-dev, packages boost, boost-dev and boost-test now work as intended - rebased patch arm-intrinsic Signed-off-by: Qing He <qing.he@intel.com>
Diffstat (limited to 'meta/packages/boost/boost_1.44.0.bb')
-rw-r--r--meta/packages/boost/boost_1.44.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/packages/boost/boost_1.44.0.bb b/meta/packages/boost/boost_1.44.0.bb
new file mode 100644
index 0000000000..81a2e53ba3
--- /dev/null
+++ b/meta/packages/boost/boost_1.44.0.bb
@@ -0,0 +1,27 @@
1include boost-36.inc
2
3LICENSE = "boost"
4LIC_FILES_CHKSUM = "file://LICENSE_1_0.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
5
6PR = "r0"
7
8SRC_URI = "${SOURCEFORGE_MIRROR}/boost/${BOOST_P}.tar.bz2 \
9 file://arm-intrinsics.patch \
10 "
11
12BJAM_OPTS = '${BJAM_TOOLS} \
13 --builddir=${S}/${TARGET_SYS} \
14 ${BJAM_EXTRA}'
15
16# build only mt libraries and install symlinks for compatibility
17BJAM_EXTRA += "threading=multi"
18do_install_append() {
19 for lib in ${BOOST_LIBS}; do
20 if [ -e ${D}${libdir}/libboost_${lib}.a ]; then
21 ln -s libboost_${lib}.a ${D}${libdir}/libboost_${lib}-mt.a
22 fi
23 if [ -e ${D}${libdir}/libboost_${lib}.so ]; then
24 ln -s libboost_${lib}.so ${D}${libdir}/libboost_${lib}-mt.so
25 fi
26 done
27}