diff options
author | Samuel Ortiz <sameo@linux.intel.com> | 2008-11-12 13:04:51 +0100 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2008-12-01 20:44:09 +0000 |
commit | f94ff9905535e4cd0157853bc57e1b6248029ad4 (patch) | |
tree | b7de74ad48700eb4cffd8bd486a148df05349dca /meta/packages/bluez | |
parent | fdc825062564e5145fdd1ebe6c7bd416429dfd82 (diff) | |
download | poky-f94ff9905535e4cd0157853bc57e1b6248029ad4.tar.gz |
bluez4: Bump to 4.17
Diffstat (limited to 'meta/packages/bluez')
-rw-r--r-- | meta/packages/bluez/bluez4.inc | 41 | ||||
-rw-r--r-- | meta/packages/bluez/bluez4_4.17.bb | 50 |
2 files changed, 91 insertions, 0 deletions
diff --git a/meta/packages/bluez/bluez4.inc b/meta/packages/bluez/bluez4.inc new file mode 100644 index 0000000000..4afb0fd8fa --- /dev/null +++ b/meta/packages/bluez/bluez4.inc | |||
@@ -0,0 +1,41 @@ | |||
1 | DESCRIPTION = "BlueZ - Bluetooth protocol stack for Linux" | ||
2 | SECTION = "console" | ||
3 | PRIORITY = "optional" | ||
4 | DEPENDS = "gstreamer gst-plugins-base libusb dbus" | ||
5 | PROVIDES = "bluez-utils-dbus" | ||
6 | RPROVIDES_${PN} = "bluez-pan bluez-sdp bluez-utils-dbus" | ||
7 | RREPLACES_${PN} = "bluez-utils-dbus" | ||
8 | RCONFLICTS_${PN} = "bluez-utils-nodbus" | ||
9 | LICENSE = "GPL" | ||
10 | |||
11 | SRC_URI = "http://www.kernel.org/pub/linux/bluetooth/bluez-${PV}.tar.gz" | ||
12 | |||
13 | S = "${WORKDIR}/bluez-${PV}" | ||
14 | |||
15 | inherit autotools update-rc.d pkgconfig | ||
16 | |||
17 | INITSCRIPT_NAME = "bluetooth" | ||
18 | INITSCRIPT_PARAMS = "defaults 23 19" | ||
19 | |||
20 | do_install_append() { | ||
21 | install -d ${D}${base_sbindir} ${D}${base_bindir}/ | ||
22 | echo base_sbindir is: ${D}${base_sbindir} | ||
23 | mv ${D}${sbindir}/* ${D}${base_sbindir}/ | ||
24 | mv ${D}${bindir}/* ${D}${base_bindir}/ | ||
25 | rmdir ${D}${bindir} ${D}${sbindir} | ||
26 | chmod u+s ${D}${base_sbindir}/hciattach ${D}${base_sbindir}/hciconfig | ||
27 | } | ||
28 | |||
29 | PACKAGES =+ "${PN}-alsa ${PN}-alsa-dev gst-plugin-bluez gst-plugin-bluez-dev ${PN}-lib ${PN}-lib-dev ${PN}-lib-dbg" | ||
30 | |||
31 | FILES_${PN}-alsa = " ${libdir}/alsa-lib/*.so " | ||
32 | FILES_${PN}-alsa-dev += " ${libdir}/alsa-lib/*.la " | ||
33 | |||
34 | FILES_gst-plugin-bluez = "${libdir}/gstreamer-*/*.so" | ||
35 | FILES_gst-plugin-bluez-dev = "${libdir}/gstreamer-*/*.la" | ||
36 | FILES_${PN}-lib = "${libdir}/libbluetooth.so.*" | ||
37 | FILES_${PN}-lib-dev = "${libdir}/libbluetooth.so \ | ||
38 | ${libdir}/*.la \ | ||
39 | ${includedir}/bluetooth \ | ||
40 | ${libdir}/pkgconfig/bluez.pc \ | ||
41 | " | ||
diff --git a/meta/packages/bluez/bluez4_4.17.bb b/meta/packages/bluez/bluez4_4.17.bb new file mode 100644 index 0000000000..437dfe679b --- /dev/null +++ b/meta/packages/bluez/bluez4_4.17.bb | |||
@@ -0,0 +1,50 @@ | |||
1 | require bluez4.inc | ||
2 | |||
3 | DEPENDS += "glib-2.0" | ||
4 | PR = "r4" | ||
5 | |||
6 | PACKAGES =+ "${PN}-compat" | ||
7 | |||
8 | CONFFILES_${PN} = " \ | ||
9 | ${sysconfdir}/bluetooth/main.conf \ | ||
10 | " | ||
11 | |||
12 | CONFFILES_${PN}-compat = " \ | ||
13 | ${sysconfdir}/bluetooth/rfcomm.conf \ | ||
14 | " | ||
15 | |||
16 | FILES_${PN} = " \ | ||
17 | ${base_sbindir}/bluetoothd \ | ||
18 | ${libdir}/bluetooth \ | ||
19 | ${sysconfdir}/init.d/bluetooth \ | ||
20 | ${sysconfdir}/bluetooth/*.service \ | ||
21 | ${sysconfdir}/bluetooth/main.conf \ | ||
22 | ${sysconfdir}/default \ | ||
23 | ${sysconfdir}/dbus-1 \ | ||
24 | ${base_sbindir}/hciattach \ | ||
25 | ${base_sbindir}/hid2hci \ | ||
26 | " | ||
27 | |||
28 | FILES_${PN}-dbg += " \ | ||
29 | ${libdir}/bluetooth/.debug \ | ||
30 | ${libdir}/cups/backend/.debug \ | ||
31 | ${libdir}/alsa-lib/.debug \ | ||
32 | " | ||
33 | |||
34 | FILES_${PN}-lib-dbg += " ${libdir}/bluetooth/plugins/.debug/*.so" | ||
35 | |||
36 | |||
37 | FILES_${PN}-compat = " \ | ||
38 | ${base_sbindir}/bccmd \ | ||
39 | ${base_sbindir}/hciconfig \ | ||
40 | ${base_bindir}/ciptool \ | ||
41 | ${base_bindir}/dfutool \ | ||
42 | ${base_bindir}/dund \ | ||
43 | ${base_bindir}/hcitool \ | ||
44 | ${base_bindir}/hidd \ | ||
45 | ${base_bindir}/l2ping \ | ||
46 | ${base_bindir}/pand \ | ||
47 | ${base_bindir}/rfcomm \ | ||
48 | ${base_bindir}/sdptool \ | ||
49 | ${sysconfdir}/bluetooth/rfcomm.conf \ | ||
50 | " | ||