summaryrefslogtreecommitdiffstats
path: root/meta/packages/bluez/bluez-utils_3.18.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-09-07 09:04:17 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-09-07 09:04:17 +0000
commit6b728c4ad4bf63a79f51ee1318a19089f78ffb48 (patch)
tree409a6c41d6972f8b37155d7995805310d8ae300c /meta/packages/bluez/bluez-utils_3.18.bb
parent197bfeed9f24d668915bef5557b251d14dc2451a (diff)
downloadpoky-6b728c4ad4bf63a79f51ee1318a19089f78ffb48.tar.gz
bluez-utils: upgraded to 3.18
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2715 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/bluez/bluez-utils_3.18.bb')
-rw-r--r--meta/packages/bluez/bluez-utils_3.18.bb107
1 files changed, 107 insertions, 0 deletions
diff --git a/meta/packages/bluez/bluez-utils_3.18.bb b/meta/packages/bluez/bluez-utils_3.18.bb
new file mode 100644
index 0000000000..8fa75c34a7
--- /dev/null
+++ b/meta/packages/bluez/bluez-utils_3.18.bb
@@ -0,0 +1,107 @@
1require bluez-utils.inc
2
3DEPENDS += "glib-2.0"
4PR = "r1"
5
6# ti patch doesn't apply, people using it should rediff it and send it upstream
7#SRC_URI += "file://hciattach-ti-bts.patch;patch=1 "
8
9EXTRA_OECONF = " \
10 --enable-bccmd \
11 --enable-hid2hci \
12 --enable-alsa \
13 --disable-cups \
14 --enable-glib \
15 --disable-sdpd \
16 --enable-network \
17 --enable-serial \
18 --enable-input \
19 --enable-audio \
20 --enable-echo \
21 --enable-configfile \
22 --enable-initscripts \
23 --enable-test \
24 "
25
26# The config options are explained below:
27
28# --enable-obex enable OBEX support
29# --enable-alsa enable ALSA support, not needed for nokia770, nokia800 and fic-gtao1
30# --enable-cups install CUPS backend support
31# --enable-bccmd install BCCMD interface utility
32# --enable-avctrl install Audio/Video control utility
33# --enable-hid2hci install HID mode switching utility
34# --enable-dfutool install DFU firmware upgrade utility
35
36# --enable-glib For systems that use and install GLib anyway
37# --disable-sdpd The sdpd is obsolete and should no longer be used. This of course requires that hcid will be started with -s to enable the SDP server
38
39#Following services can be enabled so far:
40# --enable-network
41# --enable-serial
42# --enable-input
43# --enable-audio
44# --enable-echo
45
46#There is no need to modify any init script. They will be started
47#automatically or on demand. Only /etc/bluetooth/*.service files should
48#be patched to change name or the autostart value.
49# --enable-configfile
50# --enable-initscripts
51
52#For even smaller -doc packages
53# --disable-manpages
54# --disable-pcmciarules
55
56#I haven't seen any embedded device with HID proxy support. So simply
57#disable it:
58# --disable-hid2hci
59
60
61PACKAGES =+ "${PN}-compat"
62
63CONFFILES_${PN} = " \
64 ${sysconfdir}/bluetooth/hcid.conf \
65 ${sysconfdir}/default/bluetooth \
66 "
67
68CONFFILES_${PN}-compat = " \
69 ${sysconfdir}/bluetooth/rfcomm.conf \
70 "
71
72FILES_${PN} = " \
73 ${base_sbindir}/hcid \
74 ${libdir}/bluetooth \
75 ${sysconfdir}/init.d/bluetooth \
76 ${sysconfdir}/bluetooth/*.service \
77 ${sysconfdir}/bluetooth/hcid.conf \
78 ${sysconfdir}/default \
79 ${sysconfdir}/dbus-1 \
80 ${base_sbindir}/hciattach \
81 "
82
83FILES_${PN}-dbg += " \
84 ${libdir}/bluetooth/.debug \
85 ${libdir}/cups/backend/.debug \
86 ${libdir}/alsa-lib/.debug \
87 "
88
89FILES_${PN}-compat = " \
90 ${base_bindir}/sdptool \
91 ${base_bindir}/dund \
92 ${base_bindir}/rctest \
93 ${base_bindir}/ciptool \
94 ${base_bindir}/l2test \
95 ${base_bindir}/rfcomm \
96 ${base_bindir}/hcitool \
97 ${base_bindir}/pand \
98 ${base_bindir}/hidd \
99 ${base_bindir}/l2ping \
100 ${base_sbindir}/hciconfig \
101 ${base_sbindir}/bccmd \
102 ${base_sbindir}/hciemu \
103 ${base_sbindir}/hid2hci \
104 ${base_bindir}/passkey-agent \
105 ${sysconfdir}/bluetooth/rfcomm.conf \
106 "
107