summaryrefslogtreecommitdiffstats
path: root/meta/packages/binutils
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-02-11 09:51:23 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2010-02-11 09:51:23 +0000
commit633e0ff5e3d7a3bd7ca874a3f399e8670553e4cd (patch)
tree3ec7389bd3d74c75d4071b70ff793709ae940c6c /meta/packages/binutils
parent6877acce5a4a1793de418d2b1377b115d1ce66f9 (diff)
downloadpoky-633e0ff5e3d7a3bd7ca874a3f399e8670553e4cd.tar.gz
binutils: Apply cross compiling changes to libtool since we don't autoreconf
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/binutils')
-rw-r--r--meta/packages/binutils/binutils-2.19/libtool.patch69
-rw-r--r--meta/packages/binutils/binutils_2.19.bb3
2 files changed, 71 insertions, 1 deletions
diff --git a/meta/packages/binutils/binutils-2.19/libtool.patch b/meta/packages/binutils/binutils-2.19/libtool.patch
new file mode 100644
index 0000000000..81289f3006
--- /dev/null
+++ b/meta/packages/binutils/binutils-2.19/libtool.patch
@@ -0,0 +1,69 @@
1A command like /bin/sh ../../i586-poky-linux-libtool --mode=install /usr/bin/install -c gck-roots-store-standalone.la '/media/data1/builds/poky1/tmp/work/core2-poky-linux/gnome-keyring-2.26.1-r1/image/usr/lib/gnome-keyring/standalone/' fails (e.g. gnome-keyring or pulseaudio)
2
3This is because libdir has a trailing slash which breaks the comparision.
4
5RP 2/1/10
6
7Index: binutils-2.19/ltmain.sh
8===================================================================
9--- binutils-2.19.orig/ltmain.sh 2007-05-25 20:56:24.000000000 +0100
10+++ binutils-2.19/ltmain.sh 2010-02-10 22:49:07.191629027 +0000
11@@ -2320,8 +2320,12 @@
12 dir="$dir$objdir"
13
14 if test -n "$relink_command"; then
15+ # Strip any trailing slash from the destination.
16+ func_stripname '' '/' "$libdir"
17+ destlibdir=$func_stripname_result
18+
19 # Determine the prefix the user has applied to our future dir.
20- inst_prefix_dir=`$ECHO "X$destdir" | $Xsed -e "s%$libdir\$%%"`
21+ inst_prefix_dir=`$ECHO "X$destdir" | $Xsed -e "s%$destlibdir\$%%"`
22
23 # Don't allow the user to place us outside of our expected
24 # location b/c this prevents finding dependent libraries that
25@@ -3958,8 +3962,14 @@
26 absdir="$abs_ladir"
27 libdir="$abs_ladir"
28 else
29- dir="$libdir"
30- absdir="$libdir"
31+ # Adding 'libdir' from the .la file to our library search paths
32+ # breaks crosscompilation horribly. We cheat here and don't add
33+ # it, instead adding the path where we found the .la. -CL
34+ dir="$abs_ladir"
35+ absdir="$abs_ladir"
36+ libdir="$abs_ladir"
37+ #dir="$libdir"
38+ #absdir="$libdir"
39 fi
40 test "X$hardcode_automatic" = Xyes && avoidtemprpath=yes
41 else
42@@ -4329,8 +4339,6 @@
43 add="$libdir/$linklib"
44 fi
45 else
46- # We cannot seem to hardcode it, guess we'll fake it.
47- add_dir="-L$libdir"
48 # Try looking first in the location we're being installed to.
49 if test -n "$inst_prefix_dir"; then
50 case $libdir in
51@@ -4478,7 +4486,17 @@
52 fi
53 ;;
54 *)
55- path="-L$absdir/$objdir"
56+ # OE sets installed=no in staging. We need to look in $objdir and $absdir,
57+ # preferring $objdir. RP 31/04/2008
58+ if test -f "$absdir/$objdir/$depdepl" ; then
59+ depdepl="$absdir/$objdir/$depdepl"
60+ path="-L$absdir/$objdir"
61+ elif test -f "$absdir/$depdepl" ; then
62+ depdepl="$absdir/$depdepl"
63+ path="-L$absdir"
64+ else
65+ path="-L$absdir/$objdir"
66+ fi
67 ;;
68 esac
69 else
diff --git a/meta/packages/binutils/binutils_2.19.bb b/meta/packages/binutils/binutils_2.19.bb
index bd03b4d39c..65a6aa102c 100644
--- a/meta/packages/binutils/binutils_2.19.bb
+++ b/meta/packages/binutils/binutils_2.19.bb
@@ -1,4 +1,4 @@
1PR = "r0" 1PR = "r1"
2 2
3require binutils.inc 3require binutils.inc
4 4
@@ -11,6 +11,7 @@ SRC_URI = "\
11 file://binutils-uclibc-300-006_better_file_error.patch;patch=1 \ 11 file://binutils-uclibc-300-006_better_file_error.patch;patch=1 \
12 file://binutils-uclibc-300-012_check_ldrunpath_length.patch;patch=1 \ 12 file://binutils-uclibc-300-012_check_ldrunpath_length.patch;patch=1 \
13 file://binutils-uclibc-gas-needs-libm.patch;patch=1 \ 13 file://binutils-uclibc-gas-needs-libm.patch;patch=1 \
14 file://libtool.patch;patch=1 \
14 " 15 "
15 16
16# powerpc patches 17# powerpc patches