summaryrefslogtreecommitdiffstats
path: root/meta/packages/binutils
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-09-16 14:05:04 +0000
committerRichard Purdie <richard@openedhand.com>2006-09-16 14:05:04 +0000
commit0eadb89687b68244df3dd4a74d32a4e6b492cd53 (patch)
tree6bdf83cacb5842c5dc130ef95a961a83ec413cc9 /meta/packages/binutils
parent3ea4918a0a8d6091845bdd3258a213dccfea8c62 (diff)
downloadpoky-0eadb89687b68244df3dd4a74d32a4e6b492cd53.tar.gz
binutils-2.15: Add update from OE to allow correct operation with gcc 4.x (requested by zecke)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@721 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/binutils')
-rw-r--r--meta/packages/binutils/binutils-2.15.94.0.1/binutils-2.15-allow-gcc-4.0.patch75
-rw-r--r--meta/packages/binutils/binutils_2.15.94.0.1.bb6
2 files changed, 78 insertions, 3 deletions
diff --git a/meta/packages/binutils/binutils-2.15.94.0.1/binutils-2.15-allow-gcc-4.0.patch b/meta/packages/binutils/binutils-2.15.94.0.1/binutils-2.15-allow-gcc-4.0.patch
new file mode 100644
index 0000000000..26e5a12116
--- /dev/null
+++ b/meta/packages/binutils/binutils-2.15.94.0.1/binutils-2.15-allow-gcc-4.0.patch
@@ -0,0 +1,75 @@
1Fix found here: http://www.freelists.org/archives/openbeos/11-2005/msg00090.html
2
3Fixes:
4In file included from ./targ-cpu.h:1,
5 from /home/dank/crosstool-new/build/i686-unknown-linux-gnu/gcc-2.95.3-glibc-2.2.2/binutils-2.15/gas/config/obj-elf.h:42,
6 from ./obj-format.h:1,
7 from /home/dank/crosstool-new/build/i686-unknown-linux-gnu/gcc-2.95.3-glibc-2.2.2/binutils-2.15/gas/config/te-linux.h:4,
8 from ./targ-env.h:1,
9 from /home/dank/crosstool-new/build/i686-unknown-linux-gnu/gcc-2.95.3-glibc-2.2.2/binutils-2.15/gas/as.h:626,
10 from /home/dank/crosstool-new/build/i686-unknown-linux-gnu/gcc-2.95.3-glibc-2.2.2/binutils-2.15/gas/app.c:30:
11/home/dank/crosstool-new/build/i686-unknown-linux-gnu/gcc-2.95.3-glibc-2.2.2/binutils-2.15/gas/config/tc-i386.h:451: error: array type has incomplete element type
12make[3]: *** [app.o] Error 1
13make[3]: Leaving directory `/home/dank/crosstool-new/build/i686-unknown-linux-gnu/gcc-2.95.3-glibc-2.2.2/build-binutils/gas'
14
15when building binutils-2.15 with gcc-4.0
16
17
18diff -ur binutils-2.15.old/gas/as.h binutils-2.15/gas/as.h
19--- binutils-2.15.old/gas/as.h 2003-11-22 18:14:21.000000000 -0800
20+++ binutils-2.15/gas/as.h 2006-02-14 22:05:35.000000000 -0800
21@@ -605,7 +605,26 @@
22 struct expressionS;
23 struct fix;
24 typedef struct symbol symbolS;
25-struct relax_type;
26+
27+/* JF moved this here from as.h under the theory that nobody except MACHINE.c
28+ and write.c care about it anyway. */
29+/* [zooey]: the above no longer holds with gcc4, as it keeps bugging about
30+ incomplete element types in arrays, if relax_type isn't defined
31+ here. So I moved the definition back from tc.h to here. */
32+struct relax_type
33+{
34+ /* Forward reach. Signed number. > 0. */
35+ long rlx_forward;
36+ /* Backward reach. Signed number. < 0. */
37+ long rlx_backward;
38+
39+ /* Bytes length of this address. */
40+ unsigned char rlx_length;
41+
42+ /* Next longer relax-state. 0 means there is no 'next' relax-state. */
43+ relax_substateT rlx_more;
44+};
45+
46 typedef struct frag fragS;
47
48 #ifdef BFD_ASSEMBLER
49diff -ur binutils-2.15.old/gas/tc.h binutils-2.15/gas/tc.h
50--- binutils-2.15.old/gas/tc.h 2003-12-03 15:39:38.000000000 -0800
51+++ binutils-2.15/gas/tc.h 2006-02-14 22:03:35.000000000 -0800
52@@ -24,23 +24,6 @@
53
54 extern const pseudo_typeS md_pseudo_table[];
55
56-/* JF moved this here from as.h under the theory that nobody except MACHINE.c
57- and write.c care about it anyway. */
58-
59-struct relax_type
60-{
61- /* Forward reach. Signed number. > 0. */
62- long rlx_forward;
63- /* Backward reach. Signed number. < 0. */
64- long rlx_backward;
65-
66- /* Bytes length of this address. */
67- unsigned char rlx_length;
68-
69- /* Next longer relax-state. 0 means there is no 'next' relax-state. */
70- relax_substateT rlx_more;
71-};
72-
73 typedef struct relax_type relax_typeS;
74
75 extern const int md_reloc_size; /* Size of a relocation record */
diff --git a/meta/packages/binutils/binutils_2.15.94.0.1.bb b/meta/packages/binutils/binutils_2.15.94.0.1.bb
index 2b2996abe6..43ac3db2ae 100644
--- a/meta/packages/binutils/binutils_2.15.94.0.1.bb
+++ b/meta/packages/binutils/binutils_2.15.94.0.1.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.gnu.org/software/binutils/"
3SECTION = "devel" 3SECTION = "devel"
4LICENSE = "GPL" 4LICENSE = "GPL"
5MAINTAINER = "Gerald Britton <gbritton@doomcom.org>" 5MAINTAINER = "Gerald Britton <gbritton@doomcom.org>"
6PR = "r2" 6PR = "r3"
7 7
8inherit autotools gettext 8inherit autotools gettext
9 9
@@ -45,8 +45,8 @@ SRC_URI = \
45 file://objdump_fix.patch;patch=1 \ 45 file://objdump_fix.patch;patch=1 \
46 file://binutils-100_cflags_for_build.patch;patch=1 \ 46 file://binutils-100_cflags_for_build.patch;patch=1 \
47 file://binutils-2.15.91.0.1-uclibc-100-conf.patch;patch=1 \ 47 file://binutils-2.15.91.0.1-uclibc-100-conf.patch;patch=1 \
48 file://binutils-2.15.90.0.3-uclibc-200-build_modules.patch;patch=1" 48 file://binutils-2.15.90.0.3-uclibc-200-build_modules.patch;patch=1 \
49 49 file://binutils-2.15-allow-gcc-4.0.patch;patch=1"
50S = "${WORKDIR}/binutils-${PV}" 50S = "${WORKDIR}/binutils-${PV}"
51B = "${S}/build.${HOST_SYS}.${TARGET_SYS}" 51B = "${S}/build.${HOST_SYS}.${TARGET_SYS}"
52 52