summaryrefslogtreecommitdiffstats
path: root/meta/packages/binutils/binutils-2.20.1
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2010-08-13 17:08:19 -0700
committerSaul Wold <Saul.Wold@intel.com>2010-08-13 17:19:16 -0700
commitbfaeda03beeaae3ba265632f0bcfa3354e55766a (patch)
treec28f242e630250bee7ffc867546cc1e2a304b3dd /meta/packages/binutils/binutils-2.20.1
parent8c498e5338cfcbf97a4b6a0064e45ed2b755b25d (diff)
downloadpoky-bfaeda03beeaae3ba265632f0bcfa3354e55766a.tar.gz
binutils: fix the installed location of libiberty.a file
This fixes: [BUGID #209] the libiberty was getting installed in usr/lib/lib64 path which was leaving prelink-native recipe wondering where to get libiberty. Fix the path and prelink-native recipe is building fine now. Patch added: libiberty_path_fix.patch
Diffstat (limited to 'meta/packages/binutils/binutils-2.20.1')
-rw-r--r--meta/packages/binutils/binutils-2.20.1/libiberty_path_fix.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/packages/binutils/binutils-2.20.1/libiberty_path_fix.patch b/meta/packages/binutils/binutils-2.20.1/libiberty_path_fix.patch
new file mode 100644
index 0000000000..36a14d7a18
--- /dev/null
+++ b/meta/packages/binutils/binutils-2.20.1/libiberty_path_fix.patch
@@ -0,0 +1,20 @@
1don't let the distro compiler point to the wrong installation location
2
3Thanks to RP for helping find the source code causing the issue.
4
52010/08/13
6Nitin A Kamble <nitin.a.kamble@intel.com>
7Index: binutils-2.20.1/libiberty/Makefile.in
8===================================================================
9--- binutils-2.20.1.orig/libiberty/Makefile.in
10+++ binutils-2.20.1/libiberty/Makefile.in
11@@ -327,7 +327,8 @@ install: install_to_$(INSTALL_DEST) inst
12 # multilib-specific flags, it's overridden by FLAGS_TO_PASS from the
13 # default multilib, so we have to take CFLAGS into account as well,
14 # since it will be passed the multilib flags.
15-MULTIOSDIR = `$(CC) $(CFLAGS) -print-multi-os-directory`
16+#MULTIOSDIR = `$(CC) $(CFLAGS) -print-multi-os-directory`
17+MULTIOSDIR = ""
18 install_to_libdir: all
19 ${mkinstalldirs} $(DESTDIR)$(libdir)/$(MULTIOSDIR)
20 $(INSTALL_DATA) $(TARGETLIB) $(DESTDIR)$(libdir)/$(MULTIOSDIR)/$(TARGETLIB)n