diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2010-08-27 15:14:24 +0100 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-08-27 15:29:45 +0100 |
commit | 29d6678fd546377459ef75cf54abeef5b969b5cf (patch) | |
tree | 8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/packages/automake | |
parent | da49de6885ee1bc424e70bc02f21f6ab920efb55 (diff) | |
download | poky-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz |
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things
and is generally overwhelming. This commit splits it into several
logical sections roughly based on function, recipes.txt gives more
information about the classifications used.
The opportunity is also used to switch from "packages" to "recipes"
as used in OpenEmbedded as the term "packages" can be confusing to
people and has many different meanings.
Not all recipes have been classified yet, this is just a first pass
at separating things out. Some packages are moved to meta-extras as
they're no longer actively used or maintained.
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/automake')
-rw-r--r-- | meta/packages/automake/automake.inc | 13 | ||||
-rw-r--r-- | meta/packages/automake/automake/path_prog_fixes.patch | 67 | ||||
-rw-r--r-- | meta/packages/automake/automake_1.11.1.bb | 41 |
3 files changed, 0 insertions, 121 deletions
diff --git a/meta/packages/automake/automake.inc b/meta/packages/automake/automake.inc deleted file mode 100644 index d68c45d4f7..0000000000 --- a/meta/packages/automake/automake.inc +++ /dev/null | |||
@@ -1,13 +0,0 @@ | |||
1 | DESCRIPTION = "A tool for automatically generating Makefiles." | ||
2 | LICENSE = "GPLv2" | ||
3 | HOMEPAGE = "http://www.gnu.org/software/automake/" | ||
4 | SECTION = "devel" | ||
5 | PR = "r1" | ||
6 | |||
7 | SRC_URI = "${GNU_MIRROR}/automake/automake-${PV}.tar.bz2 " | ||
8 | |||
9 | inherit autotools | ||
10 | |||
11 | export AUTOMAKE = "${@bb.which('automake', bb.data.getVar('PATH', d, 1))}" | ||
12 | |||
13 | FILES_${PN} += "${datadir}/automake* ${datadir}/aclocal*" | ||
diff --git a/meta/packages/automake/automake/path_prog_fixes.patch b/meta/packages/automake/automake/path_prog_fixes.patch deleted file mode 100644 index fb38442e30..0000000000 --- a/meta/packages/automake/automake/path_prog_fixes.patch +++ /dev/null | |||
@@ -1,67 +0,0 @@ | |||
1 | --- | ||
2 | Makefile.am | 3 ++- | ||
3 | Makefile.in | 3 ++- | ||
4 | aclocal.in | 4 ++-- | ||
5 | automake.in | 6 ++++-- | ||
6 | 4 files changed, 10 insertions(+), 6 deletions(-) | ||
7 | |||
8 | Index: automake-1.10.1/Makefile.am | ||
9 | =================================================================== | ||
10 | --- automake-1.10.1.orig/Makefile.am 2008-01-21 22:28:58.000000000 +0000 | ||
11 | +++ automake-1.10.1/Makefile.am 2008-10-10 17:21:20.000000000 +0100 | ||
12 | @@ -75,7 +75,8 @@ | ||
13 | -e 's,[@]SHELL[@],$(SHELL),g' \ | ||
14 | -e 's,[@]VERSION[@],$(VERSION),g' \ | ||
15 | -e 's,[@]configure_input[@],Generated from $@.in; do not edit by hand.,g' \ | ||
16 | - -e 's,[@]datadir[@],$(datadir),g' | ||
17 | + -e 's,[@]datadir[@],$(datadir),g' \ | ||
18 | + -e 's,[@]bindir[@],$(bindir),g' | ||
19 | |||
20 | ## These files depend on Makefile so they are rebuilt if $(VERSION), | ||
21 | ## $(datadir) or other do_subst'ituted variables change. | ||
22 | Index: automake-1.10.1/Makefile.in | ||
23 | =================================================================== | ||
24 | --- automake-1.10.1.orig/Makefile.in 2008-01-21 22:29:10.000000000 +0000 | ||
25 | +++ automake-1.10.1/Makefile.in 2008-10-10 17:22:21.000000000 +0100 | ||
26 | @@ -185,7 +185,8 @@ | ||
27 | -e 's,[@]SHELL[@],$(SHELL),g' \ | ||
28 | -e 's,[@]VERSION[@],$(VERSION),g' \ | ||
29 | -e 's,[@]configure_input[@],Generated from $@.in; do not edit by hand.,g' \ | ||
30 | - -e 's,[@]datadir[@],$(datadir),g' | ||
31 | + -e 's,[@]datadir[@],$(datadir),g' \ | ||
32 | + -e 's,[@]bindir[@],$(bindir),g' | ||
33 | |||
34 | WGET = wget | ||
35 | WGET_SV_CVS = $(WGET) http://savannah.gnu.org/cgi-bin/viewcvs/~checkout~/ | ||
36 | Index: automake-1.10.1/aclocal.in | ||
37 | =================================================================== | ||
38 | --- automake-1.10.1.orig/aclocal.in 2008-01-21 22:11:41.000000000 +0000 | ||
39 | +++ automake-1.10.1/aclocal.in 2008-10-10 17:21:20.000000000 +0100 | ||
40 | @@ -1,8 +1,8 @@ | ||
41 | -#!@PERL@ -w | ||
42 | +#!@bindir@/env perl | ||
43 | # -*- perl -*- | ||
44 | # @configure_input@ | ||
45 | |||
46 | -eval 'case $# in 0) exec @PERL@ -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac' | ||
47 | +eval 'case $# in 0) exec @bindir@/env perl -S "$0";; *) exec @bindir@/env perl -S "$0" "$@";; esac' | ||
48 | if 0; | ||
49 | |||
50 | # aclocal - create aclocal.m4 by scanning configure.ac | ||
51 | Index: automake-1.10.1/automake.in | ||
52 | =================================================================== | ||
53 | --- automake-1.10.1.orig/automake.in 2008-01-21 22:11:41.000000000 +0000 | ||
54 | +++ automake-1.10.1/automake.in 2008-10-10 17:21:20.000000000 +0100 | ||
55 | @@ -1,8 +1,10 @@ | ||
56 | -#!@PERL@ -w | ||
57 | +#!@bindir@/env perl | ||
58 | # -*- perl -*- | ||
59 | # @configure_input@ | ||
60 | |||
61 | -eval 'case $# in 0) exec @PERL@ -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac' | ||
62 | +use warnings; | ||
63 | + | ||
64 | +eval 'case $# in 0) exec @bindir@/env perl -S "$0";; *) exec @bindir@/env perl -S "$0" "$@";; esac' | ||
65 | if 0; | ||
66 | |||
67 | # automake - create Makefile.in from Makefile.am | ||
diff --git a/meta/packages/automake/automake_1.11.1.bb b/meta/packages/automake/automake_1.11.1.bb deleted file mode 100644 index a78b6901f1..0000000000 --- a/meta/packages/automake/automake_1.11.1.bb +++ /dev/null | |||
@@ -1,41 +0,0 @@ | |||
1 | require automake.inc | ||
2 | |||
3 | DEPENDS_virtclass-native = "autoconf-native" | ||
4 | |||
5 | RDEPENDS_automake += "\ | ||
6 | autoconf \ | ||
7 | perl \ | ||
8 | perl-module-bytes \ | ||
9 | perl-module-constant \ | ||
10 | perl-module-cwd \ | ||
11 | perl-module-data-dumper \ | ||
12 | perl-module-dynaloader \ | ||
13 | perl-module-errno \ | ||
14 | perl-module-exporter-heavy \ | ||
15 | perl-module-file-basename \ | ||
16 | perl-module-file-compare \ | ||
17 | perl-module-file-copy \ | ||
18 | perl-module-file-glob \ | ||
19 | perl-module-file-spec-unix \ | ||
20 | perl-module-file-stat \ | ||
21 | perl-module-getopt-long \ | ||
22 | perl-module-io \ | ||
23 | perl-module-io-file \ | ||
24 | perl-module-posix \ | ||
25 | perl-module-strict \ | ||
26 | perl-module-text-parsewords \ | ||
27 | perl-module-vars " | ||
28 | |||
29 | RDEPENDS_automake-native = "autoconf-native perl-native-runtime" | ||
30 | |||
31 | PATHFIXPATCH = "file://path_prog_fixes.patch;patch=1" | ||
32 | PATHFIXPATCH_virtclass-native = "" | ||
33 | |||
34 | SRC_URI += "${PATHFIXPATCH}" | ||
35 | |||
36 | do_install () { | ||
37 | oe_runmake 'DESTDIR=${D}' install | ||
38 | install -d ${D}${datadir} | ||
39 | } | ||
40 | |||
41 | BBCLASSEXTEND = "native" | ||