summaryrefslogtreecommitdiffstats
path: root/meta/packages/autoconf/autoconf-2.65/path_prog_fixes.patch
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-01-29 16:00:31 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2010-01-29 16:00:31 +0000
commit50d9304068e5ee151b2bc29e14adbfaabe203738 (patch)
tree368f60471b69077cfffe97097cbd08b863adda28 /meta/packages/autoconf/autoconf-2.65/path_prog_fixes.patch
parent4420ddc284b4eae1a6165de30de165347a03334c (diff)
downloadpoky-50d9304068e5ee151b2bc29e14adbfaabe203738.tar.gz
autoconf: 2.63 -> 2.65 (not default)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/autoconf/autoconf-2.65/path_prog_fixes.patch')
-rw-r--r--meta/packages/autoconf/autoconf-2.65/path_prog_fixes.patch126
1 files changed, 126 insertions, 0 deletions
diff --git a/meta/packages/autoconf/autoconf-2.65/path_prog_fixes.patch b/meta/packages/autoconf/autoconf-2.65/path_prog_fixes.patch
new file mode 100644
index 0000000000..f47b973ab6
--- /dev/null
+++ b/meta/packages/autoconf/autoconf-2.65/path_prog_fixes.patch
@@ -0,0 +1,126 @@
1Index: autoconf-2.63/bin/autoheader.in
2===================================================================
3--- autoconf-2.63.orig/bin/autoheader.in 2008-12-31 17:48:33.000000000 +0000
4+++ autoconf-2.63/bin/autoheader.in 2008-12-31 17:48:33.000000000 +0000
5@@ -1,8 +1,8 @@
6-#! @PERL@
7+#! @bindir@/env perl
8 # -*- Perl -*-
9 # @configure_input@
10
11-eval 'case $# in 0) exec @PERL@ -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
12+eval 'case $# in 0) exec @bindir@/env perl -S "$0";; *) exec @bindir@/env perl -S "$0" "$@";; esac'
13 if 0;
14
15 # autoheader -- create `config.h.in' from `configure.ac'
16Index: autoconf-2.63/bin/autom4te.in
17===================================================================
18--- autoconf-2.63.orig/bin/autom4te.in 2008-08-28 03:08:41.000000000 +0100
19+++ autoconf-2.63/bin/autom4te.in 2008-12-31 17:48:33.000000000 +0000
20@@ -1,8 +1,10 @@
21-#! @PERL@ -w
22+#! @bindir@/env perl
23 # -*- perl -*-
24 # @configure_input@
25
26-eval 'case $# in 0) exec @PERL@ -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
27+use warnings;
28+
29+eval 'case $# in 0) exec @bindir@/env perl -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
30 if 0;
31
32 # autom4te - Wrapper around M4 libraries.
33@@ -88,7 +90,7 @@
34 my $freeze = 0;
35
36 # $M4.
37-my $m4 = $ENV{"M4"} || '@M4@';
38+my $m4 = $ENV{"M4"} || '@bindir@/env m4';
39 # Some non-GNU m4's don't reject the --help option, so give them /dev/null.
40 fatal "need GNU m4 1.4 or later: $m4"
41 if system "$m4 --help </dev/null 2>&1 | grep reload-state >/dev/null";
42Index: autoconf-2.63/bin/autoreconf.in
43===================================================================
44--- autoconf-2.63.orig/bin/autoreconf.in 2008-12-31 17:48:33.000000000 +0000
45+++ autoconf-2.63/bin/autoreconf.in 2008-12-31 17:48:33.000000000 +0000
46@@ -1,8 +1,10 @@
47-#! @PERL@ -w
48+#! @bindir@/env perl
49 # -*- perl -*-
50 # @configure_input@
51
52-eval 'case $# in 0) exec @PERL@ -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
53+use warnings;
54+
55+eval 'case $# in 0) exec @bindir@/env perl -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
56 if 0;
57
58 # autoreconf - install the GNU Build System in a directory tree
59Index: autoconf-2.63/bin/autoscan.in
60===================================================================
61--- autoconf-2.63.orig/bin/autoscan.in 2008-08-28 03:08:10.000000000 +0100
62+++ autoconf-2.63/bin/autoscan.in 2008-12-31 17:48:33.000000000 +0000
63@@ -1,4 +1,4 @@
64-#! @PERL@ -w
65+#! @bindir@/env perl
66 # -*- perl -*-
67 # @configure_input@
68
69@@ -23,7 +23,9 @@
70
71 # Written by David MacKenzie <djm@gnu.ai.mit.edu>.
72
73-eval 'case $# in 0) exec @PERL@ -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
74+use warnings;
75+
76+eval 'case $# in 0) exec @bindir@/env perl -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
77 if 0;
78
79 BEGIN
80Index: autoconf-2.63/bin/autoupdate.in
81===================================================================
82--- autoconf-2.63.orig/bin/autoupdate.in 2008-08-28 03:08:10.000000000 +0100
83+++ autoconf-2.63/bin/autoupdate.in 2008-12-31 17:48:33.000000000 +0000
84@@ -1,4 +1,4 @@
85-#! @PERL@ -w
86+#! @bindir@/env perl
87 # -*- perl -*-
88 # @configure_input@
89
90@@ -24,7 +24,9 @@
91 # Originally written by David MacKenzie <djm@gnu.ai.mit.edu>.
92 # Rewritten by Akim Demaille <akim@freefriends.org>.
93
94-eval 'case $# in 0) exec @PERL@ -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
95+use warnings;
96+
97+eval 'case $# in 0) exec @bindir@/env perl -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
98 if 0;
99
100 BEGIN
101@@ -56,7 +58,7 @@
102 my @include = ('@datadir@');
103 my $force = 0;
104 # m4.
105-my $m4 = $ENV{"M4"} || '@M4@';
106+my $m4 = $ENV{"M4"} || '@bindir@/env m4';
107
108
109 # $HELP
110Index: autoconf-2.63/bin/ifnames.in
111===================================================================
112--- autoconf-2.63.orig/bin/ifnames.in 2008-08-28 03:08:10.000000000 +0100
113+++ autoconf-2.63/bin/ifnames.in 2008-12-31 17:48:33.000000000 +0000
114@@ -1,8 +1,10 @@
115-#! @PERL@ -w
116+#! @bindir@/env perl
117 # -*- perl -*-
118 # @configure_input@
119
120-eval 'case $# in 0) exec @PERL@ -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
121+use warnings;
122+
123+eval 'case $# in 0) exec @bindir@/env perl -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
124 if 0;
125
126 # ifnames - print the identifiers used in C preprocessor conditionals