diff options
author | Richard Purdie <richard@openedhand.com> | 2007-08-21 14:00:13 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2007-08-21 14:00:13 +0000 |
commit | 2075cb72ac072d658f68c15e1f0e1e41b1e96233 (patch) | |
tree | e13c6591b132cf6ed3faedff79ed4717a1d0767d /meta/packages/apt | |
parent | a4b8304b62d6bf4b522769d5d9283050a5e63f3c (diff) | |
download | poky-2075cb72ac072d658f68c15e1f0e1e41b1e96233.tar.gz |
apt: Add db/db-native as a DEPENDS so apt-ftparchive gets built (needed by deb rootfs creation
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2531 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/apt')
-rw-r--r-- | meta/packages/apt/apt-native.inc | 6 | ||||
-rw-r--r-- | meta/packages/apt/apt-native_0.7.2.bb | 1 | ||||
-rw-r--r-- | meta/packages/apt/apt-native_0.7.3.bb | 2 | ||||
-rw-r--r-- | meta/packages/apt/apt.inc | 2 | ||||
-rw-r--r-- | meta/packages/apt/files/db_linking_hack.patch | 27 |
5 files changed, 34 insertions, 4 deletions
diff --git a/meta/packages/apt/apt-native.inc b/meta/packages/apt/apt-native.inc index 942f4991d3..75cd8f47cd 100644 --- a/meta/packages/apt/apt-native.inc +++ b/meta/packages/apt/apt-native.inc | |||
@@ -1,11 +1,13 @@ | |||
1 | require apt.inc | 1 | require apt.inc |
2 | inherit native | 2 | inherit native |
3 | 3 | ||
4 | DEPENDS += "dpkg-native curl-native" | 4 | DEPENDS += "dpkg-native curl-native db-native" |
5 | FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/apt-${PV}" | 5 | FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/apt-${PV}" |
6 | PACKAGES = "" | 6 | PACKAGES = "" |
7 | USE_NLS = "no" | 7 | USE_NLS = "no" |
8 | 8 | ||
9 | SRC_URI += "file://db_linking_hack.patch;patch=1" | ||
10 | |||
9 | python do_stage () { | 11 | python do_stage () { |
10 | bb.build.exec_func('do_stage_base', d) | 12 | bb.build.exec_func('do_stage_base', d) |
11 | bb.build.exec_func('do_stage_config', d) | 13 | bb.build.exec_func('do_stage_config', d) |
@@ -35,7 +37,7 @@ do_stage_base () { | |||
35 | install -m 0755 bin/apt-get ${bindir}/ | 37 | install -m 0755 bin/apt-get ${bindir}/ |
36 | install -m 0755 bin/apt-config ${bindir}/ | 38 | install -m 0755 bin/apt-config ${bindir}/ |
37 | install -m 0755 bin/apt-cache ${bindir}/ | 39 | install -m 0755 bin/apt-cache ${bindir}/ |
38 | 40 | install -m 0755 bin/apt-ftparchive ${bindir}/ | |
39 | install -m 0755 bin/apt-sortpkgs ${bindir}/ | 41 | install -m 0755 bin/apt-sortpkgs ${bindir}/ |
40 | install -m 0755 bin/apt-extracttemplates ${bindir}/ | 42 | install -m 0755 bin/apt-extracttemplates ${bindir}/ |
41 | 43 | ||
diff --git a/meta/packages/apt/apt-native_0.7.2.bb b/meta/packages/apt/apt-native_0.7.2.bb index 43f73889f7..3342618aa9 100644 --- a/meta/packages/apt/apt-native_0.7.2.bb +++ b/meta/packages/apt/apt-native_0.7.2.bb | |||
@@ -1,4 +1,5 @@ | |||
1 | require apt-native.inc | 1 | require apt-native.inc |
2 | PR = "r1" | ||
2 | 3 | ||
3 | SRC_URI += "file://nodoc.patch;patch=1 \ | 4 | SRC_URI += "file://nodoc.patch;patch=1 \ |
4 | file://noconfigure.patch;patch=1" | 5 | file://noconfigure.patch;patch=1" |
diff --git a/meta/packages/apt/apt-native_0.7.3.bb b/meta/packages/apt/apt-native_0.7.3.bb index 3342618aa9..6db567f987 100644 --- a/meta/packages/apt/apt-native_0.7.3.bb +++ b/meta/packages/apt/apt-native_0.7.3.bb | |||
@@ -1,5 +1,5 @@ | |||
1 | require apt-native.inc | 1 | require apt-native.inc |
2 | PR = "r1" | 2 | PR = "r2" |
3 | 3 | ||
4 | SRC_URI += "file://nodoc.patch;patch=1 \ | 4 | SRC_URI += "file://nodoc.patch;patch=1 \ |
5 | file://noconfigure.patch;patch=1" | 5 | file://noconfigure.patch;patch=1" |
diff --git a/meta/packages/apt/apt.inc b/meta/packages/apt/apt.inc index 6c9632e8ff..92507be188 100644 --- a/meta/packages/apt/apt.inc +++ b/meta/packages/apt/apt.inc | |||
@@ -1,7 +1,7 @@ | |||
1 | DESCRIPTION = "Advanced front-end for dpkg." | 1 | DESCRIPTION = "Advanced front-end for dpkg." |
2 | LICENSE = "GPL" | 2 | LICENSE = "GPL" |
3 | SECTION = "base" | 3 | SECTION = "base" |
4 | DEPENDS = "curl" | 4 | DEPENDS = "curl db" |
5 | RDEPENDS = "dpkg" | 5 | RDEPENDS = "dpkg" |
6 | 6 | ||
7 | SRC_URI = "${DEBIAN_MIRROR}/main/a/apt/apt_${PV}.tar.gz \ | 7 | SRC_URI = "${DEBIAN_MIRROR}/main/a/apt/apt_${PV}.tar.gz \ |
diff --git a/meta/packages/apt/files/db_linking_hack.patch b/meta/packages/apt/files/db_linking_hack.patch new file mode 100644 index 0000000000..3c8368b1ed --- /dev/null +++ b/meta/packages/apt/files/db_linking_hack.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | Index: apt-0.7.3/configure.in | ||
2 | =================================================================== | ||
3 | --- apt-0.7.3.orig/configure.in 2007-07-01 10:38:45.000000000 +0000 | ||
4 | +++ apt-0.7.3/configure.in 2007-08-21 13:39:26.000000000 +0000 | ||
5 | @@ -67,8 +67,20 @@ | ||
6 | [AC_DEFINE(HAVE_BDB) | ||
7 | BDBLIB="-ldb" | ||
8 | AC_MSG_RESULT(yes)], | ||
9 | - [BDBLIB="" | ||
10 | - AC_MSG_RESULT(no)] | ||
11 | + | ||
12 | + LIBS="$LIBS -lpthread" | ||
13 | + [AC_MSG_CHECKING(if we can link against BerkeleyDB with pthread) | ||
14 | + AC_LINK_IFELSE( | ||
15 | + [AC_LANG_PROGRAM( | ||
16 | + [#include <db.h>], | ||
17 | + [int r, s, t; db_version(&r, &s, &t);] | ||
18 | + )], | ||
19 | + [AC_DEFINE(HAVE_BDB) | ||
20 | + BDBLIB="-ldb -lpthread" | ||
21 | + AC_MSG_RESULT(yes)], | ||
22 | + [BDBLIB="" | ||
23 | + AC_MSG_RESULT(no)] | ||
24 | + )] | ||
25 | )] | ||
26 | ) | ||
27 | |||