diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2009-11-19 13:45:01 +0000 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2009-11-19 13:45:01 +0000 |
commit | a6f36aedaf399b52ef2af07ee5429ce4d68a2649 (patch) | |
tree | 9b5399c123cd35644a1eaf1e8bc952bc5aa4299b /meta/packages/apt | |
parent | 24f0ecbb14e5b6e4ab21fdc5def50b8a1f3f9bc4 (diff) | |
download | poky-a6f36aedaf399b52ef2af07ee5429ce4d68a2649.tar.gz |
apt: Stage include headers in do_install and drop custom staging function
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/apt')
-rw-r--r-- | meta/packages/apt/apt-package.inc | 3 | ||||
-rw-r--r-- | meta/packages/apt/apt_0.7.14.bb | 10 |
2 files changed, 3 insertions, 10 deletions
diff --git a/meta/packages/apt/apt-package.inc b/meta/packages/apt/apt-package.inc index 43f54cadab..9e104f12ed 100644 --- a/meta/packages/apt/apt-package.inc +++ b/meta/packages/apt/apt-package.inc | |||
@@ -98,4 +98,7 @@ do_install () { | |||
98 | install -d ${D}${localstatedir}/cache/apt/archives/partial | 98 | install -d ${D}${localstatedir}/cache/apt/archives/partial |
99 | install -d ${D}${docdir}/apt/examples | 99 | install -d ${D}${docdir}/apt/examples |
100 | install -m 0644 doc/examples/* ${D}${docdir}/apt/examples/ | 100 | install -m 0644 doc/examples/* ${D}${docdir}/apt/examples/ |
101 | |||
102 | install -d ${D}${includedir}/apt-pkg/ | ||
103 | install -m 0644 include/apt-pkg/*.h ${D}${includedir}/apt-pkg/ | ||
101 | } | 104 | } |
diff --git a/meta/packages/apt/apt_0.7.14.bb b/meta/packages/apt/apt_0.7.14.bb index efd7ab3bc5..1a9cf3602d 100644 --- a/meta/packages/apt/apt_0.7.14.bb +++ b/meta/packages/apt/apt_0.7.14.bb | |||
@@ -12,13 +12,3 @@ require apt-package.inc | |||
12 | FILES_${PN} += "${bindir}/apt-key" | 12 | FILES_${PN} += "${bindir}/apt-key" |
13 | apt-manpages += "doc/apt-key.8" | 13 | apt-manpages += "doc/apt-key.8" |
14 | 14 | ||
15 | do_stage() { | ||
16 | install -d ${STAGING_LIBDIR} ${STAGING_INCDIR}/apt-pkg | ||
17 | eval `cat environment.mak | grep ^GLIBC_VER | sed -e's, = ,=,'` | ||
18 | oe_libinstall -so -C bin libapt-pkg$GLIBC_VER-6 ${STAGING_LIBDIR}/ | ||
19 | ln -sf libapt-pkg$GLIBC_VER-6.so ${STAGING_LIBDIR}/libapt-pkg.so | ||
20 | oe_libinstall -so -C bin libapt-inst$GLIBC_VER-6 ${STAGING_LIBDIR}/ | ||
21 | ln -sf libapt-inst$GLIBC_VER-6.so ${STAGING_LIBDIR}/libapt-inst.so | ||
22 | |||
23 | install -m 0644 include/apt-pkg/*.h ${STAGING_INCDIR}/apt-pkg/ | ||
24 | } | ||