diff options
author | Chris Larson <kergoth@openedhand.com> | 2006-09-19 09:04:09 +0000 |
---|---|---|
committer | Chris Larson <kergoth@openedhand.com> | 2006-09-19 09:04:09 +0000 |
commit | 4fa2d11bb1fdb58ff426114169583672fc3d65b8 (patch) | |
tree | 0bd4952bbe057c3dc219be7e371a6a9d496c6535 /meta/packages/apt | |
parent | 04f695333350e31fa87b7822c17a073af73fcd84 (diff) | |
download | poky-4fa2d11bb1fdb58ff426114169583672fc3d65b8.tar.gz |
Sync up.. all the deb/dpkg changes which I have locally are now in svn.
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@728 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/apt')
-rw-r--r-- | meta/packages/apt/apt-0.6.45exp2/noconfigure.patch | 35 | ||||
-rw-r--r-- | meta/packages/apt/apt-native.inc | 56 | ||||
-rw-r--r-- | meta/packages/apt/apt-native_0.6.45exp2.bb | 3 | ||||
-rw-r--r-- | meta/packages/apt/files/apt.conf | 16 |
4 files changed, 82 insertions, 28 deletions
diff --git a/meta/packages/apt/apt-0.6.45exp2/noconfigure.patch b/meta/packages/apt/apt-0.6.45exp2/noconfigure.patch new file mode 100644 index 0000000000..682a96da24 --- /dev/null +++ b/meta/packages/apt/apt-0.6.45exp2/noconfigure.patch | |||
@@ -0,0 +1,35 @@ | |||
1 | --- | ||
2 | apt-pkg/packagemanager.cc | 4 ++++ | ||
3 | 1 file changed, 4 insertions(+) | ||
4 | |||
5 | --- apt-0.6.45exp2.orig/apt-pkg/packagemanager.cc | ||
6 | +++ apt-0.6.45exp2/apt-pkg/packagemanager.cc | ||
7 | @@ -534,10 +534,12 @@ bool pkgPackageManager::SmartUnPack(PkgI | ||
8 | |||
9 | List->Flag(Pkg,pkgOrderList::UnPacked,pkgOrderList::States); | ||
10 | |||
11 | +#if 0 | ||
12 | // Perform immedate configuration of the package. | ||
13 | if (List->IsFlag(Pkg,pkgOrderList::Immediate) == true) | ||
14 | if (SmartConfigure(Pkg) == false) | ||
15 | return _error->Error("Internal Error, Could not perform immediate configuration (2) on %s",Pkg.Name()); | ||
16 | +#endif | ||
17 | |||
18 | return true; | ||
19 | } | ||
20 | @@ -609,6 +611,7 @@ pkgPackageManager::OrderResult pkgPackag | ||
21 | DoneSomething = true; | ||
22 | } | ||
23 | |||
24 | +#if 0 | ||
25 | // Final run through the configure phase | ||
26 | if (ConfigureAll() == false) | ||
27 | return Failed; | ||
28 | @@ -623,6 +626,7 @@ pkgPackageManager::OrderResult pkgPackag | ||
29 | return Failed; | ||
30 | } | ||
31 | } | ||
32 | +#endif | ||
33 | |||
34 | return Completed; | ||
35 | } | ||
diff --git a/meta/packages/apt/apt-native.inc b/meta/packages/apt/apt-native.inc index 4ace9e94bb..de9426bf70 100644 --- a/meta/packages/apt/apt-native.inc +++ b/meta/packages/apt/apt-native.inc | |||
@@ -19,39 +19,43 @@ python do_stage_config () { | |||
19 | 19 | ||
20 | data = bb.data.expand(data, d) | 20 | data = bb.data.expand(data, d) |
21 | 21 | ||
22 | outpath = bb.data.expand('${STAGING_DIR}/${sysconfdir}/apt.conf', d) | 22 | outdir = os.path.join(bb.data.getVar('sysconfdir', d, 1), 'apt') |
23 | if not os.path.exists(outdir): | ||
24 | os.makedirs(outdir) | ||
25 | outpath = os.path.join(outdir, 'apt.conf') | ||
26 | |||
23 | outfile = file(outpath, 'w') | 27 | outfile = file(outpath, 'w') |
24 | outfile.write(data) | 28 | outfile.write(data) |
25 | outfile.close() | 29 | outfile.close() |
26 | } | 30 | } |
27 | 31 | ||
28 | do_stage_base () { | 32 | do_stage_base () { |
29 | install -d ${STAGING_BINDIR} | 33 | install -d ${bindir} |
30 | install -m 0755 bin/apt-cdrom ${STAGING_BINDIR}/ | 34 | install -m 0755 bin/apt-cdrom ${bindir}/ |
31 | install -m 0755 bin/apt-get ${STAGING_BINDIR}/ | 35 | install -m 0755 bin/apt-get ${bindir}/ |
32 | install -m 0755 bin/apt-config ${STAGING_BINDIR}/ | 36 | install -m 0755 bin/apt-config ${bindir}/ |
33 | install -m 0755 bin/apt-cache ${STAGING_BINDIR}/ | 37 | install -m 0755 bin/apt-cache ${bindir}/ |
34 | 38 | ||
35 | install -m 0755 bin/apt-sortpkgs ${STAGING_BINDIR}/ | 39 | install -m 0755 bin/apt-sortpkgs ${bindir}/ |
36 | install -m 0755 bin/apt-extracttemplates ${STAGING_BINDIR}/ | 40 | install -m 0755 bin/apt-extracttemplates ${bindir}/ |
37 | 41 | ||
38 | eval `cat environment.mak | grep ^GLIBC_VER | sed -e's, = ,=,'` | 42 | eval `cat environment.mak | grep ^GLIBC_VER | sed -e's, = ,=,'` |
39 | oe_libinstall -so -C bin libapt-pkg$GLIBC_VER-6 ${STAGING_LIBDIR}/ | 43 | oe_libinstall -so -C bin libapt-pkg$GLIBC_VER-6 ${libdir}/ |
40 | ln -sf libapt-pkg$GLIBC_VER-6.so ${STAGING_LIBDIR}/libapt-pkg.so | 44 | ln -sf libapt-pkg$GLIBC_VER-6.so ${libdir}/libapt-pkg.so |
41 | oe_libinstall -so -C bin libapt-inst$GLIBC_VER-6 ${STAGING_LIBDIR}/ | 45 | oe_libinstall -so -C bin libapt-inst$GLIBC_VER-6 ${libdir}/ |
42 | ln -sf libapt-inst$GLIBC_VER-6.so ${STAGING_LIBDIR}/libapt-inst.so | 46 | ln -sf libapt-inst$GLIBC_VER-6.so ${libdir}/libapt-inst.so |
43 | 47 | ||
44 | install -d ${STAGING_LIBDIR}/apt/methods | 48 | install -d ${libdir}/apt/methods |
45 | install -m 0755 bin/methods/* ${STAGING_LIBDIR}/apt/methods/ | 49 | install -m 0755 bin/methods/* ${libdir}/apt/methods/ |
46 | 50 | ||
47 | install -d ${STAGING_LIBDIR}/dpkg/methods/apt | 51 | install -d ${libdir}/dpkg/methods/apt |
48 | install -m 0644 dselect/desc.apt ${STAGING_LIBDIR}/dpkg/methods/apt/ | 52 | install -m 0644 dselect/desc.apt ${libdir}/dpkg/methods/apt/ |
49 | install -m 0644 dselect/names ${STAGING_LIBDIR}/dpkg/methods/apt/ | 53 | install -m 0644 dselect/names ${libdir}/dpkg/methods/apt/ |
50 | install -m 0755 dselect/install ${STAGING_LIBDIR}/dpkg/methods/apt/ | 54 | install -m 0755 dselect/install ${libdir}/dpkg/methods/apt/ |
51 | install -m 0755 dselect/setup ${STAGING_LIBDIR}/dpkg/methods/apt/ | 55 | install -m 0755 dselect/setup ${libdir}/dpkg/methods/apt/ |
52 | install -m 0755 dselect/update ${STAGING_LIBDIR}/dpkg/methods/apt/ | 56 | install -m 0755 dselect/update ${libdir}/dpkg/methods/apt/ |
53 | 57 | ||
54 | install -d ${STAGING_DIR}${sysconfdir}/apt | 58 | install -d ${sysconfdir}/apt |
55 | install -d ${STAGING_DIR}${localstatedir}/lib/apt/lists/partial | 59 | install -d ${localstatedir}/lib/apt/lists/partial |
56 | install -d ${STAGING_DIR}${localstatedir}/cache/apt/archives/partial | 60 | install -d ${localstatedir}/cache/apt/archives/partial |
57 | } | 61 | } |
diff --git a/meta/packages/apt/apt-native_0.6.45exp2.bb b/meta/packages/apt/apt-native_0.6.45exp2.bb index 32f19e8e4c..43f73889f7 100644 --- a/meta/packages/apt/apt-native_0.6.45exp2.bb +++ b/meta/packages/apt/apt-native_0.6.45exp2.bb | |||
@@ -1,3 +1,4 @@ | |||
1 | require apt-native.inc | 1 | require apt-native.inc |
2 | 2 | ||
3 | SRC_URI += "file://nodoc.patch;patch=1" | 3 | SRC_URI += "file://nodoc.patch;patch=1 \ |
4 | file://noconfigure.patch;patch=1" | ||
diff --git a/meta/packages/apt/files/apt.conf b/meta/packages/apt/files/apt.conf index 944233c347..37785871db 100644 --- a/meta/packages/apt/files/apt.conf +++ b/meta/packages/apt/files/apt.conf | |||
@@ -3,7 +3,7 @@ Dir "${STAGING_DIR}/" | |||
3 | State "var/lib/apt/" | 3 | State "var/lib/apt/" |
4 | { | 4 | { |
5 | Lists "lists/"; | 5 | Lists "lists/"; |
6 | status "${IMAGE_ROOTFS}/${localstatedir}/lib/dpkg/status"; | 6 | status "${IMAGE_ROOTFS}/var/dpkg/status"; |
7 | }; | 7 | }; |
8 | Cache "var/cache/apt/" | 8 | Cache "var/cache/apt/" |
9 | { | 9 | { |
@@ -22,3 +22,17 @@ Dir "${STAGING_DIR}/" | |||
22 | apt-cache "apt-cache"; | 22 | apt-cache "apt-cache"; |
23 | }; | 23 | }; |
24 | }; | 24 | }; |
25 | |||
26 | APT | ||
27 | { | ||
28 | Immediate-Configure "false"; | ||
29 | Architecture "i586"; | ||
30 | Get | ||
31 | { | ||
32 | Assume-Yes "true"; | ||
33 | Force-Yes "true" | ||
34 | }; | ||
35 | }; | ||
36 | |||
37 | DPkg::Options {"--root=${IMAGE_ROOTFS}";"--admindir=${IMAGE_ROOTFS}/var/dpkg";"--force-all";"--no-debsig"}; | ||
38 | }; | ||