summaryrefslogtreecommitdiffstats
path: root/meta/packages/apt
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-06-25 15:26:54 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-06-25 15:26:54 +0000
commitbcfd6c036238b4e194460b6e48b9b4dc48de34ed (patch)
treecd9694a5ed9ab50a5ec423c19946af50dba8d62e /meta/packages/apt
parent1d73583a583288fb6c772b55320e304a893896bc (diff)
downloadpoky-bcfd6c036238b4e194460b6e48b9b4dc48de34ed.tar.gz
apt: unbreak host checking
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4729 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/apt')
-rw-r--r--meta/packages/apt/apt-0.7.14/nodoc.patch10
-rw-r--r--meta/packages/apt/apt-0.7.14/use-host.patch44
-rw-r--r--meta/packages/apt/apt.inc5
3 files changed, 54 insertions, 5 deletions
diff --git a/meta/packages/apt/apt-0.7.14/nodoc.patch b/meta/packages/apt/apt-0.7.14/nodoc.patch
index 9101847189..db8cf93717 100644
--- a/meta/packages/apt/apt-0.7.14/nodoc.patch
+++ b/meta/packages/apt/apt-0.7.14/nodoc.patch
@@ -2,9 +2,11 @@
2 Makefile | 2 +- 2 Makefile | 2 +-
3 1 file changed, 1 insertion(+), 1 deletion(-) 3 1 file changed, 1 insertion(+), 1 deletion(-)
4 4
5--- apt-0.6.45exp2.orig/Makefile 5--- apt-0.7.14.orig/Makefile
6+++ apt-0.6.45exp2/Makefile 6+++ apt-0.7.14/Makefile
7@@ -17,7 +17,7 @@ all headers library clean veryclean bina 7@@ -15,11 +15,11 @@ all headers library clean veryclean bina
8 $(MAKE) -C apt-inst $@
9 $(MAKE) -C methods $@
8 $(MAKE) -C cmdline $@ 10 $(MAKE) -C cmdline $@
9 $(MAKE) -C ftparchive $@ 11 $(MAKE) -C ftparchive $@
10 $(MAKE) -C dselect $@ 12 $(MAKE) -C dselect $@
@@ -13,3 +15,5 @@
13 $(MAKE) -C po $@ 15 $(MAKE) -C po $@
14 16
15 # Some very common aliases 17 # Some very common aliases
18 .PHONY: maintainer-clean dist-clean distclean pristine sanity
19 maintainer-clean dist-clean distclean pristine sanity: veryclean
diff --git a/meta/packages/apt/apt-0.7.14/use-host.patch b/meta/packages/apt/apt-0.7.14/use-host.patch
new file mode 100644
index 0000000000..894a697661
--- /dev/null
+++ b/meta/packages/apt/apt-0.7.14/use-host.patch
@@ -0,0 +1,44 @@
1---
2 buildlib/sizetable | 4 +++-
3 configure.in | 2 +-
4 2 files changed, 4 insertions(+), 2 deletions(-)
5
6--- apt-0.7.14.orig/buildlib/sizetable
7+++ apt-0.7.14/buildlib/sizetable
8@@ -9,16 +9,19 @@
9 #
10 # This is used primarily for the MD5 algorithm.
11 # The format is:-
12 # CPU endian sizeof: char, int, short, long
13 i386 little 1 4 2 4
14+i486 little 1 4 2 4
15+i586 little 1 4 2 4
16+i686 little 1 4 2 4
17 armeb big 1 4 2 4
18 arm little 1 4 2 4
19 alpha little 1 4 2 8
20 mipsel little 1 4 2 4
21 sparc big 1 4 2 4
22 sparc64 big 1 4 2 8
23 m68k big 1 4 2 4
24 powerpc big 1 4 2 4
25 mips big 1 4 2 4
26 hppa big 1 4 2 4
27-m32r big 1 4 2 4
28\ No newline at end of file
29+m32r big 1 4 2 4
30--- apt-0.7.14.orig/configure.in
31+++ apt-0.7.14/configure.in
32@@ -86,11 +86,11 @@ AC_SUBST(BDBLIB)
33 dnl Converts the ARCH to be something singular for this general CPU family
34 dnl This is often the dpkg architecture string.
35 dnl First check against the full canonical canoncial-system-type in $target
36 dnl and if that fails, just look for the cpu
37 AC_MSG_CHECKING(debian architecture)
38-archset="`dpkg-architecture -qDEB_HOST_ARCH`"
39+archset="`echo $host_alias|cut -d'-' -f1`"
40 if test "x$archset" = "x"; then
41 AC_MSG_ERROR([failed: use --host= or output from dpkg-architecture])
42 fi
43 AC_MSG_RESULT($archset)
44 AC_DEFINE_UNQUOTED(COMMON_ARCH,"$archset")
diff --git a/meta/packages/apt/apt.inc b/meta/packages/apt/apt.inc
index e42b63d22b..af08aa5d11 100644
--- a/meta/packages/apt/apt.inc
+++ b/meta/packages/apt/apt.inc
@@ -5,8 +5,9 @@ DEPENDS = "curl db"
5RDEPENDS = "dpkg" 5RDEPENDS = "dpkg"
6 6
7SRC_URI = "${DEBIAN_MIRROR}/main/a/apt/apt_${PV}.tar.gz \ 7SRC_URI = "${DEBIAN_MIRROR}/main/a/apt/apt_${PV}.tar.gz \
8 file://no-ko-translation.patch;patch=1 \ 8 file://no-ko-translation.patch;patch=1 \
9 " 9 file://use-host.patch;patch=1 \
10 "
10 11
11S = "${WORKDIR}/apt-${PV}" 12S = "${WORKDIR}/apt-${PV}"
12 13