summaryrefslogtreecommitdiffstats
path: root/meta/packages/apr
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-01-12 15:37:21 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2009-01-12 15:37:21 +0000
commita43863b7f126b4e4e9eae64c11b657ef9530e50a (patch)
treeb4fde6ff27b409c26e89ceda469ee27f3824799b /meta/packages/apr
parent669aeb73eb48b7b224b91e5108d8d736d9489cba (diff)
downloadpoky-a43863b7f126b4e4e9eae64c11b657ef9530e50a.tar.gz
apr: Remove workdir path references from installed apr files
Diffstat (limited to 'meta/packages/apr')
-rw-r--r--meta/packages/apr/apr-util_1.3.4.bb2
-rw-r--r--meta/packages/apr/apr/configfix.patch51
-rw-r--r--meta/packages/apr/apr_1.3.3.bb5
3 files changed, 55 insertions, 3 deletions
diff --git a/meta/packages/apr/apr-util_1.3.4.bb b/meta/packages/apr/apr-util_1.3.4.bb
index 590c22e882..2c9432a157 100644
--- a/meta/packages/apr/apr-util_1.3.4.bb
+++ b/meta/packages/apr/apr-util_1.3.4.bb
@@ -3,7 +3,7 @@ SECTION = "libs"
3DEPENDS = "apr expat gdbm" 3DEPENDS = "apr expat gdbm"
4LICENSE = "Apache License, Version 2.0" 4LICENSE = "Apache License, Version 2.0"
5 5
6PR = "r2" 6PR = "r3"
7 7
8SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.gz \ 8SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.gz \
9 file://configure_fixes.patch;patch=1" 9 file://configure_fixes.patch;patch=1"
diff --git a/meta/packages/apr/apr/configfix.patch b/meta/packages/apr/apr/configfix.patch
new file mode 100644
index 0000000000..ec46172c6d
--- /dev/null
+++ b/meta/packages/apr/apr/configfix.patch
@@ -0,0 +1,51 @@
1Index: apr-1.3.3/apr-config.in
2===================================================================
3--- apr-1.3.3.orig/apr-config.in 2009-01-12 15:16:31.000000000 +0000
4+++ apr-1.3.3/apr-config.in 2009-01-12 15:19:25.000000000 +0000
5@@ -152,14 +152,7 @@
6 flags="$flags $LDFLAGS"
7 ;;
8 --includes)
9- if test "$location" = "installed"; then
10 flags="$flags -I$includedir $EXTRA_INCLUDES"
11- elif test "$location" = "source"; then
12- flags="$flags -I$APR_SOURCE_DIR/include $EXTRA_INCLUDES"
13- else
14- # this is for VPATH builds
15- flags="$flags -I$APR_BUILD_DIR/include -I$APR_SOURCE_DIR/include $EXTRA_INCLUDES"
16- fi
17 ;;
18 --srcdir)
19 echo $APR_SOURCE_DIR
20@@ -181,29 +167,14 @@
21 exit 0
22 ;;
23 --link-ld)
24- if test "$location" = "installed"; then
25- ### avoid using -L if libdir is a "standard" location like /usr/lib
26- flags="$flags -L$libdir -l${APR_LIBNAME}"
27- else
28- ### this surely can't work since the library is in .libs?
29- flags="$flags -L$APR_BUILD_DIR -l${APR_LIBNAME}"
30- fi
31+ flags="$flags -l${APR_LIBNAME}"
32 ;;
33 --link-libtool)
34 # If the LA_FILE exists where we think it should be, use it. If we're
35 # installed and the LA_FILE does not exist, assume to use -L/-l
36 # (the LA_FILE may not have been installed). If we're building ourselves,
37 # we'll assume that at some point the .la file be created.
38- if test -f "$LA_FILE"; then
39- flags="$flags $LA_FILE"
40- elif test "$location" = "installed"; then
41- ### avoid using -L if libdir is a "standard" location like /usr/lib
42- # Since the user is specifying they are linking with libtool, we
43- # *know* that -R will be recognized by libtool.
44- flags="$flags -L$libdir -R$libdir -l${APR_LIBNAME}"
45- else
46- flags="$flags $LA_FILE"
47- fi
48+ flags="$flags ll${APR_LIBNAME}"
49 ;;
50 --shlib-path-var)
51 echo "$SHLIBPATH_VAR"
diff --git a/meta/packages/apr/apr_1.3.3.bb b/meta/packages/apr/apr_1.3.3.bb
index 3e23bcd878..ac25246bee 100644
--- a/meta/packages/apr/apr_1.3.3.bb
+++ b/meta/packages/apr/apr_1.3.3.bb
@@ -2,10 +2,11 @@ DESCRIPTION = "Apache Portable Runtime (APR) library"
2SECTION = "libs" 2SECTION = "libs"
3LICENSE = "Apache License, Version 2.0" 3LICENSE = "Apache License, Version 2.0"
4 4
5PR = "r0" 5PR = "r2"
6 6
7SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.bz2 \ 7SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.bz2 \
8 file://configure_fixes.patch;patch=1" 8 file://configure_fixes.patch;patch=1 \
9 file://configfix.patch;patch=1"
9 10
10inherit autotools lib_package binconfig 11inherit autotools lib_package binconfig
11 12